Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Brunolima077

Logica e programacao vetor

Recommended Posts

Boa tarde! Sou iniciante na area de T.I. minha professora passou esse exercicio e estou quebrando a cabeça! Alguém me ajuda por favor.. Isso é o que tenho pronto até o momento

 

var
nome, tipo : caracter
diarias : inteiro
vl_uni, vl_tot, vl_sub, vl_ger, consumo, taxa_servico : real
inicio
// Seção de Comandos
Escreval("***********************************")
Escreval("Diárias ***************************")
Escreval("Nome do Hóspede:                   ")
leia(nome)
Escreval("Tipo de Apartamento (Single/Duplo/Triplo/Triplo Casal/Quádruplo Casal):     ")
leia(tipo)
Escreval("Quantidade de Diárias:             ")
leia(diarias)
Escreval("Valor do Consumo Interno:          ")
leia(consumo)
//processamento
se tipo = "Single" então
   vl_uni <- 130
fimse
se tipo = "Duplo" então
   vl_uni <- 200
fimse
se tipo = "Triplo" então
   vl_uni <- 280
fimse
se tipo = "Triplo Casal" então
   vl_uni <- 280
fimse
se tipo = "Quádruplo Casal" então
   vl_uni <- 340
fimse
vl_tot <- vl_uni * diarias
vl_sub <- vl_tot + consumo
taxa_servico <- vl_sub/100
vl_ger <- vl_sub + taxa_servico
// saida
Escreval()
Escreval()
Escreval("***********************************")
Escreval("Diárias Calculadas ****************")
Escreval("Nome do Hóspede:                   ", nome)
Escreval("Tipo de Apartamento:     ", tipo)
Escreval("Quantidade de Diárias:             ", diarias)
Escreval("Valor Unitário:                    ",vl_uni)
Escreval("Valor Total:                       ", vl_tot)
Escreval("Valor do Consumo Interno:          ", consumo)
Escreval("SubTotal:                          ", vl_sub)
Escreval("Valor da Taxa de Serviço           ", taxa_servico)
Escreval("SubTotal:                          ", vl_ger)
fimalgoritmo

IMG_20160601_021747.jpg

Screenshot_20160601-021614.png

Screenshot_20160601-021728.png

Editado por dif
usar a tag CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Brunolima077,

 

As verificações feitas são baseadas na versão 3 (3.0.6.3) do VisualAlg. Não sei dizer se vale para qualquer versão.

 

1) Creio que você não pode usar uma variável com nomenclatura tipo, pois é uma palavra reservada do VisuAlg. Sugiro alterar para para por exemplo tipoAp.

 

2) O texto do tipo de apartamento ficou muito grande, aqui "bugou" na hora de ler os dados... inclusive no VisuAlg tem um linha vertical marcando o limite horizontal para usar como referência. Eu sugiro dividir em duas linhas ou mudar o texto mesmo.

 

3) Ao "selecionar" o tipo de apartamento lá nos se, por definição você terá que usar um se/senao, pois são proposições mutuamente exclusivas entre si, ou seja, se for uma coisa, não pode ser outra, logo não tem porque continuar verificando após ser uma... (vide diferença entre se e se/senao)

 

Por enquanto acho que é isso.

 

Por favor, dê uma verificada e tente ser mais específico onde está com dúvidas.

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • @Simon Viegas minha duvida esta no vetor não entendi muito bem como funciona, e me pede para armazenar em vetor os valores arrecadados por dia, com reserva, frigobar, massagem e lavanderia. Poderia me ajudar? Obrigado

     

     

    Editado por Brunolima077

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Brunolima077 Olá! Tudo bem? Me interessei pelo seu exercício, por gentileza qual o enunciado dele?

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • @mi2011

    O hotel “Bem Estar” precisa desenvolver um sistema para fazer a gestão de seu hotel. Os gestores do hotel especificaram que este sistema deverá compreender as seguintes funcionalidades:

    Acomodações, que gerencia a reserva dos hóspedes, o serviço de frigobar e alimentação oferecido pelo hotel;

    Serviços e facilidades, que gerencia os demais serviços e facilidades oferecidos pelo hotel: lavanderia, massagem.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @Brunolima077 Me diga uma coisa, você já aprendeu outros comandos como o escolha caso e o para faça  ou somente o se ?

    Editado por mi2011

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • algoritmo "semnome"
    // Função :
    // Autor :
    // Data : 31/05/2016
    // Seção de Declarações
    var
    
    nome:caracter
    i, data, diarias, adulto, crianca, apto, cama, consumo, agua, gas, refri, ceva, copa, cafe, croi, sanduba, sopa, fondue, lava, calca, lavapassa, camiseta:inteiro
    lavapassa1, camisa, lavapassa2, moleton, lavapassa3, jaqueta, lavapassa4, meia, lavapassa5, bermuda, lavapassa6, infantil, lavapassa7, terno, lavapassa8:inteiro
    paleto, lavapassa9, tenis, lavapassa10, sapato, lavapassa11, malha, lavapassa12, massagem, shiatsu, reflexo, drena:inteiro
    vl_uni, vl_tot: real
    
    
    inicio
    
    para i de 1 ate 30 faca
    
       escreval("HOTEL BEM ESTAR")
       escreval("")
       escreva("Nome do Cliente...: ")
       leia(nome)
       escreva("Data de entrada(digite sem espaços ou carcteres especiais)...: ")
       leia(data)
       escreva("Número de diárias............................................: ")
       leia(diarias)
       escreva("Número de adultos............................................: ")
       leia(adulto)
       escreva("Número de crianças...........................................: ")
       leia(crianca)
       escreva("Apto: 1)Single 2)Duplo 3)Triplo 4)Triplo Casal 5)Quadruplo Casal ")
       leia(apto)
       escreva("Cama extra(Válido para Ap Single, Duplo e Triplo): 1)Sim 2)Não ")
       leia(cama)
       escreva("Frigobar(bebidas)......: Houve consumo? 1)Sim 2)Não ")
       leia(consumo)
    
       se(consumo=1) então
          escreval("Bebidas(quantidade):")
          escreva("Água sem gás........: ")
          leia(agua)
          escreva("Água com gás........: ")
          leia(gas)
          escreva("Refri(lata).........: ")
          leia(refri)
          escreva("Cervaja(lata).......: ")
          leia(ceva)
       senao
          se(consumo=2)então
             escreval("Sem consumo de bebidas")
             escreval("")
          senao
             escreva("Erro:Responda 1 ou 2")
             escreval("")
          fimse
       fimse
    
       escreva("Alimentação(copa): Houve consumo? 1)Sim 2)Não ")
       leia(copa)
       se(copa=1)então
          escreval("Tipo de Alimentação(Qtdade):")
          escreva("Café da manhã...............: ")
          leia(cafe)
          escreva("Croissant...................: ")
          leia(croi)
          escreva("Sanduíche Natural...........: ")
          leia(sanduba)
          escreva("Sopa de legumes e carne.....: ")
          leia(sopa)
          escreva("Fondue......................: ")
          leia(fondue)
       senao
          se(copa=2)então
             escreval("Sem consumo na copa do hotel")
             escreval("")
          senao
             escreval("Erro:Responda 1 ou 2")
             escreval("")
          fimse
       fimse
    
       escreval("Lavanderia e Passadoria")
       escreva("Houve uso dos serviços? 1)Sim 2)Não ")
       leia(lava)
       se(lava=1)então
          escreval("Especifique o uso dos serviços:")
          escreva("Calças(qtdade).................: ")
          leia(calca)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa)
          escreva("Camisetas(qtdade)..............: ")
          leia(camiseta)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa1)
          escreva("Camisa social(qtdade)..........: ")
          leia(camisa)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa2)
          escreva("Moleton(qtdade)................: ")
          leia(moleton)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa3)
          escreva("Jaqueta(qtdade)................: ")
          leia(jaqueta)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa4)
          escreva("Meia/roupa íntima(qtdade/peças): ")
          leia(meia)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa5)
          escreva("Bermuda(qtdade)................: ")
          leia(Bermuda)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa6)
          escreva("Roupa infantil(qtdade).........: ")
          leia(infantil)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa7)
          escreva("Terno completo(qtdade).........: ")
          leia(terno)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa8)
          escreva("Paletó(qtdade).................: ")
          leia(paleto)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa9)
          escreva("Tênis(qtdade/pares)............: ")
          leia(tenis)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa10)
          escreva("Sapato(qtdade).................: ")
          leia(sapato)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa11)
          escreva("Malha de lã/Pullover(qtdade)...: ")
          leia(malha)
          escreva("1)Lavanderia 2)Lavanderia e Passadoria ")
          leia(lavapassa12)
       senao
          se(lava=2)então
             escreval("Sem utilização dos serviços de lavanderia e passaderia")
             escreval("")
          senao
             escreval("Erro:Responda 1 ou 2")
             escreval("")
          fimse
       fimse
    
       escreval("Serviços de Massagem")
       escreva("Utilizou serviços de massagem? 1)Sim 2)Não ")
       leia(massagem)
       se(massagem=1)então
          escreval("Quais serviços de massagem foram utilizados?")
          escreva("Shiatsu(qtdade/sessões)...........: ")
          leia(shiatsu)
          escreva("Reflexologia(qtdade/sessões)......: ")
          leia(reflexo)
          escreva("Drenagem Linfática(qtdade/sessões): ")
          leia(drena)
       senao
          se(massagem=2)então
             escreval("Não foram utilizados serviços de massagem")
             escreval("")
          senao
             escreval("Erro:Responda 1 ou 2")
             escreval("")
          fimse
       fimse
       se diarias < 5 então
          novadiaria <- diaria*5/100
       fimse
       se diarias = 5 e <= 10 então
          novadiaria2 <- diaria*3/100
       fimse
       se diarias > 10 então
          novadiaria3 <- diaria*1/100
       fimse
       se apto = 1 então
          vl_uni <- 130
       fimse
       se apto = 2 então
          vl_uni <- 200
       fimse
       se apto = 3 então
          vl_uni <- 280
       fimse
       se apto = 4 então
          vl_uni <- 280
       fimse
       se apto = 5 então
          vl_uni <- 340
       fimse
       vl_tot <- vl_uni * diarias
    
    fimpara
    //armazenar, em vetor, os valores arrecadados por dia, com a reserva, o frigobar, a lavanderia e a massagem;
    //verificar o valor arrecadado em acomodações em um determinado dia;
    vl_tot <- vl_uni * diarias
    //verificar o valor arrecadado no mês com acomodações;
    //verificar qual o dia de maior arrecadação em relação as acomodações;
    //verificar qual o serviço de maior arrecadação no mês.    .
    
    
    // Seção de Comandos
    fimalgoritmo

     

    Editado por dif
    usar o fórum para postar o código.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×