Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Nonu

VisualG Exercício CPF valido ou não. Sem caracpenum()

Recommended Posts

Fala galera, to com dificuldade para fazer um exercício, tenho q fazer um programa que diz se o CPF é valido ou não, mas sem usar o  caracpenum :tw_dissapointed:

Editado por Simon Viegas
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Nonu.

 

Faça o seguinte: crie um algoritmo que faz essa verificação de CPF usando o Caracpnum(). Poste seu código aqui, depois damos um jeito.

 

obs.: antes de postar um código no fórum, favor verificar postagem:

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • var
    cpf: caracter
    n_cpf:vetor[1..11] de inteiro
    soma1:vetor [1..9] de inteiro
    soma2:vetor[1..10] de inteiro
    s1:inteiro
    s2:inteiro
    x:inteiro
    resto1:inteiro
    resto2:inteiro
    inicio
    escreval("*******TESTE DE VALIDAÇÃO!*******")
    escreval("Digite o CPF:")
    leia(cpf)
    para x de 1 ate 11 faca
    n_cpf[x]:=caracpnum(copia(cpf,x,1))
    fimpara
    para x de 1 ate 9 faca
    soma1[x]:= n_cpf[x]*(11-x)
    s1:=s1+soma1[x]
    fimpara
    resto1:=s1 mod 11
    se (resto1<2) então
    resto1:=0
    senao
    resto1:= 11-resto1
    fimse
    para x de 1 ate 10 faca
    soma2[x]:= n_cpf[x]*(12-x)
    s2:=s2+soma2[x]
    fimpara
    resto2:=s2 mod 11
    se (resto2<2) então
    resto2:=0
    senao
    resto2:= 11-resto2
    fimse
    se(resto1=n_cpf[10])e (resto2=n_cpf[11])então
    escreva(cpf," Esse Cpf é Valido")
    senao
    escreva(cpf," Esse Cpf não é Valido!")
    fimse
    fimalgoritmo

     

    Editado por Nonu
    não botei em code
    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Olá @Nonu.

     

    Por favor, edite sua postagem seguindo a orientação:

    2 horas atrás, Simon Viegas disse:

    obs.: antes de postar um código no fórum, favor verificar postagem:

     

    No aguardo.

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • No botão code <> não aparece a opção visualg ou portugol.

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

     

     

     

     

    @EduardoS

     

    47 minutos atrás, Nonu disse:

    No botão code <> não aparece a opção visualg ou portugol.

     

    Use HTML mesmo..

     

     

     

    Para separar os dígitos, você pode usar a seguinte base lógica:

     

    Ou seja, com esse exemplo do @EduardoS, dá para ir "pegando" os números da direita para esquerda.

     

    No aguardo.

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • No botão code <> não aparece a opção visualg ou portugol.

     

    var
    cpf: caracter
    n_cpf:vetor[1..11] de inteiro
    soma1:vetor [1..9] de inteiro
    soma2:vetor[1..10] de inteiro
    s1:inteiro
    s2:inteiro
    x:inteiro
    resto1:inteiro
    resto2:inteiro
    inicio
    escreval("*******TESTE DE VALIDAÇÃO!*******")
    escreval("Digite o CPF:")
    leia(cpf)
    para x de 1 ate 11 faca
    n_cpf[x]:=caracpnum(copia(cpf,x,1))
    fimpara
    para x de 1 ate 9 faca
    soma1[x]:= n_cpf[x]*(11-x)
    s1:=s1+soma1[x]
    fimpara
    resto1:=s1 mod 11
    se (resto1<2) então
    resto1:=0
    senao
    resto1:= 11-resto1
    fimse
    para x de 1 ate 10 faca
    soma2[x]:= n_cpf[x]*(12-x)
    s2:=s2+soma2[x]
    fimpara
    resto2:=s2 mod 11
    se (resto2<2) então
    resto2:=0
    senao
    resto2:= 11-resto2
    fimse
    se(resto1=n_cpf[10])e (resto2=n_cpf[11])então
    escreva(cpf," Esse Cpf é Valido")
    senao
    escreva(cpf," Esse Cpf não é Valido!")
    fimse
    fimalgoritmo

     

    Editado por Nonu
    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×