Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
RomuloS

ajuda de sintaxe

Recommended Posts

Galera estou com difculdades para rodar esse algoritmo no visual g é um exercicio de um livro.

// Função :Calcular tempo decorrido

// Autor :RÕMULO

// Data : 11/1/2012

// Seção de Declarações

var;

min_i ,hora_i,hora_f,min_f,hora_d,min_d: inteiro

inicio

escreva ("digite o horario inicial:");//Esta dando erro de sintaxe nesta linha

escreva ("hora: ");

leia (hora_i);

escreva "digite os minutos iniciais"

leia (min_i);

escreva "digite o horario final"

escreva "hora: "

leia (hora_f);

escreva "minuto: "

leia (min_f)

se (min_i>min_f)

então inicio

min_f<-min_f+60

hora_f<-hora_f-1

fim

se (hora_i>hora_f)

então hora_f<-hora_f+24

min_d<-min_f_min_i;

hora_d<-hora_f-hora_i;

escreva "O jogo durou ",hora_d,"hora(s) e ",min_d,"minuto(s)"

fimalgoritmo

alguem pode me ajudar a resolver o problema da sintaxe?

Obrigado.

Editado por RomuloS
erro de digitação

Compartilhar este post


Link para o post
Compartilhar em outros sites

Comparando essa linha de escreva com as demais, a diferença são os parenteses. Retire e tente novamente. O correto seria usar os parenteses. Pode ser problema nas aspas, talvez aspas simples.

Compartilhar este post


Link para o post
Compartilhar em outros sites

@RomuloS: O problema deve ser esses pontos e vírgulas ";" que você usou no programa. Pelo rápido que pude observar, o Visualg não usa esse tipo de separador.

NW

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Agora parece estar dando erro na linha 32

    após a palavra chave fimalgoritmo

    O visual g passa a seguinte mensagem:

    "Esperava encontrar fimse na linha 32"

    O que sera que pode ser?

    algoritmo "semnome"

    // Função :

    // Autor :

    // Data : 11/1/2012

    // Seção de Declarações

    var;

    min_i ,hora_i,hora_f,min_f,hora_d,min_d: inteiro

    inicio

    escreva ("digite o horario inicial:")

    escreva ('hora: ');

    leia (hora_i)

    escreva ("digite os minutos iniciais")

    leia (min_i)

    escreva ("digite o horario final")

    escreva ("hora: ")

    leia (hora_f)

    escreva ("minuto: ")

    leia (min_f)

    se (min_i>min_f) então

    inicio

    min_f<-min_f+60

    hora_f<-hora_f-1

    fim

    se (hora_i>hora_f)

    então hora_f<-hora_f+24

    min_d<-min_f_min_i;

    hora_d<-hora_f-hora_i;

    escreva "O jogo durou ",hora_d,"hora(s) e ",min_d,"minuto(s)"

    fimalgoritmo

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Para cada se aberto, você vai precisar de um fimse.

    Exemplo:

    [B]se[/B] Valor > 10 [B]então[/B]
    escreva ("Valor maior que 10")
    Maior <- VERDADEIRO
    [B]fimse[/B]

    E outra, ainda tem ponto e vírgula no programa. Tem que tirar isso.

    NW

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×