Ir ao conteúdo
  • Cadastre-se

Recommended Posts

Aí pessoal me ajudem por favor

Elabore um algoritmo que receba um número inteiro de 4 algarismos (se o usuário informar errado, enviar mensagem e encerrar) e exiba se o algarismo da centena é par ou ímpar.

por enquanto fiz isso mas tá errado

var

n1:inteiro

n2:real

inicio

// Seção de Comandos

escreval("Digite um numero inteiro de 4 algarismo")

leia(n1)

n2 <- n1 / 100

se n2 mod 2 = 0 então

escreval("par")

senao

escreval("Impar")

fimse

Compartilhar este post


Link para o post
Compartilhar em outros sites

Adriano,

Aí pessoal me ajudem por favor

Elabore um algoritmo que receba um número inteiro de 4 algarismos (se o usuário informar errado, enviar mensagem e encerrar) e exiba se o algarismo da centena é par ou ímpar.

por enquanto fiz isso mas tá errado

A lógica do seu algoritmo está correta. O problema está na divisão. Você precisa apenas da parte inteira resultante da divisão. Exemplo:

1234 / 100 = 12,34

Aqui, você precisa apenas do valor 12. O Visualg oferece uma função para retornar apenas a parte inteira de um valor decimal: int()

Veja no exemplo abaixo sobre como usá-la. Declare duas variáveis inteiras, faça a divisão e atribua a parte inteira à variável d. Aí, basta fazer o teste para saber se o número em d é par ou não.

Falta também testar os valores aceitos pelo programa, ou seja, o valor não poderá ser menor que 1000 ou maior que 9999, certo? Basta adicionar esse teste.

var
d, n1 : inteiro

inicio

escreval("Digite um numero inteiro de 4 algarismo")
leia(n1)

d <- int(n1 / 100)

se d mod 2 = 0 então
escreval("par")
senao
escreval("impar")
fimse

fimalgoritmo

PS: O corretor ortográfico do fórum acaba corrigindo onde não deve. O comando então no código acima não é acentuado.

[]'s

LNW

Compartilhar este post


Link para o post
Compartilhar em outros sites

Me ajudem aí pessoal :

Leia 40 números inteiros (maiores que zero - fazer consistência),

calcule e apresente

a quantidade de pares e a quantidade de ímpares.

consegui fazer a metade tá dando um erro :

var

cont:inteiro

par,impar:real

inicio

para cont de 1 ate 40 faca

se cont mod 2 = 0 então

par <- cont + 1

senao

impar <- cont +1

fimse

fimpara

escreval(par)

escreval(impar)

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×