Ir ao conteúdo
  • Cadastre-se
Kelvim

FORMULA EXCEl

Recommended Posts

Boa tarde

Sou eu de novo gente.

Gostaria de saber se existe alguma formula que achasse qual o valor entre dois valores para dividir o terceiro em que o resultado fosse resto igual a zero EX:

A B C D

1 INICIO TERMINO Comprimento

2 25 45 300

3

A3=(comprimento / (algum valor entre A2;B2)), onde o resto seja 0 seja divisão exata.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Oi, Kelvim,

Se eu entendi corretamente o seu problema, você pode utilizar a função MOD.

MOD é uma função que, dado um dividendo e um divisor, retorna o resto.

Supondo-se a operação 8/2 (8 dividido por 2), MOD retornaria 0; na operação 8/3, retornaria 2.

Aplicando a função ao seu problema, a seguinte fórmula seria formada:

=SE(MOD(C2;A2)=0;C2/A2;SE(MOD(C2;B2)=0;C2/B2;"Nenhuma das divisões retorna um resto igual a 0."))

A fórmula acima verifica se o resto da divisão de C2 por A2 é zero e, caso positivo, realiza a divisão entre os números; caso negativo, verifica se o resto da divisão de C2 por B2 é zero e, caso positivo, divide os valores. Se nenhum dos valores for divisível por C2, a fórmula exibe uma mensagem dizendo que as divisões não apresentam um resto nulo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Boa noite

A formula e interessante, só que eu tenho o seguinte problema.

Eu tenho dois valores que são os extremos das minhas possibilidade.

Todos os números que estiverem entre os dois posso usar para dividir X, entretanto preciso descobrir qual valor entre estes dois numero me trará a divisão de X/Y=0

EX: A1 = 18,5

B2 = 19,5

Pode ser qualquer numero entre 18,5 e 19,5. Pode ser 18,75 e por ai vai.

Posso dividir EX: 300/18,75 = 16.

Este calculo eu fiz ele manualmente de uma forma meio louca mas queria uma formula que fizesse isso mais fácil

Compartilhar este post


Link para o post
Compartilhar em outros sites

Acredito que não exista uma fórmula específica para realizar o que você precisa, no entanto, você pode resolver o problema a partir de uma das (duas) soluções abaixo.

A primeira solução é criar uma função VBA, conforme abaixo.


Function DescobrirDivisor(min As Double, max As Double, _
dividendo As Double)
Dim divisor As Double
Dim quociente As Integer
divisor = dividendo
quociente = 2
Do While Not (divisor >= min And divisor <= max)
divisor = dividendo / quociente
quociente = quociente + 1
If divisor < min Then
Exit Do
End If
Loop
DescobrirDivisor = divisor
End Function

A função recebe três parâmetros: o menor número do intervalo, o maior número do mesmo intervalo e o dividendo.

Supondo-se que os seguintes valores foram passados, a função realiza o que é descrito abaixo.

- Menor: 18,5 (célula A1)

- Maior: 19,5 (célula B1)

- Dividendo: 900 (célula C1)

Observação: A função seria chamada conforme abaixo.

=DescobrirDivisor(A1;B1;C1)

O maior divisor possível para o dividendo informado é o próprio dividendo. O dividendo dividido por ele mesmo apresenta um quociente igual a 1 (900 / 900 = 1). Portanto, a primeira solução que a função encontra é:

- Divisor: 900

No entanto, 900 não está entre o intervalo informado. Portanto, a função encontra o próximo divisor que apresentaria o próximo menor quociente inteiro possível. Isto é realizado dividindo-se o dividendo pelo quociente.

Observação: O primeiro menor quociente inteiro possível é 1; o próximo, 2; o próximo, 3; o próximo, 4 e assim por diante.

- Divisor: 900 / 2 (quociente) = 450

Ainda assim, o divisor não está entre o intervalo informado, portanto, a função continua incrementando o quociente e calculando o divisor, até encontrar um valor que esteja entre os parâmetros menor e maior.

- Divisor: 900 / 3 = 300

- Divisor: 900 / 4 = 225

- Divisor: 900 / 5 = 180

- Divisor: 900 / 6 = 150

- Divisor: 900 / 7 = 128,571428571429

- Divisor: 900 / 8 = 112,5

- Divisor: 900 / 9 = 100

- Divisor: 900 / 10 = 90

[...]

- Divisor: 900 / 44 = 20,4545454545455

- Divisor: 900 / 45 = 20

- Divisor: 900 / 46 = 19,5652173913043

- Divisor: 900 / 47 = 19,148936170212765957446808510638 (este valor foi provavelmente arredondado)

Encontrado um valor que esteja dentro do intervalo informado, a função retorna-o. Caso não houver um divisor que produzirá uma divisão exata dentro do intervalo informado, a função retorna o próximo divisor encontrado após o menor valor. Abaixo, exemplo.

- Menor: 2,8

- Maior: 3,4

- Dividendo: 7

- Divisor: 7 / 2 = 3,5

- Divisor: 7 / 3 = 2,33333333333333

---

Caso você não queira utilizar uma função VBA, é possível utilizar as fórmulas abaixo e ir arrastando-as até encontrar o valor desejado.

Suponham-se as seguintes células e valores:

- A1: 18,5 (menor valor)

- B1: 19,5 (maior valor)

- C1: 900 (dividendo)

- D1: 1 (primeiro quociente inteiro)

Na célula C2, a seguinte fórmula deve ser adicionada:

=$C$1/D2

Na célula D2:

=D1+1

As fórmulas devem ser arrastadas na vertical, até que o valor desejado seja encontrado.

Para facilitar a visualização do resultado, você pode adicionar a seguinte fórmula na célula E1 e arrastá-la na vertical:

=SE(E(C1>=$A$1;C1<=$B$1);"Resultado encontrado";"")

Abaixo, exemplo dos resultados que podem ser obtidos com as fórmulas acima.

Linha 1 -> 18,500 | 19,500 | 900,00000 | 1 | (vazio)

Linha 2 -> (vazio) | (vazio) | 450,00000 | 2 | (vazio)

Linha 3 -> (vazio) | (vazio) | 300,00000 | 3 | (vazio)

Linha 4 -> (vazio) | (vazio) | 225,00000 | 4 | (vazio)

[...]

Linha 45 -> (vazio) | (vazio) | 20,00000 | 45 | (vazio)

Linha 46 -> (vazio) | (vazio) | 19,56521 | 46 | (vazio)

Linha 47 -> (vazio) | (vazio) | 19,14894 | 47 | Resultado encontrado

Linha 48 -> (vazio) | (vazio) | 18,75000 | 48 | Resultado encontrado

Linha 49 -> (vazio) | (vazio) | 18,36735 | 49 | (vazio)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×