Ir ao conteúdo
  • Cadastre-se

Problemas para compilar em C no Sublime


Mrcaio.

Posts recomendados

Olá a todos,

 

Estou sofrendo um pouco com o sublime na questão da linguagem C. Estou começando a aprender essa nova linguagem, e quando vou compilar o código sempre da erro:

 

[Decode error - output not utf-8]

 

Eu já salvei ele em utf-8 e é um código bem simples que estou reproduzindo para aprender a linguagem.

 

Grato.

Link para o comentário
Compartilhar em outros sites

@Mrcaio., @welber91

 

 

Vocês adicionaram o diretório do compilador (que contém o g++.exe) à variável de ambiente PATH (do usuário ou sistema)?

 

Eu não uso esse editor, mas acabei de baixar a versão portable para verificar esse problema. Aqui pude reproduzir o problema:

 

 

Sem adicionar o caminho do diretório à variável PATH:

 

subli.png

 

 

Após a inclusão:

 

 

subli2.png

 

 

E o executável é gerado...

 

 

No Windows:

 

Painel de Controle > Sistema e Segurança > Sistema > Configurações avançadas do sistema

 

clique em Variáveis de Ambiente...

 

 

Lá, você tem a opção de incluir o caminho à variável PATH do usuário ou do sistema.

 

 

 

Testem aí...

 

 

LNW

Link para o comentário
Compartilhar em outros sites

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...