Ir ao conteúdo
  • Cadastre-se
ilton710

RESOLVIDO O que há de errado com essas formulas

Recommended Posts

onde a formula teria que pegar os valores está vazio então fica difícil definir o que tem que aparecer e porque 

as formulas estão indicando  para retornar os valores D6  E5... e estão vazios

 

coloque valores fictícios nas posições  e fale o que teria que retomar com aqueles valores

 

 

 

em EY4 coloque essa formula e arraste para baixo

 

=VALOR($EU4&$EW4)

Compartilhar este post


Link para o post
Compartilhar em outros sites

é pelo visto você vai ter que aguardar alguém com mais experiência "ou mais inteligente que eu :P "

 

antes fazia mais sentido para mim

pelo menos ajudei em alguma coisa

 

 

 

Edit:

acho que já descobri o que tem de errado

 

a função menor

 

tipo ( 0, 1, 2, 3 )

menor(c:c;3) apresentaria 2

 

( 0, 0, 0, 0, 1, 2, 3 )

menor(c:c;3) apresentaria 0 porque o 3º numero menor da lista também é 0

 

creio que seja isso

Compartilhar este post


Link para o post
Compartilhar em outros sites

Infelizmente não é isso, os valores do menor para o maior são únicos. Quando aparece uma sequencia de qualquer numero repetido é porque a formula ainda não resolveu a questão. Mas grato pela colaboração.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Em    EY  onde a formula pega o MENOR valor não são valores únicos se repetem e muito

FA3=

=SEERRO(  MENOR($EY$4:$EY$243;  COLS($FA:FA)+CONT.SE(EZ3:$EZ3;EZ3));"")

EY4=

=VALOR($EU4&EW4)   <<<aqui você colocou a formula que indiquei para retornar valor numérico 

no lugar dessa que retornava valor em texto >>>   =EU4&""&EW4

 

Em EU e EW tem um monte de números que são da representação binária de ES

 

repare a sequencia de  EY  >>410, 14, 00, 70, 00, 00, 90, 70, 00, 00, 00,...  <<isso não são valores únicos. tem repetidos. e muitos

 

se a formula pega valor de EY que é a concatenação de EU e EW que por sua vez é a representação do valor em ES

 

você vai ter que criar uma coluna auxiliar com valores únicos de EY para a formula poder trabalhar corretamente

 

 

Edit:

 

Em EY5

 

coloque essa formula e arraste para baixo

 

=SE(CONT.SE(EY$4:EY4;VALOR($EU5&EW5))=0;VALOR($EU5&EW5);"")

 

deixe EY4 como está, assim a coluna EY vai retomar somente valores unicos e as outras formulas vão funcionar corretamente

 

se você tem formulas que usam os valores de cada linha da coluna EY vai ter que adicionar uma coluna auxiliar com os valores

Compartilhar este post


Link para o post
Compartilhar em outros sites

como falei coloque essa formula Em EY5 e arraste para baixo

 

ou crie outra coluna para formula de FA3

 

=SE(CONT.SE(EY$4:EY4;VALOR($EU5&EW5))=0;VALOR($EU5&EW5);"")

 

 

FA4 usa os valores repetidos de EY5 

 

FA3 precisa de valores únicos portanto você precisa de 2 colunas

 

FA4=SE(COLS($FA:FA)=CORRESP($EY4;$FA$3:$FT$3;0);$EY4;"")   <<<precisa dos valores das linhas de EY5


Fiz o sugerido mas o resultado não foi o esperado. Dê uma olhada em: http://www.sendspace.com/file/lhmydl

É o conjunto de formulas em FA3, que apresentam problemas. Com relação as repetições elas aparecem e não constituem "erro". É assim mesmo.

coloque essa formula em EX5

 

=SE(CONT.SE(EX$4:EX4;VALOR($EU5&EW5))=0;VALOR($EU5&EW5);"")

 

Arraste para baixo

 

Em FA3 coloque

 

=SEERRO(MENOR($EX$4:$EX$243;COLS($FA3:FA3)+CONT.SE(EZ3:$EZ3;EZ3));"")

 

Arraste para o lado

 

apresentou todos os valores menos o 10 do inicio depois do 0

 

 

COLS($FA3:FA3)+CONT.SE(EZ3:$EZ3;EZ3)

 

 

agora ve se me ajuda e apresenta mais detalhes e tira as formatações personalizadas e coloque a barra de rolagem de volta "nunca mexi nisso na minha então nao sei fazer :P"

Compartilhar este post


Link para o post
Compartilhar em outros sites

Meu caro edcronos, super grato pela colaboração. :D  O gtsalikis do Planilhando matou a questão.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×