Ir ao conteúdo
  • Cadastre-se
Lucas Oliveira_766736

Fazer um algoritmo que leia 5 grupos de 4 valores (A,B,C,D) e mostre-os na ordem lida. Em seguida, ordene-os em ordem decrescente e mostre-os novament

Recommended Posts

Fazer um algoritmo que leia 5 grupos de 4 valores (A,B,C,D) e mostre-os na ordem lida. Em seguida, ordene-os em ordem decrescente e mostre-os novamente, já ordenados (por grupo).

  Já fiz uma parte e acho q esta certo o problema, o problema e o final, já vi umas resoluções para este problema, porém, todos usam vetor  e matrizes e ainda não aprendi isto na faculdade, portanto gostaria que as respostas fossem com as instruções REPITA OU PARA OU ENQUANTO, segue abaixo  a maneiro q fiz o algoritmo:


 



var
x,a,b,c,d:inteiro
inicio
para x:= 1 ate 5 faca
leia (a,b,c,d)
escreval("Grupo",x,"=",A,B,C,D)
fimpara
para x:=5 ate 1 passo -1 faca
escreval("Grupo",x,"=",A,B,C,D)
fimpara
fimalgoritmo


Grupo 5= 17 18 19 20______
Grupo 5= 17 18 19 20      \
Grupo 4= 17 18 19 20         ==      ESTE E O ERRO DO MEU CODIGO
Grupo 3= 17 18 19 20         ==      OS GRUPOS ATE APARECEN EM ORDEM DESCRENTE 
Grupo 2= 17 18 19 20         ==      MAS TODOS SÃO IGUAIS AO GRUPO 5, EU QUERIA
Grupo 1= 17 18 19 20______/ Q OS GRUPOS FICASSEM SALVOS E DEPOIS EU PUDESSE
ESCREVE-LOS NO FINAL EM ORDEM DECRESCENTE

Fim da execução.



 

 

POR FAVOR ME A CORRIGIR O ERRO NA SAÍDA DO ALGORITMO

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ao invés de armazenar os grupos em variaveis, armazene em vetores. Ex:

 

Criação dos 5 grupos

vargrupo1:vet[1..4] de caractere;grupo2:vet[1..4] de caractere;grupo3:vet[1..4] de caractere;grupo4:vet[1..4] de caractere;grupo5:vet[1..4] de caractere;

Esses cinco grupo estão preparados para ler 4 letras(A,B,C e D) cada.

 

Leitura dos cinco grupos

//Leitura grupo 1para x:= 1 ate 4 faca                                                                                                                                                                                         escreval("Digite a letra do ",x,"º  grupo 1");     leia(grupo1[x]);  fimpara                                                                                                                                                                                                        //Leitura grupo 2para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 2");leia(grupo2[x]);fimpara                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
//Leitura grupo 3para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 3");leia(grupo3[x]);fimpara //Leitura grupo 4para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 4");leia(grupo4[x]);fimpara //Leitura grupo 5para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 5");leia(grupo5[x]);fimpara 

Seu programa já tem todos os grupos criados e armazena os valores deles cinco.


Por tanto só falta você imprimir os cinco grupos de forma comum que mostrará na ordem que eles formam lidos/armazenados e por fim fazer outra impressão com os valores em ordem decrescente(para isso você estará trabalhando com algo chamado de ordenação de vetores).


Obs: Peço desculpas ao moderador do grupo se coloquei uma resposta muito pronta.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ao invés de armazenar os grupos em variaveis, armazene em vetores. Ex:

 

Criação dos 5 grupos

vargrupo1:vet[1..4] de caractere;grupo2:vet[1..4] de caractere;grupo3:vet[1..4] de caractere;grupo4:vet[1..4] de caractere;grupo5:vet[1..4] de caractere;

Esses cinco grupo estão preparados para ler 4 letras(A,B,C e D) cada.

 

Leitura dos cinco grupos

//Leitura grupo 1para x:= 1 ate 4 faca                                                                                                                                                                                         escreval("Digite a letra do ",x,"º  grupo 1");     leia(grupo1[x]);  fimpara                                                                                                                                                                                                        //Leitura grupo 2para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 2");leia(grupo2[x]);fimpara                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                   
//Leitura grupo 3para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 3");leia(grupo3[x]);fimpara //Leitura grupo 4para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 4");leia(grupo4[x]);fimpara //Leitura grupo 5para x:= 1 ate 4 faca escreval("Digite a letra do ",x,"º grupo 5");leia(grupo5[x]);fimpara 

Seu programa já tem todos os grupos criados e armazena os valores deles cinco.

Por tanto só falta você imprimir os cinco grupos de forma comum que mostrará na ordem que eles formam lidos/armazenados e por fim fazer outra impressão com os valores em ordem decrescente(para isso você estará trabalhando com algo chamado de ordenação de vetores).

Obs: Peço desculpas ao moderador do grupo se coloquei uma resposta muito pronta.

 

 

Obrigado pelo resposta amigo, mas queria q fosse sem vetor, pois eu ainda nao aprendir sobre vetores na faculdade.

valeu

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×