Ir ao conteúdo
  • Cadastre-se

Ajuda Com Programação Em Java


Ir à solução Resolvido por Derfel,

Posts recomendados

Galera Só Novo aqui No Fórum E Esto Fazendo Um Curso De Java 

 

E vocês Dão Para Me Ajuda Com Esse Erro

algoritmo "Somadedoisnumeros;"// Função :// Autor :// Data : 20/07/2015// Seção de Declarações varnumero1: inteironumero2: inteirosoma: inteiroinicioEscreva (“ Informe um número: “);Escreva (“ Informe OUTRO  número: “);soma = numero1 + numero2;Leia (numero1);Leia (numero2);Escreva (“ O resultado da soma dos números informados é :” , soma);fimalgoritmo 

Ta Dando Erro De sintase Incorreta 

 

Link para o comentário
Compartilhar em outros sites

  • Solução

Os erros de sintaxe ocorrem quando o código está em desacordo com os padrões de escrita da linguagem. No caso do VisuAlg temos:

1)não é necessário colocar ;(ponto e virgula) após cada sentença e sim apenas pular de linha.

2)o comando de atribuição não é   =   e sim   <-

modificando isso os erros de sintaxe devem acabar.

 

Porém como foi pontuado por Math.Pi existem erros de lógica no algoritmo.

1)voce precisa primeiro ler os valores dos numeros para efetuar a soma.

2)Como recomendação seria legal voce ler o numero após cada pedido de escreva.

 

Segue abaixo uma versão funcional do código:

Algoritmo "somadedoisnumeros"// Disciplina  : [Linguagem e Lógica de Programação] // Professor(a): Antonio Carlos Nicolodi // Descrição   : Aqui você descreve o que o programa faz! (função)// Autor(a)    : Nome do(a) aluno(a)// Data atual  : 22/07/2015Var// Seção de Declarações das variáveis numero1:inteironumero2:inteirosoma:inteiroInicio// Seção de Comandos, procedimento, funções, operadores, etc... Escreva("Informe o primeiro numero: ")Leia(numero1)Escreva("Informe o segundo numero: ")Leia(numero2)soma <- numero1 + numero2Escreva("O resultado da soma é: ",soma)Fimalgoritmo

Recomendo dar uma lida em "A linguagem do VisuAlg" localizado dentro do proprio programa em HELP.

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Visitante
Este tópico está impedido de receber novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Ebook grátis: Aprenda a ler resistores e capacitores!

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!