Ir ao conteúdo
  • Cadastre-se
Lucas.Souza200

RESOLVIDO Vendas semanais - visualg

Recommended Posts

Olá. Estou cursando o primeiro semestre do curso técnico de T.I. e a professora de lógica passou o seguinte exercício:

Faça um programa que receba as vendas semanais (de um mês) de cinco vendedores de uma loja e armazene essas vendas em uma matriz. Calcule e mostre:

- o total de venda de cada vendedor;
- o total de cada semana (todos os vendedores juntos);
- o total de vendas do mês.

Acontece que eu só consigo fazer a primeira parte do código, que é a coleta de dados (quanto cada vendedor vendeu em cada semana do mês). Não faço a menor ideia de como devo prosseguir para mostrar o total de vendas de cada vendedor, o total de cada semana e o total do mês. Pensei em fazer com um contador, mas não deu certo. Abaixo está o código (a linguagem que estamos usando é o Portugol [VisualG]).

algoritmo "semnome"
// Função :
// Autor :
// Data : 26/05/2016
// Seção de Declarações
var
mVendas: vetor [1..4, 1..5] de inteiro
i, j, acum_vendas1: inteiro
inicio
para i de 1 ate 4 faca
   para j de 1 ate 5 faca
      escreva("Digite o número de vendas do", j, "º vendedor na", i, "ª semana do mês: ")
      leia(mVendas[i,j])
   fimpara
   limpatela
fimpara
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Lucas.Souza200
  você precisa colocar uma variável para cada vendedor, tipo v1 para o primeiro
vendedor até v5 para o quinto vendedor, aí colocar outros dois loops iguais a
estes, sem o escreva e o leia;  E dentro deles você faz a soma de cada vendedor,
sendo que o primeiro vendedor é mvendas[i,1], e o segundo é    mvendas[i,2],  e
aí vai .  assim:

acum_vendas1:=acum_vendas1+mvendas[i,j]
se j=1 então
  v1:=v1+mvendas[i,1]
fimse
se j=2 então
  v2:=v2+mvendas[i,2]
fimse

faça a mesma coisa para os outros vendedores, assim na saída dos loops você 
terá o total de vendas no mês de cada vendedor, aí escreva o total de cada 
vendedor na tela.
  E para o total de vendas no mês some o total de cada vendedor v1+v2...+v5

Aí depois do primeiro fimpara coloque assim:

  fimpara
  escreval("total de vendas da ",i,"ª semana ",acum_vendas1)
  acum_vendas1:=0
fimpara  

 

Editado por devair1010
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado, @devair1010. Fiz o que você disse e consegui concluir o exercício. O código final ficou assim:

algoritmo "Exercício 4"
// Função :
// Autor :
// Data : 26/05/2016
// Seção de Declarações
var
mVendas: vetor [1..4, 1..5] de inteiro
i, j, acum_vendas1, acum_vendasMes, v1, v2, v3, v4, v5: inteiro
inicio
para i de 1 ate 4 faca
   para j de 1 ate 5 faca
      escreva("Digite o número de vendas do", j, "º vendedor na", i, "ª semana do mês: ")
      leia(mVendas[i,j])
   fimpara
   limpatela
fimpara

para i de 1 ate 4 faca
   para j de 1 ate 5 faca
      acum_vendas1 <- acum_vendas1 + mVendas[i,j]
      se(j = 1)então
         v1 <- v1 + mVendas[i,1]
      fimse
      se(j = 2)então
         v2 <- v2 + mVendas[i,2]
      fimse
      se(j = 3)então
         v3 <- v3 + mVendas[i,3]
      fimse
      se(j = 4)então
         v4 <- v4 + mVendas[i,4]
      fimse
      se(j = 5)então
         v5 <- v5 + mVendas[i,5]
      fimse
   fimpara
   escreval("Total de vendas da",i,"ª semana:",acum_vendas1)
   acum_vendasMes <- acum_vendasMes + acum_vendas1
   acum_vendas1 <- 0
fimpara
Escreval("")
Escreval("O primeiro vendedor fez", v1," vendas.")
Escreval("O segundo vendedor fez", v2," vendas.")
Escreval("O terceiro vendedor fez", v3," vendas.")
Escreval("O quarto vendedor fez", v4," vendas.")
Escreval("O quinto vendedor fez", v5," vendas.")
Escreval("")
Escreval("Total de vendas no mês:", acum_vendasMes)
Escreva("")
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×