Ir ao conteúdo
  • Cadastre-se
Francisco Sancho

Algoritmo em portugol (.alg)

Recommended Posts

Pessoal, meu professor de programação pediu um trabalho pra gente, temos que desenvolver um jogo que se passe no brasil.

então, eu tentei criar algo como ... um simulador de brasileiro, até que é um joguinho simples, baseado em escolhas, mas estou tendo alguns problemas com o algoritmo. Alguém sabe como consertar esse erro?

1.png


 

algoritmo "Jogo De Escolhas, BraSim"
// Função : Criar um Simulador do Brasil para o Augusto jogar
// Autor : FranZ // LittleJimmy
// Data : 28/08/2016
// Seção de Declarações : Agradeço a Deus por me deixar viver pra fazer isso
var
nome:   caractere
cidade: caractere
escolhas: inteiro
dinheiro: inteiro
escolhas2: inteiro
escolhas3: inteiro
escolhas4: inteiro
inicio
// Identificação do personagem
escreval ("BEM VINDO AO SIMULADOR DE BRASIL v0.0.1 (Alpha)")
escreval ("OLÁ, EU SOU O BRASIM, UMA ENTIDADE GENÉTICA SUPERIOR")
escreval ("Humano, por favor, identifique-se")
escreval ( )
leia (nome)
escreval ( )
escreval("Então, seu nome será: " ,nome)
escreval ( )
escreval ("Humano, escolha uma dessas duas cidades")
escreval ("Acre (1), Ceará(2)")
leia (escolhas)
escreval ( )
se escolhas = 1 então
   escreva("Então, você " ,nome)
   escreval (" nasceu no Acre, na pacata cidade de Alagoinha")
   escreva("Como um bom jovem, de 21 anos ")
   escreval(" seu objetivo é se tornar bem sucedido na vida")
   escreval ( )
   escreval("-------------------SUA JORNADA COMEÇA AQUI-----------------------")
   escreval ( )
senao
   se escolhas = 2 então
      escreva ("Então, você " ,nome)
      escreval(" nasceu no Ceará, na pacata cidade de Senador Sá")
      escreva("Como um bom jovem, de 21 anos")
      escreval(" seu objetivo é se tornar bem sucedido na vida")
      escreval ( )
      escreval("----------------SUA JORNADA COMEÇA AQUI-----------------------")
      escreval ( )
   senao
      escreval ("Entenda, sou uma entidade genética superior, não um deus bondoso e paciente")
      escreval ("Reinicie e jogue pelas regras, ou então nem jogue")
   fimalgoritmo
fimse
fimse
// A Aventura se inicia
escreva ("Você Atualmente tem" ,dinheiro + 0)
escreval(" em dinheiro")
escreval ( )
escreval("Você está morrendo de fome, mas se quiser sair")
escreval ("Desse país tem que trabalhar")
escreval ("Deseja comer (1) ou ir trabalhar(2) ?")
leia (escolhas2)
escreval ( )
se escolhas2 = 1 então
escreval ("Você come um pedaço enorme de Pão Doce")
escreval ("Você sente que pode sobreviver mais um dia")
escreval ( )
senao
se escolhas2 = 2 então
   escreval ("Você vai pro trabalho sem comer nada")
   escreval ("Você tem um colapso durante o expediente")
   escreval ("Você morre")
fimalgoritmo
senao
escreval ("(CARA, SÉRIO QUE VOCÊ QUER ME TROLAR?)")
escreval ("Você tropeça e cai numa poça de ácido clorídrico")
escreval ("Por desrespeitar as regras do jogo, você morre, lenta e dolorasamente")
fimalgoritmo
//isso é só uma trollagem mesmo
fimse
fimse
escreval ("Uma passagem para países gringos custa 1500g")
escreval ("Você começará o seu novo emprego amanhã as 8:00 am.")
escreval ("está tarde, deseja sair(1) ou ir dormir? (2)")
leia (escolhas3)
se escolhas3 = 1 então
escreval ( )
escreval ("Você resolve dar uma caminhada ao ar livre")
escreval ("Você se depara com uma senhora idosa te pedindo ajuda pra atarvessar a rua")
escreval ("vai ajudar(1) ou deixar a senhora sofrer(2) ?")
leia (escolhas4)
se escolhas4 = 1 então
escreval ( )
escreval ("Quando você se aproxima a Velha saca uma arma e anuncia o assalto")
escreval ("Você não tem dinheiro")
escreval ("A velha te dá um tiro e dois chutes na costela")
escreval ("um morador chama o SAMU")
escreval ("você não tinha plano de saúde")
escreval ("os médicos te deixam morrer")
escreval ("Você morre")
fimalgoritmo
senao
se escolhas4 = 2 então
escreval ( )
escreval ("Você deixa a velha para trás, sofrendo com as dores da idade")
escreval ("Sua atitude egoísta atraiu uma má fama para a cidade")
escreval ("Seus pais ficam sabendo disso e te renegam como filho")
escreval ("você entra em depressão profunda e se mata")
fimalgoritmo
senao
se escolhas3 = 2 então
escreval ( )
escreval ("você se deita na cama")
escreval ("Você sonha com um lindo futuro, com um bom emprego e uma linda familia")
escreval ("Você tem uma ótima noite de soono")
escreval ("--------------------- Fim do 1º dia ----------------------------------)
senao
escreval ("Eu odeio babacas como você")
escreval ("Você tropeça e cai num bueiro")
escreval ("Você descobre que a lenda do RATOzomem era real")
escreval ("Você é devorado por Igor, o ratozomem")
escreval ("você morre")
fimse
fimse
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não falou um FIMSE no código ?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Vá reidentando seu código... vai encontrar os erros. Exemplo de padrão:
 

algoritmo "Jogo De Escolhas, BraSim"
// Função : Criar um Simulador do Brasil para o Augusto jogar
// Autor : FranZ // LittleJimmy
// Data : 28/08/2016
// Seção de Declarações : Agradeço a Deus por me deixar viver pra fazer isso
var
nome:   caractere
cidade: caractere
escolhas: inteiro
dinheiro: inteiro
escolhas2: inteiro
escolhas3: inteiro
escolhas4: inteiro
inicio
// Identificação do personagem
escreval("BEM VINDO AO SIMULADOR DE BRASIL v0.0.1 (Alpha)")
escreval("OLÁ, EU SOU O BRASIM, UMA ENTIDADE GENÉTICA SUPERIOR")
escreval("Humano, por favor, identifique-se")
escreval( )
leia (nome)
escreval( )
escreval("Então, seu nome será: " ,nome)
escreval( )
escreval("Humano, escolha uma dessas duas cidades")
escreval("Acre (1), Ceará(2)")
leia (escolhas)
escreval( )
se escolhas = 1 então
   escreva ("Então, você " ,nome)
   escreval(" nasceu no Acre, na pacata cidade de Alagoinha")
   escreva ("Como um bom jovem, de 21 anos ")
   escreval(" seu objetivo é se tornar bem sucedido na vida")
   escreval( )
   escreval("-------------------SUA JORNADA COMEÇA AQUI-----------------------")
   escreval( )
senao
   se escolhas = 2 então
      escreva ("Então, você " ,nome)
      escreval(" nasceu no Ceará, na pacata cidade de Senador Sá")
      escreva ("Como um bom jovem, de 21 anos")
      escreval(" seu objetivo é se tornar bem sucedido na vida")
      escreval( )
      escreval("----------------SUA JORNADA COMEÇA AQUI-----------------------")
      escreval( )
      senao
      escreval("Entenda, sou uma entidade genética superior, não um deus bondoso e paciente")
      escreval("Reinicie e jogue pelas regras, ou então nem jogue")
      fimalgoritmo
   fimse
fimse




(CONTINUE A IDENTAÇÃO PARA O TRECHO ABAIXO)
// A Aventura se inicia
escreva ("Você Atualmente tem" ,dinheiro + 0)
escreval(" em dinheiro")
escreval( )
escreval("Você está morrendo de fome, mas se quiser sair")
escreval("Desse país tem que trabalhar")
escreval("Deseja comer (1) ou ir trabalhar(2) ?")
leia (escolhas2)
escreval( )
se escolhas2 = 1 então
escreval("Você come um pedaço enorme de Pão Doce")
escreval("Você sente que pode sobreviver mais um dia")
escreval( )
senao
se escolhas2 = 2 então
escreval("Você vai pro trabalho sem comer nada")
escreval("Você tem um colapso durante o expediente")
escreval("Você morre")
fimalgoritmo
senao
escreval("(CARA, SÉRIO QUE VOCÊ QUER ME TROLAR?)")
escreval("Você tropeça e cai numa poça de ácido clorídrico")
escreval("Por desrespeitar as regras do jogo, você morre, lenta e dolorasamente")
fimalgoritmo
//isso é só uma trollagem mesmo
fimse
fimse
escreval("Uma passagem para países gringos custa 1500g")
escreval("Você começará o seu novo emprego amanhã as 8:00 am.")
escreval("está tarde, deseja sair(1) ou ir dormir? (2)")
leia (escolhas3)
se escolhas3 = 1 então
escreval( )
escreval("Você resolve dar uma caminhada ao ar livre")
escreval("Você se depara com uma senhora idosa te pedindo ajuda pra atarvessar a rua")
escreval("vai ajudar(1) ou deixar a senhora sofrer(2) ?")
leia (escolhas4)
se escolhas4 = 1 então
escreval( )
escreval("Quando você se aproxima a Velha saca uma arma e anuncia o assalto")
escreval("Você não tem dinheiro")
escreval("A velha te dá um tiro e dois chutes na costela")
escreval("um morador chama o SAMU")
escreval("você não tinha plano de saúde")
escreval("os médicos te deixam morrer")
escreval("Você morre")
fimalgoritmo
senao
se escolhas4 = 2 então
escreval( )
escreval("Você deixa a velha para trás, sofrendo com as dores da idade")
escreval("Sua atitude egoísta atraiu uma má fama para a cidade")
escreval("Seus pais ficam sabendo disso e te renegam como filho")
escreval("você entra em depressão profunda e se mata")
fimalgoritmo
senao
se escolhas3 = 2 então
escreval( )
escreval("você se deita na cama")
escreval("Você sonha com um lindo futuro, com um bom emprego e uma linda familia")
escreval("Você tem uma ótima noite de soono")
escreval("--------------------- Fim do 1º dia ----------------------------------)
senao
escreval("Eu odeio babacas como você")
escreval("Você tropeça e cai num bueiro")
escreval("Você descobre que a lenda do RATOzomem era real")
escreval("Você é devorado por Igor, o ratozomem")
escreval("você morre")
fimse
fimse
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×