Ir ao conteúdo
  • Cadastre-se
helen_cris

Algoritmo em pseudocodigo com contador

Recommended Posts

será que alguém pode me ajudar?

 

Desenvolva um programa em pseudocódigo que leia os dados abaixo, referentes a vinte pessoas:

• A idade

• O peso

• A altura

• A cor dos olhos (A: azul, P: preto, V: verde, C: castanho)

• A cor dos cabelos (P: preto, C: castanhos, L: loiro e R: ruivo)

• O sexo (M: masculino e F: feminino)

• Se possui filhos (verdadeiro ou falso)

Esse programa deve calcular e mostrar:

a) A quantidade de pessoas com idade superior a 65 anos.

B) A média de altura das pessoas entre 15 e 25 anos.

c) A porcentagem de pessoas entre 18 a 24 anos que possuem filhos entre as pessoas de mesma faixa etária.

d) A porcentagem de pessoas que possuem olhos azuis e cabelo ruivo.

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
algoritmo 
    declare idade, peso, altura, i numerico 
            olhos, sexo, cabelo caracter
            
    para i <- 1 ate 20 faca
    
    inicio
    escreva ("Digite sua idade:")
    leia idade
    escreva ("Digite seu peso:")
    leia peso
    escreva ("Digite sua altura:")
    leia altura
    
    escreva ("Informe olhos")
    leia olhos 
    escreva ("Informe cabelo")
    leia cabelo 
    escreva ("Informe sexo")
    leia sexo 


Se idade >=  65
    
fim_algoritmo.

 

Travei, sei q tem alguns erros mas sou péssima em programação kkkkk

Editado por Simon Viegas
Inserir tag CODE no código
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @helen_cris, você está utilizando algum programa para "compilar"  e executar o código?

Se sim, qual?

Senão, esse pseudocódigo está em qual a linguagem de programação?

 

 

Então, se estiver utilizando o VisuAlg, fiz alguns ajustes básicos, e no próprio código tem alguns comentários:

{algoritmo} //É necessário informar o "nome do programa"
algoritmo "Aqui um nome ou descrição do algoritmo"
{    declare idade, peso, altura, i numerico} //usar VAR em vez de DECLARE
{            olhos, sexo, cabelo caracter}
var
  idade, peso, altura, i :inteiro
  olhos, sexo, cabelo    :caracter
INICIO //aqui começa a parte da execução do programa
para i <- 1 ate 20 faca
  {inicio} //o "O "inicio" fica logo abaixo da declaração das variáveis
   escreva ("Digite sua idade:")
   {leia idade} //a variável precisa ficar dentro de parênteses. "()"
   leia (idade)
   escreva ("Digite seu peso:")
   leia (peso)
   escreva ("Digite sua altura:")
   leia (altura)
   escreva ("Informe olhos")
   leia (olhos)
   escreva ("Informe cabelo")
   leia (cabelo)
   escreva ("Informe sexo")
   leia (sexo)
   {se idade >=  65}
  
   {fimSe} //comando que delimita o comando SE
   {fim_algoritmo} //antes 
fimPara //comando que delimita o fim do comando PARA
fimAlgoritmo //comando que delimita o fim do comando INICIO

Abaixo o código sem os comentários e alguns complemetos:

algoritmo "Aqui um nome ou descrição do algoritmo"
var
  idade, peso, altura, i :inteiro
  olhos, sexo, cabelo    :caracter
INICIO
para i <- 1 ate 2 faca //mudei 20 para 2, para facilitar os testes
  escreva ("Digite sua idade:")
  leia (idade)
  escreva ("Digite seu peso:")
  leia (peso)
  escreva ("Digite sua altura:")
  leia (altura)
  escreva ("Informe olhos")
  leia (olhos)
  escreva ("Informe cabelo")
  leia (cabelo)
  escreva ("Informe sexo")
  leia (sexo)
  escreval (" ") //para pular uma linha
  //a) A quantidade de pessoas com idade superior a 65 anos.
  se (idade >= 65) então

  fimSe
  
  //b) A média de altura das pessoas entre 15 e 25 anos.
  se (altura>=15) e (altura<=25) então
  
  fimSe

  //c) A porcentagem de pessoas entre 18 a 24 anos que possuem filhos entre as pessoas de mesma faixa etária.


  //d) A porcentagem de pessoas que possuem olhos azuis e cabelo ruivo.
  
fimPara
fimAlgoritmo

Veja, para facilitar as criações das estrutura de seleção (se), deixei as alínias referentes aos requisitos no próprio código... tente dar continuidade.

 

Minha sugestão é tentar fazer um  por um, não tente fazer tudo de uma vez e depois testar! Faz o primeiro se, testa e vê se tá funcionado. Faz o outro, testa e vê se tá funcionado...

 

-> Então, no primeiro se, ele está querendo uma quantidade, daí você pode utilizar uma variável para ir contando...

no segundo, ele precisa da média... daí você precisa analisar e ver o que precisa para calcular essa média... e assim por diante. Após os ses.. exibe os resultados.

 

Lembrando: tente faz apenas um se de cada vez (não importa qual), apenas analise, tente fazer, vá corrigindo até ficar pronto.

 

No aguardo.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×