Ir ao conteúdo
  • Cadastre-se
vncbarbosa

VisualG Algoritmo exercicio uf regiões

Recommended Posts

Algoritmo que receba a UF e escreva se este estado pertence a região SUL,
SUDESTE, NORTE, NORDESTE ou CENTRO-OESTE.

Pessoal preciso de uma ajuda com exercicio, segue o que eu já fiz, mas acredito que esteja errado e nao estou conseguindo desenvolver o algoritmo pra rodar da maneira que pede o exercicios. Quem puder ajudar ficarei muito grato!

Var
// Seção de Declarações das variáveis 
sigla:caractere

Inicio
// Seção de Comandos, procedimento, funções, operadores, etc... 

escreva (" Para sul, sudeste,norte, nordeste ou centro-oeste como estados- Informe a sigla: ")
leia (sigla)
escolha sigla
caso "sul"
escreval ("pertence a região sul")
caso "sudeste"
escreval ("pertence a região sudeste")
caso "norte"
escreval ("pertence a região norte")
caso "nordeste"
escreval ("pertence a região nordeste")
caso "centro-oeste"
escreval ("pertence a região centro-oeste")
caso "oe"
escreval ("outros estados")
outrocaso
escreval ("sigla inválida")
fimescolha
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @vncbarbosa. Seja bem vindo ao Fórum do Clube do Hardware.

 

 

2 horas atrás, vncbarbosa disse:

Algoritmo que receba a UF e escreva se este estado pertence a região SUL,
SUDESTE, NORTE, NORDESTE ou CENTRO-OESTE.

Pessoal preciso de uma ajuda com exercicio, segue o que eu já fiz, mas acredito que esteja errado e nao estou conseguindo desenvolver o algoritmo pra rodar da maneira que pede o exercicios. Quem puder ajudar ficarei muito grato!

 

Então, você precisa ler uma UF, correto? Logo a sugestão é que antes precisa primeiro entender o que é uma UF... Ex.:
https://pt.wikipedia.org/wiki/Unidades_federativas_do_Brasil

 

Como já deve saber, seria basicamente ler um ESTADO... ai de acordo com o estado informa qual região ele pertence.

Ex.
Informo BAHIA. O programa tem que me retornar NORDESTE.

 

A dica é simples: sempre tente primeiro entender o problema. A implementação de um algoritmo para resolver vem depois.

 

 

No aguardo.

 

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×