Ir ao conteúdo
  • Cadastre-se
Grazi Duarte

VisualG Alguém pode me explicar esse código pfvr

Recommended Posts

Var

   nome, digito, erro: caracter
   ind: inteiro

Funcao testaNome(nome: caracter):caracter
var
   nom, sobrenom, msg: caracter
   x, controle, comprnom, comprsobrenom: inteiro
Inicio

   controle := 1
   para x de 1 ate compr(nome) faca
      se (copia(nome,x,1) = " ") então
         controle := 2
      fimse
      se (controle = 1) e (copia(nome,x,1) <> " ")  então
         nom := nom + copia(nome,x,1)
      fimse
      se (controle = 2) e (copia(nome,x,1) <> " ")  então
         sobrenom := sobrenom + copia(nome,x,1)
      fimse
   fimpara

   comprsobrenom := compr(sobrenom)
   comprnom := compr(nom)

   se (comprnom > comprsobrenom) então
      msg := "Nome maior que sobrenome"
   senao
      se (comprsobrenom > comprnom) então
         msg := "Sobrenome maior que nome"
      senao
         msg := "Nome e sobrenome de mesmo tamanho"
      fimse
   fimse

fimse

retorne msg

Fimfuncao

Inicio

   Escreva ("Digite o nome: ")
   Leia(nome)

   erro := "n"

   para ind de 1 ate compr(nome) passo 1 faca
      digito := copia(nome,ind,1)
      se nao((digito >= "a") e (digito <= "z") ou (digito = " ")) então
         erro := "s"
         interrompa
      fimse
   fimpara
   se (erro = "s") então
      Escreval ("O e-mail só pode conter número ou espaço.")
   fimse
   se (erro = "n") então
      para ind de 1 ate compr(nome) passo 1 faca
         se (copia(nome,ind,1) = " ") e (copia(nome,ind+1,1) = " ") então
            erro := "s"
            interrompa
         fimse
      fimpara
      se (erro = "s") então
         Escreval ("Só deve haver um espaço entre nome e sobrenome.")
      fimse
   fimse
   se (erro = "n") então
      escreva (testaNome(nome))
   fimse


Fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×