Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Grazi Duarte

VisualG Alguém pode me explicar esse código pfvr

Recommended Posts

Var

   nome, digito, erro: caracter
   ind: inteiro

Funcao testaNome(nome: caracter):caracter
var
   nom, sobrenom, msg: caracter
   x, controle, comprnom, comprsobrenom: inteiro
Inicio

   controle := 1
   para x de 1 ate compr(nome) faca
      se (copia(nome,x,1) = " ") então
         controle := 2
      fimse
      se (controle = 1) e (copia(nome,x,1) <> " ")  então
         nom := nom + copia(nome,x,1)
      fimse
      se (controle = 2) e (copia(nome,x,1) <> " ")  então
         sobrenom := sobrenom + copia(nome,x,1)
      fimse
   fimpara

   comprsobrenom := compr(sobrenom)
   comprnom := compr(nom)

   se (comprnom > comprsobrenom) então
      msg := "Nome maior que sobrenome"
   senao
      se (comprsobrenom > comprnom) então
         msg := "Sobrenome maior que nome"
      senao
         msg := "Nome e sobrenome de mesmo tamanho"
      fimse
   fimse

fimse

retorne msg

Fimfuncao

Inicio

   Escreva ("Digite o nome: ")
   Leia(nome)

   erro := "n"

   para ind de 1 ate compr(nome) passo 1 faca
      digito := copia(nome,ind,1)
      se nao((digito >= "a") e (digito <= "z") ou (digito = " ")) então
         erro := "s"
         interrompa
      fimse
   fimpara
   se (erro = "s") então
      Escreval ("O e-mail só pode conter número ou espaço.")
   fimse
   se (erro = "n") então
      para ind de 1 ate compr(nome) passo 1 faca
         se (copia(nome,ind,1) = " ") e (copia(nome,ind+1,1) = " ") então
            erro := "s"
            interrompa
         fimse
      fimpara
      se (erro = "s") então
         Escreval ("Só deve haver um espaço entre nome e sobrenome.")
      fimse
   fimse
   se (erro = "n") então
      escreva (testaNome(nome))
   fimse


Fimalgoritmo

 

Editado por Simon Viegas

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×