Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
victorh.marques

Exercicio em VisuAlg

Recommended Posts

Bom dia, eu estou tentando fazer este exercicio:

exercicio84turmadealuno.png

eu escrevi este algoritimo:


var
x,i,qnt_A,mat,soma_A,soma_P: inteiro
turma,P_A: caractere
per_A: real
inicio
// Seção de Comandos
para i de 1 ate 10 faca
escreva ("Informe qual é a turma : ")
leia (turma)
escreva ("Informe a quantidade de alunos : ")
leia (qnt_A)

para x de 1 ate qnt_A faca
escreva ("Informe a matricula do aluno : ")
leia (mat)
escreva ("O aluno está P/A : ")
leia (P_A)
se P_A <> "P" então
soma_A <- soma_A + 1
per_A <- (100 * soma_A)/qnt_A
senao
soma_P <- soma_P + 1
fimse
fimpara

se turma = "A" então
escreval (per_A,"% dos alunos estão ausêntes na turma A !")
senao
se turma = "B" então
escreval (per_A,"% dos alunos estão ausêntes na turma B !")
senao
se turma = "C" então
escreval (per_A,"% dos alunos estão ausêntes na turma C !")
senao
se turma = "D" então
escreval (per_A,"% dos alunos estão ausêntes na turma D !")
senao
se turma = "E" então
escreval (per_A,"% dos alunos estão ausêntes na turma E !")
senao
se turma = "F" então
escreval (per_A,"% dos alunos estão ausêntes na turma F !")
senao
se turma = "G" então
escreval (per_A,"% dos alunos estão ausêntes na turma G !")
senao
se turma = "H" então
escreval (per_A,"% dos alunos estão ausêntes na turma H !")
senao
se turma = "I" então
escreval (per_A,"% dos alunos estão ausêntes na turma I !")
senao
se turma = "J" então
escreval (per_A,"% dos alunos estão ausêntes na turma J !")
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimse
fimpara
fimalgoritmo

o que está ocorrendo, é que quando o algoritimo vai dar o percentual de cada turma, os percentuais estão saindo um somado ao outro.

não esta saindo o percentual de cada turma em particular

se alguem puder ajudar obrigado !

Compartilhar este post


Link para o post
Compartilhar em outros sites

Neste algoritmo eu creio que o erro acontece porque você nunca mandou o valor de soma_A retornar a 0. Adicionar a linha soma_A <- 0 logo após o segundo para resolve.

Agora me diga uma coisa para que você esta usando o variável soma_P, para nada, então exclua ela.

Outra coisa use o caso positivo no se, pois facilita a leitura

A conta para checar o percentual de alunos que faltaram pode ser feita fora do para, assim o código não precisa passar todas vezes por ela.

exemplo:


para x de 1 ate qnt_A faca
escreva ("Informe a matricula do aluno : ")
leia (mat)
escreva ("O aluno está P/A : ")
leia (P_A)
se P_A == "a" então
soma_A <- soma_A + 1
fimse
fimpara
per_A <- (100 * soma_A)/qnt_A
soma_A <- 0

Espero ter ajudado, qualquer duvidas poste aqui.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×