Ir ao conteúdo
  • Cadastre-se

Vínculo entre planilhas não funciona com fórmula SOMARPRODUTO - Excel 2007


MikeDjorus

Posts recomendados

Boa tarde,

Estou tendo dificuldades em resolver o problema de uma planilha feita no Excel 2007:

Tenho uma matriz onde coloco dados de valores e faço vínculo entre essa e outra planilha, que faz calculo mediante ao um numero de vidas quaisquer.

Para esse calculo uso uma formula SOMARPRODUTO entre dados da matriz e dados de outra guia de planilha, que está na mesma pasta da planilha da formula, tudo isso dentro de outra formula de lógica (SE) com varias outras referências.

Como essa planilha é para uso de outros usuários tenho que protegê-la por uma senha.

Quando atualizo a matriz todos os outros valores vinculados são alterados automaticamente na planilha, porém o valor onde tenho essa fórmula não é modificado.

Não sei se é algum problema pelo fato de a fórmula ser matricial mas esse valor só altera quando desprotejo a planilha, clico na celual da formula, atualizando os vinculos manualmente.

Segue a fórmula utilizada abaixo:

=SE(E($I$7>='Referência nº de Vidas'!$A$2;$I$7<='Referência nº de Vidas'!$A$3;TabelaoAmil!B26>0;$I$6>=1);SOMARPRODUTO('T:\Produtos\TABELAS E MATRIZ DE VALORES\MATRIZES\[Matriz Tabelas - Planos Empresariais.xlsx]Amil Linha Blue'!B5:B14;TabelaoAmil!B16:B25);SE(E($I$7>'Referência nº de Vidas'!$A$3;$I$7<='Referência nº de Vidas'!$B$3;TabelaoAmil!B26>0;$I$6>=1);SOMARPRODUTO('T:\Produtos\TABELAS E MATRIZ DE VALORES\MATRIZES\[Matriz Tabelas - Planos Empresariais.xlsx]Amil Linha Blue'!B18:B27;TabelaoAmil!B16:B25);"-"))

Não sei se fui claro na exposição do problema mas desde já agradeço a colaboração.

Link para o comentário
Compartilhar em outros sites

Boa tarde,

Estou tendo dificuldades em resolver o problema de uma planilha feita no Excel 2007:

Tenho uma matriz onde coloco dados de valores e faço vínculo entre essa e outra planilha, que faz calculo mediante ao um numero de vidas quaisquer.

Para esse calculo uso uma formula SOMARPRODUTO entre dados da matriz e dados de outra guia de planilha, que está na mesma pasta da planilha da formula, tudo isso dentro de outra formula de lógica (SE) com varias outras referências.

Como essa planilha é para uso de outros usuários tenho que protegê-la por uma senha.

Quando atualizo a matriz todos os outros valores vinculados são alterados automaticamente na planilha, porém o valor onde tenho essa fórmula não é modificado.

Não sei se é algum problema pelo fato de a fórmula ser matricial mas esse valor só altera quando desprotejo a planilha, clico na celual da formula, atualizando os vinculos manualmente.

Segue a fórmula utilizada abaixo:

=SE(E($I$7>='Referência nº de Vidas'!$A$2;$I$7<='Referência nº de Vidas'!$A$3;TabelaoAmil!B26>0;$I$6>=1);SOMARPRODUTO('T:\Produtos\TABELAS E MATRIZ DE VALORES\MATRIZES\[Matriz Tabelas - Planos Empresariais.xlsx]Amil Linha Blue'!B5:B14;TabelaoAmil!B16:B25);SE(E($I$7>'Referência nº de Vidas'!$A$3;$I$7<='Referência nº de Vidas'!$B$3;TabelaoAmil!B26>0;$I$6>=1);SOMARPRODUTO('T:\Produtos\TABELAS E MATRIZ DE VALORES\MATRIZES\[Matriz Tabelas - Planos Empresariais.xlsx]Amil Linha Blue'!B18:B27;TabelaoAmil!B16:B25);"-"))

Não sei se fui claro na exposição do problema mas desde já agradeço a colaboração.

Eu acredito que sua desconfiança esteja correta. Fórmulas matriciais não atualizam automaticamente como as outras, você deve recalculá-las após qualquer alteração. Era muito comum o uso destas fórmulas nas versões anteriores ao excel 2007. Como você está trabalhando com o office 2007, acredito que seja possível atualizar esta fórmula usando novas funções, tais como o somases, que permite vincular mais de uma condição para realizar o somatório.

Como você deseja utilizar a fórmula somar produto, você pode criar na planilha matriz uma coluna com o produto das células desejadas. Assim ficará fácil de utilizar a fórmula somases sem a necessidade de uma fórmula matricial.

Link para o comentário
Compartilhar em outros sites

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

APRENDA TUDO SOBRE HARDWARE!

HARDWARE 2022

 

CLIQUE AQUI E BAIXE AGORA MESMO!