Ir ao conteúdo
  • Cadastre-se

consulta no excel


Fabiano Martinss

Posts recomendados

olá

Estou tentando montar uma tela de consulta no excel onde digito o código do item e nas outras células aparecem as informações referentes a este código.

Tenho duas planilhas uma para cada fornecedor, e esta terceira para consulta.

Estou tentando aninhar a função "SE" e "PROCV" porém não estou conseguindo.

Na prática esta formula teria que procurar o código nas duas planilhas de fornecedores e retornar o nome do fornecedor.

obrigado

Feliz ano novo a todos do clube!!!!

Link para o comentário
Compartilhar em outros sites

http://www.sendspace.com/file/ra4mc2

hoje nao tenho acesso a original mas é +- isso(poosso postar a original amanha).

Com formatação condicional criei uma forma de não repetir o mesmo código nem no mesmo fornecedor nem no outro, ou seja, nas duas planilhas o código só pode aparecer uma vez!

Onde diz data do pedido estou procurando uma forma de:

quando for digitado na coluna "carro'' o código do carro, na coluna "data do pedido" apareça a data atual (e que esta nao mude) tem como?

Link para o comentário
Compartilhar em outros sites

Boa Noite!

Se o amigo Patropi me permite, darei a seguinte solução!

para o procv use este

=SEERRO(SE(D7=PROCV(D7;'Fornecedor 1'!A2:A20;1;0);"FORNECEDOR 1";"");SE(D7=PROCV(D7;'Fornecedor 2'!A2:A20;1;0);"FORNECEDOR 2";""))

no caso a celula D7 é onde digitarei o codigo do carro....

quanto a data, eu sei isso de nao mudar a data por macro!

Private Sub Worksheet_Change(ByVal Target As Range)

Set Colunas = Range("A1:A20")

If Not Application.Intersect(Colunas, Range(Target.Address)) Is Nothing Then

linha = Target.Row

If IsEmpty(Range("B" & linha).Value) = True Then

Range("B" & linha).Value = DateTime.Now

End If

End If

End Sub

coluna A é onde digita... e o B é onde aparecerá a data!

qualquer duvia é so perguntar!:lol:

Um abraço!:cool:

Link para o comentário
Compartilhar em outros sites

Olá!

A macro mesmo que vai colocar a data... quando você digitar na coluna A u outra que você mudar!

para colocar a macro, office 2007 ou superior, você clcia com o direito na guia da aba

e vai em exibir codigo...

na janela que abre você coloca o codigo!

office 2003 você aperta Alt+F11 na janela q abre clica como direito na aba que você quer usar o codigo, vai em exibir codigo, e na janela branca que abre você coloca o codigo!

ok?:rolleyes:

Link para o comentário
Compartilhar em outros sites

Esta funcionando! Só nao estou conseguindo modificar ela!

Preciso que ela vá até A2500 e a coluna que aparece a data também preciso alterar!

já alterei mas nao esta funcionando com os novos endereços!

Sub Adicionar()

End Sub

Private Sub Worksheet_Change(ByVal Target As Range)

Set Colunas = Range("A1:A2500")

If Not Application.Intersect(Colunas, Range(Target.Address)) Is Nothing Then

linha = Target.Row

If IsEmpty(Range("I" & linha).Value) = True Then

Range("I" & linha).Value = DateTime.Now

End If

End If

End Sub

Link para o comentário
Compartilhar em outros sites

Olha!

selecionei o codigo que você coloco, copiei

colei em uma planilha e ele funciono beleza!

digitei em A1 a data apareceu em i1

digitei em A2499 a data apareceu em i2499

você alterou ela corretamente, deve ser uma outra coisa q você ta faznedo errado!

:rolleyes:

ta ai um modelo com o codigo que você fez!

http://www.sendspace.com/file/3nz8an

Link para o comentário
Compartilhar em outros sites

Arquivado

Este tópico foi arquivado e está fechado para novas respostas.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...