Ir ao conteúdo
  • Cadastre-se

olliver.soul

Membros Plenos
  • Total de itens

    780
  • Registro em

  • Última visita

  • Qualificações

    0%

Reputação

198

Informações gerais

  • Cidade e Estado
    São Paulo, SP
  • Sexo
    Prefiro não dizer
  1. Você pode usar uma variável para atribuir o valor da linha. Para algo mais complexo depende dos valores das colunas, se seguir alguma lógica a implementação será mais fácil. For Each var_inserir In Worksheets("ADD STAFF").Range("G3:G20") If var_inserir = "NEW" Then L = var_inserir.Row Sheets("Workers").Range("B6:D6").Insert Shift:=xlDown 'insere uma linha no intervalo indicado Worksheets("ADD STAFF").Range("F" & L & ":E" & L & ",C" & L).Copy Sheets("Workers").Range("B6:D6") End If Next var_inserir
  2. Como ficou seu código após alterar para PasteSpecial? Se a macro anterior estava funcionando e você só fez essa adaptação, devia funcionar.
  3. Só para testar coloquei uma instrução para gerar apenas 3 linhas (Exit For). Sub Main() Dim WkCopia As Worksheet Dim WkNova As Workbook Dim L As Integer Set WkCopia = ThisWorkbook.ActiveSheet For L = 3 To WkCopia.Range("B2").End(xlDown).Row Set WkNova = Workbooks.Add WkCopia.Range(L & ":" & L).Copy WkNova.ActiveSheet.Cells(1) If L >= 5 Then Exit For Next L End Sub
  4. Segue uma macro que copia o range B12:AL14 de todas as Plans de Boletim. Para testar insira um módulo na planilha Boletim. A partir daí você pode ir adaptando. Sub Main() Dim Boletim As Worksheet Dim Unir As Worksheet Dim Area As Range Dim L As Integer L = 1 Set Unir = Workbooks.Add.ActiveSheet For Each Boletim In ThisWorkbook.Worksheets Set Area = Boletim.Range("B12:AL14") Area.Copy Unir.Cells(L, 1) L = L + 2 Next Boletim End Sub
  5. Com essa fórmula não tem a compensação no resultado. =se(cont.se(g10:n10;"<1,5")=0;"aprovado";"reprovado")
  6. @Julio Oviedo Testou com a fórumula CONT.SE?
  7. Você pode usar o cont.se para verificar se há algum resultado < 1,5 =SE(CONT.SE(G10:N10;"<1,5")=0;"APROVADO";"REPROVADO") adicionado 2 minutos depois Assim se tiver por exemplo uma nota 1,4 e outra 1,6 o resultado será aprovado.
  8. Com a propriedade CurrentRegion fica mais fácil copiar todo conteúdo, mas para isso a tabela não pode ter linhas ou colunas em branco. Insira um módulo na planilha e teste a macro abaixo. Sub Main() Dim Area As Range Dim Pasta As Workbook Set Area = Range("B2").CurrentRegion Set Pasta = Workbooks.Add Area.Copy Pasta.ActiveSheet.Range("B2") End Sub
  9. Colocando em ordem: U = {-5, -2, 0, 1, 1/2, 3/4, 2, 10/3, 4} Veja que há elementos fracionários pertencente aos racionais.
  10. Se tivesse colocado no módulo como comentei acima, já teria resolvido.
  11. O resultado da fórmula é de acordo com a descrição do problema.
  12. No print a macro está no módulo Plan1 e não no módulo que comentei acima.
  13. É só usar as fórmulas lógicas/condicionais. Segue um exemplo. =SE(OU(A1=1;A1=-1);"APROVADO";SE(OU(A1>1;A1<-1);"REPROVADO";""))
  14. Crie um módulo padrão (tipo Modulo 1, 2, etc) e coloque a macro nele. Isso deve resolver.

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×