Ir ao conteúdo
  • Cadastre-se

VisualG Exercício somatória com visualg


Posts recomendados

Oi pessoal, tudo bem? alguém poderia me ajudar ? estou tentando fazer um exercício, mas não saí do lugar 

O exercício consiste em usar o comando "PARA" e fazer a soma de termos

Ex: O usuário insere o valorinicial e o valorfinal, com esses dados eu tenho que fazer a somatória

exemplo prático: o usuário insere o valorinicial: 1 e valorfinal:10 o programa tem que fazer a soma de 1+2+3+4+5+6+7+8+9+10 e exibir

Desde já agradeço a atenção

 

Segue meu código:

var
num1: inteiro
num2: inteiro
termos: inteiro
ult_termo: inteiro
media: real
num_sequencia: inteiro
sequencia: real
inicio
Escreva ("Digite o primeiro número da sequência: ")
Leia (num1)

Escreva ("Digite o segundo número da sequência: ")
Leia (num2)

Se ((num1 > num2))  entao
Escreva ("O primeiro número deve ser menor, por favor tente novamente.")
Fimse

Para ult_termo de num1 ate num2 faca
media <- (ult_termo + num1)/2
num_sequencia <- (ult_termo - num1 + 1)
sequencia <- media * num_sequencia
Fimpara

Se ((num1 < num2)) entao
Escreval ("O resultado da soma desta sequência é:", sequencia)
Fimse

fimalgoritmo

 

Link para o comentário
Compartilhar em outros sites

  • Moderador

Caro usuário,

 

Seja bem-vindo ao Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!