Ir ao conteúdo
  • Cadastre-se

C++ Como posso transformar essa linguagem em códigos c++?


PicoPc

Posts recomendados

algoritmo "Conjunto de dados"
var
cont, soma, nhomens, nmulher: inteiro
altura: real
alturaM, alturaH, media, maior, menor: real
sexo: literal
inicio
cont<- 0
nhomens<- 0
nmulher<- 0
escreval("Digite a altura e o sexo de 5 pessoas:")
repita
escreva("Altura: ")
leia(altura)
escreva("Sexo: ")
leia(sexo)
escreval("--------------- x xx --------------")
cont<- cont + 1
se(altura > maior ) entao
maior<- altura
se(altura < menor) entao
menor<- altura
fimse
fimse
se(sexo = "m") entao
nmulher<- nmulher + 1
atecont = 5
fimalgoritmo

 

  • Obrigado 1
Link para o comentário
Compartilhar em outros sites

ao meu ver é questao apenas de entender o que esse codigo faz e aplicar a mesma logica na linguagem desejada

uma simples estrutura de repeticao controlada, alguns if/else

 

você entende perfeitamente o q essas estruturas postadas fazer? e conhece as estruturas na linguagem q deseja?

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

2 horas atrás, PicoPc disse:

cont,
soma,
nhomens,
nmulher: inteiro 
altura: real alturaM, alturaH, media, maior, menor: real 
sexo: literal

 

 

Ao que parece você deve ler altura e sexo de 5 pessoas e calcular esses valores aí acima.

  • maior altura e menor altura por sexo
  • total de mulheres
  • alguma media? Não está no código
  • alturaM, alturaH? Não está no código

Verifique o enunciado e crie uma simples classe, Conjunto, e na criação leia os valores e calcule tudo.

  • Curtir 1
Link para o comentário
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Como se tornar um desenvolvedor full-stack

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!