Ir ao conteúdo
  • Cadastre-se

VisualG Puxar um procedimento no Visual G


Ir à solução Resolvido por JorgeGus,

Posts recomendados

Estou fazendo com procedimentos pelo VisualG e esta dando bom ate ai ta rodando no VisualG, mas quando tempo puxar o procedimento "cadastrar produtos" para caso 1 ele informa que não encontra a Variável caract_cell sendo que declarei ela como registro no inicio.

 

Algoritmo "algo"
tipo
   caract_cell = registro
      codigo:inteiro
      modelo:caracter
      marca:caracter
      preco:real
   fimRegistro
var
   opcao:inteiro
   
procedimento menu_principal
inicio
   escreval("+++++++++++++++++++++++++++++++++++")
   escreval("+ 1 - Cadastrar produtos          +") //informar para o usuário se o produto foi cadastrado ou não
   escreval("+ 2 - Todos os produtos           +")
   escreval("+ 3 - Pesquisar um produto        +") //informar ao usuário  que o produto não foi encontrado caso ocorra.
   escreval("+ 4 - Sair                        +")
   escreval("+++++++++++++++++++++++++++++++++++")
fimprocedimento

procedimento cadastrarprodutos
var
   i,codigo:inteiro
inicio
   para i de 1 ate 100 faca
      escreval("Informe o código do produto")
      leia(caract_cell[i].codigo)
      escreval("Informe o modelo do produto")
      leia(caract_cell[i].modelo)
      escreval("Informe a marca do produto")
      leia(caract_cell[i].marca)
      escreval("Informe o preço do produto")
      leia(caract_cell[i].preco)
   fimpara
fimProcedimento

inicio
   repita
      menu_principal
      escreva("=====> ")
      leia(opcao)
      limpaTela

      escolha(opcao)
      caso 1
         cadastrarprodutos
      caso 2

      caso 3

      caso 4
         escreval("Obrigado pela preferência")
      outrocaso
         escreval("*********Opção Inválida**********")
      fimEscolha
   ate opcao = 4
fimAlgoritmo

 

Alguém tem alguma solução pra ajudar no codigo ?

Link para o post
Compartilhar em outros sites
  • Solução

Você declarou um tipo, mas não declarou um vetor desse tipo.

 

Declare por exemplo:

produtos: vetor[1..100] de caract_cell

 

E mude a referência para:

leia(produtos[i].codigo)

 

  • Obrigado 1
Link para o post
Compartilhar em outros sites
55 minutos atrás, JorgeGus disse:

Você declarou um tipo mas não declarou um vetor desse tipo.

 

Declare por exemplo:


produtos: vetor[1..100] de caract_cell

 

E mude a referência para:


leia(produtos[i].codigo)

 

 

Consegui aqui, te agradeço.

  • Curtir 1
Link para o post
Compartilhar em outros sites
  • Simon Viegas alterou o título para Puxar um procedimento no Visual G

Crie uma conta ou entre para comentar

Você precisa ser um usuário para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!