Ir ao conteúdo
  • Cadastre-se

Formulas do Excel


Posts recomendados

Caro jauad, Boa Tarde.

O que você precisa não é difícil de ser feito.

Você só tem que tomar certos cuidados técnicos para que a formação da fórmula de pesquisa esteja ajustada à realidade da planilha, sempre.

O que você precisa é somente uma fórmula que:

a) Identifique o fornecedor selecionado (C9)

B) Monte a fórmula de pesquisa na ABA vinculada ao fornecedor de C9. (Aba Tecbits; Helios; Teste...)

Podemos supor que nas planilhas de fornecedores a descrição esteja iniciando em A2.

Logo, na planilha TECBITS em A2 está a descrição do primeiro produto.

Se considerarmos o seu exemplo de maneira absoluta, a fórmula que estaria na planilha PEDIDO célula A16 seria: ='Tecbits'!A2

As demais linhas seguiriam a mesma lógica:

A17 --> ='Tecbits'!A3

A18 --> ='Tecbits'!A4

A19 --> ='Tecbits'!A5...

Porém, como a cada momento existirá um fornecedor diferente, devemos fazer esta fórmula agir de maneira relativa, isto é, dependendo do conteúdo de C9, a fórmula mudará de ABA de fornecedor.

A primeira questão técnica aparece aquí.

Integridade de dados.

Existem duas opções:

1) O nome que aparece em C9 (Fornecedor) é igual ao nome da ABA correspondente.

2) O nome que aparece em C9 (Fornecedor) é diferente ao nome da ABA correspondente.

Para o caso 1) a fórmula fica montada de maneira direta, utilizando o próprio conteúdo de C9 na montagem.

Em PEDIDO, A16 seria --> =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A2))))

A fórmula faz:

Veirifca se foi selecionado algum fornecedor em C9.

Se foi, então junta o Aspas + Nome do fornecedor + Aspas + Ponto de Exclamação + Letra A (da coluna de descrição) + Número da linha de A2 que é 2, finalizando assim o endereço correto da célula desejada. Ex.: 'TECBIS'!A2

Atente para o fato que foi utilizada uma função para representar o número 2. Porquê?

Já que será necessário copiar a linha da fórmula para várias linhas abaixo, a única maneira de criar um campo variável é utilizando uma função.

Quando copiar a fórmula de A16 que é =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A2)))), ela simplesmente irá manter todos os dados fíxos alterando a única variável que existe que é a função linha (LIN()).

A16 --> =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A2)))) --> 'TECBIS'!A2

A17 --> =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A3)))) --> 'TECBIS'!A3

A18 --> =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A4)))) --> 'TECBIS'!A4

Para o caso 2), a montagem da fórmula deverá ser feita utilizando-se uma tabela auxiliar para indicar qual ABA se refere a qual FORNECEDOR, já que NÃO poderá ser utilizado de maneira direta o contéúdo de C9.

Neste caso irá depender diretamente de como estarão os nomes das abas e os nomes dos fornecedores para determinar como será montada a fórmula para obter o mesmo resultado obtido no caso 1).

Em ambos os casos você poderá também montar um controle de quantidade de linhas a serem buscadas na ABA fornecedor.

Pode ser um CONT.SE ou outro tipo de controle apenas para saber quantas linhas deverão ser buscadas.

FAÇA UM TESTE.

Coloque o nome dos fornecedores IGUAIS ao nome das ABAS.

Fornecedor: TECBIS --> Aba: TECBIS

Fornecedor: HELIOS --> Aba: HELIOS

Fornecedor: TESTE --> Aba: TESTE

Preencha as células de A2 até A5 destas ABAS.(Descrição do produto)

Faça o campo validação de C9 usar os nomes TECBIS;HELIOS;TESTE

Coloque em PEDIDO, célula A16 --> =SE($C$9="";"";INDIRETO(CONCATENAR("'"&$C$9&"'!"&"A"&LIN(A2))))

Copie A16 e cole em A17 até A19.

Observe o resultado.

Era isto que você queria?

Espero ter ajudado.

Link para o post
Compartilhar em outros sites
  • 10 meses depois...

Meus, caros...

Eu trabalho com vendas, tenho uma panilha montada com os numeros de cota dos vendedores e o realizado por categoria de produtos. Mas preciso de somar isso tudo e dar nota. Desta forma ( de 50% a 60% nota 5, de 61% a 69% nota 6, 70% a 79% nota 7 assim por diante) como devo fazer????

Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora

Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas comunidades sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

Aprenda a ler resistores e capacitores

EBOOK GRÁTIS!

CLIQUE AQUI E BAIXE AGORA MESMO!