Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
eliumoraes

Problemas com meu apt-get

Recommended Posts

Estou tendo problemas para instalar os programas através do apt-get, acredito que o meu repositório do Elementary OS está corrompido, mas não sei como limpar e voltar ao normal.

Por exemplo, ao tentar instalar o Qucs ou qualquer programa aparece sempre a mesma mensagem:


sudo apt-get install qucs
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você deve querer executar 'apt-get -f install' para corrigí-los:
Os pacotes a seguir têm dependências desencontradas:
 clang-3.8 : Depende: libllvm3.8v4 mas não será instalado
 libclang-common-3.8-dev : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não será instalado
 libclang1-3.8 : Depende: libllvm3.8v4 mas não será instalado
 liblldb-3.8 : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não será instalado
 lldb-3.8 : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não será instalado
 llvm-3.8 : Depende: libllvm3.8v4 mas não será instalado
 llvm-3.8-dev : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não será instalado
 llvm-3.8-runtime : Depende: libllvm3.8v4 mas não será instalado
 qucs : Depende: libqt4-qt3support (>= 4:4.5.3) mas não será instalado
        Recomenda: freehdl mas não será instalado
        Recomenda: verilog mas não será instalado
        Recomenda: octave mas não será instalado
E: Dependências desencontradas. Tente 'apt-get -f install' sem nenhum pacote (ou especifique uma solução).

Quando tento o comando que ele indica o seguinte ocorre:

apt-get -f install
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os seguintes pacotes foram instalados automaticamente e já não são necessários:
  firefox-locale-bg firefox-locale-cs firefox-locale-da firefox-locale-id
  firefox-locale-ko firefox-locale-pt firefox-locale-ru firefox-locale-th
  firefox-locale-vi libcurl3:i386 libidn11:i386 libjsoncpp0 libllvm3.8
  libntdb1 libpth20:i386 librtmp0:i386 libtimezonemap1 libxfce4ui-1-0
  libxfce4ui-common libxfce4util-bin libxfce4util-common libxfce4util6
  libxfconf-0-2 linux-headers-3.13.0-85 linux-headers-3.13.0-85-generic
  linux-headers-3.19.0-39 linux-headers-3.19.0-39-generic
  linux-image-3.13.0-85-generic linux-image-3.19.0-39-generic
  linux-image-extra-3.13.0-85-generic linux-image-extra-3.19.0-39-generic
  linux-signed-image-3.13.0-85-generic python-ntdb xfconf
Utilize 'apt-get autoremove' para os remover.
Os pacotes extra a seguir serão instalados:
  libllvm3.8v4
Os NOVOS pacotes a seguir serão instalados:
  libllvm3.8v4
0 pacotes atualizados, 1 pacotes novos instalados, 0 a serem removidos e 16 não atualizados.
9 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/9.721 kB de arquivos.
Depois desta operação, 40,4 MB adicionais de espaço em disco serão usados.
Você quer continuar? [Y/n] y
(Lendo banco de dados ... 433968 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb ...
A descompactar libllvm3.8v4:amd64 (1:3.8-2ubuntu3~trusty4) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb (--unpack):
 a tentar sobre-escrever '/usr/lib/x86_64-linux-gnu/libLLVM-3.8.so.1', que também está no pacote libllvm3.8:amd64 1:3.8~svn271772-1~exp1
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
E: Sub-process /usr/bin/dpkg returned an error code (1)

Meu update também está dando erro, sempre termina com a seguinte linha:

W: Erro GPG: http://download.opensuse.org  Release: As assinaturas a seguir não puderam ser verificadas devido à chave pública não estar disponível: NO_PUBKEY 1BE1E8D7A2B5E9D5

A sugestão do autoremove também está bugando:

apt-get autoremove
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Você pode querer executar 'apt-get -f install' para corrigí-los.
Os pacotes a seguir têm dependências desencontradas:
 clang-3.8 : Depende: libllvm3.8v4 mas não está instalado
 libclang-common-3.8-dev : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não está instalado
 libclang1-3.8 : Depende: libllvm3.8v4 mas não está instalado
 liblldb-3.8 : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não está instalado
 lldb-3.8 : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não está instalado
 llvm-3.8 : Depende: libllvm3.8v4 mas não está instalado
 llvm-3.8-dev : Depende: libllvm3.8v4 (= 1:3.8-2ubuntu3~trusty4) mas não está instalado
 llvm-3.8-runtime : Depende: libllvm3.8v4 mas não está instalado
E: Dependências desencontradas. Tente usar -f.

Ou:

 apt-get autoremove -f
Lendo listas de pacotes... Pronto
Construindo árvore de dependências       
Lendo informação de estado... Pronto
Corrigindo dependências... Pronto
Os pacotes extra a seguir serão instalados:
  libllvm3.8v4
Os pacotes a seguir serão REMOVIDOS:
  firefox-locale-bg firefox-locale-cs firefox-locale-da firefox-locale-id
  firefox-locale-ko firefox-locale-pt firefox-locale-ru firefox-locale-th
  firefox-locale-vi libcurl3:i386 libidn11:i386 libjsoncpp0 libllvm3.8
  libntdb1 libpth20:i386 librtmp0:i386 libtimezonemap1 libxfce4ui-1-0
  libxfce4ui-common libxfce4util-bin libxfce4util-common libxfce4util6
  libxfconf-0-2 linux-headers-3.13.0-85 linux-headers-3.13.0-85-generic
  linux-headers-3.19.0-39 linux-headers-3.19.0-39-generic
  linux-image-3.13.0-85-generic linux-image-3.19.0-39-generic
  linux-image-extra-3.13.0-85-generic linux-image-extra-3.19.0-39-generic
  linux-signed-image-3.13.0-85-generic python-ntdb xfconf
Os NOVOS pacotes a seguir serão instalados:
  libllvm3.8v4
0 pacotes atualizados, 1 pacotes novos instalados, 34 a serem removidos e 15 não atualizados.
9 pacotes não totalmente instalados ou removidos.
É preciso baixar 0 B/9.721 kB de arquivos.
Depois desta operação, 576 MB de espaço em disco serão liberados.
Você quer continuar? [Y/n] y

(Lendo banco de dados ... 433968 ficheiros e directórios actualmente instalados.)
A preparar para desempacotar .../libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb ...
A descompactar libllvm3.8v4:amd64 (1:3.8-2ubuntu3~trusty4) ...
dpkg: erro ao processar o arquivo /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb (--unpack):
 a tentar sobre-escrever '/usr/lib/x86_64-linux-gnu/libLLVM-3.8.so.1', que também está no pacote libllvm3.8:amd64 1:3.8~svn271772-1~exp1
dpkg-deb: erro: o subprocesso colar foi morto pelo sinal (Pipe quebrado)
Erros foram encontrados durante o processamento de:
 /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

 

Preciso de ajuda para resolver isso, alguém?

Compartilhar este post


Link para o post
Compartilhar em outros sites

@eliumoraes Antes de tudo dê um apt-get update e logo em seguida # apt-get install synaptic.

 

E utilize o gerenciador de pacotes "Synaptic" para localizar seus pacotes quebrados ou corrompidos.

 

A sua sources.list deve estar devidamente preparada pois ele procura os pacotes listados na mesma.

Compartilhar este post


Link para o post
Compartilhar em outros sites

tenta também "Você pode querer executar 'apt-get -f install' para corrigí-los."

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • @JorgeSouza Não tem como instalar através do apt-get o synaptic, pois qualquer instalação através do apt-get dá o mesmo erro, lembrando que o meu update também não funciona, está o erro ali no primeiro tópico.

     

    @Gamer_PC Eu já fiz esse procedimento, está ali no primeiro tópico a execução e o erro que dá ao fazer. 

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    "download.opensuse.org"?

    Poste o conteudo de "/etc/apt/sources.list".

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    a sources.list em questão está  :tw_scream: desesperadora

     

    crie uma nova utilizando o serviço -> https://repogen.simplylinux.ch/

     

    não esqueça de selecionar a versão correta que tens instalada

    Editado por Manjaro

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • @AmarildoJr Meu sources.list:

    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    
    # newer versions of the distribution.
    deb http://br.archive.ubuntu.com/ubuntu/ trusty main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://br.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://br.archive.ubuntu.com/ubuntu/ trusty universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty universe
    deb http://br.archive.ubuntu.com/ubuntu/ trusty-updates universe
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
    ## team, and may not be under a free licence. Please satisfy yourself as to 
    ## your rights to use the software. Also, please note that software in 
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://br.archive.ubuntu.com/ubuntu/ trusty multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty multiverse
    deb http://br.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://br.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
    deb-src http://br.archive.ubuntu.com/ubuntu/ trusty-backports main restricted universe multiverse
    
    deb http://security.ubuntu.com/ubuntu trusty-security main restricted
    deb-src http://security.ubuntu.com/ubuntu trusty-security main restricted
    deb http://security.ubuntu.com/ubuntu trusty-security universe
    deb-src http://security.ubuntu.com/ubuntu trusty-security universe
    deb http://security.ubuntu.com/ubuntu trusty-security multiverse
    deb-src http://security.ubuntu.com/ubuntu trusty-security multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu trusty partner
    # deb-src http://archive.canonical.com/ubuntu trusty partner
    
    ## Uncomment the following two lines to add software from Ubuntu's
    ## 'extras' repository.
    ## This software is not part of Ubuntu, but is offered by third-party
    ## developers who want to ship their latest software.
    # deb http://extras.ubuntu.com/ubuntu trusty main
    # deb-src http://extras.ubuntu.com/ubuntu trusty main
    
    ## Pacote para o Firefox
    deb http://packages.linuxmint.com debian import
    deb http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.8 main
    # deb-src http://llvm.org/apt/trusty/ llvm-toolchain-trusty-3.8 main

    @Manjaro Dei uma olhada no site, mas ele é específico para Ubuntu, será que posso criar uma sources.list com ele e utilizar mesmo assim?

     

    Obs.: Na minha sources.list existem várias referências ao Ubuntu, apesar de meu SO ser o Elementary OS.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Nossa, quanta confusão! Há pacotes para o Trusty, para o Trusty-Backports, para o Mint Debian Edition.... é normal isso no Elementary?

    Eu nem tenho tempo de olhar isso agora. Se for pra usar uma distro, que seja uma "mainline" como Debian, Ubuntu, openSUSE, Arch... é muito mais simples de manter os repositórios.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    @eliumoraes fala mano desculpa nao vi.

     

    tenta isolar alguns repositórios no sources.list comentando-os

     

    se não tiver conseguindo instalar o synaptic, tenta instalação manual via dpkg -i (um saco por causa das deps. porém pra resolver o problema fazemos tudo ne)

     

    Meu mint tava dando problema um tempo aí, eu tentava fazer de tudo mas tudo via apt torno-se mega ultra lento, o que nao é normal. os servers deviam estar sobrecarregados sei la, depois de um tempo melhorou.

     

    tenta trocar os mirrors também, no ubuntu (acho) procura no menu por "fontes de aplicativos"

     

    bom , se isso não ajudar infelizmente não sei. na pior das hipoteses, salva teu /home num diretório diferente, cria uma lista de backup (comandos abaixo) dos teus apps e reinstala que vai demorar menos.

     

    dpkg --get-selections > package_list.txt (cria um .txt com sua lista de programas, coloca isso no teu home a ser salvo)

    sudo apt-get update && sudo apt-get upgrade

    sudo dpkg --clear-selections 

    sudo dpkg --set-selections < package_list.txt

    sudo apt-get update && sudo apt-get dselect-upgrade

     

    esse procedimento me permite reinstalar todo meu sistema com  o home salvo em coisa de uma hora no máximo, com tudo já configurado do jeito que estava.

     

    link da dica: http://askubuntu.com/questions/243387/how-can-i-backup-my-programs-applications-so-that-after-i-reinstall-a-new-one

     

     

    abç

    Editado por Gamer_PC
    Correção

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

     

    9 horas atrás, eliumoraes disse:

    @Manjaro Dei uma olhada no site, mas ele é específico para Ubuntu, será que posso criar uma sources.list com ele e utilizar mesmo assim?

     

    @eliumoraes - - O Elementary OS é baseado no Ubuntu..... - é Ubuntu com uma Interface diferenciada...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • Pessoal, desculpe pela demora. Eu estava tentando há todo esse tempo resolver o problema, hoje finalmente consegui encontrar um jeito.

     

    Primeiro usei este comando:

    
    sudo dpkg -i --force-overwrite /var/cache/apt/archives/libllvm3.8v4_1%3a3.8-2ubuntu3~trusty4_amd64.deb
    
    

     

    E depois este:

     

    
    sudo apt-get install -f
    
    

     

    Deu vários erros e achei que não iria dar certo (depois de tantas tentativas e fracassos), mas voltou a funcionar o apt-get e ainda consegui fazer o update do sistema sem problemas.

     

    Faz tempo que o tópico está aberto, mas caso alguém tenha o mesmo problema pode ser útil esta resposta.

     

    Fonte!

    • Curtir 1

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×