Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
JULIANA VALENTE

Comparar Tabelas No Excel

Recommended Posts

Estou desperada, estou com um problema na planilha e se caso não resolver posso ser demitida.

preciso da fórmula ou de um jeito fácil para comparar 2 tabelas no excel.

as tabelas são basicamente assim

tabela de registros

coluna1--coluna2

MES JAN--MES FEV

6.111-1--6.111-1

7.222-2--6.666-6 -> Mostrar q este registro foi inserido

8.888-8--7.222-2

Eu preciso comparar a coluna "janeiro" e verificar se foi inserido algum registro no coluna "fevereiro".

por exemplo na coluna fevereiro (acima), o segundo registro é novo (6.666-6), e ele está na linha 2.

na na linha 3 (coluna 2)tem o registro 7.222-2 que também tem na coluna janeiro (linha 2), eu gostaria que me informasse que (no caso acima) só o numero 6.666-6 foi inserido, podendo ser mostrado isso na coluna ao lado, ou mudar a cor da celula, qualquer coisa que dê para ver que foi inserido esse numero.

lembro que é uma relação com certa de 10 mil registros.

se não tiver solução me avisem também, ou me ajudem a fazer de outra forma ou em outro programa, mas por favor me ajudem!!

agradeço muito e espero uma ajuda.

obrigado

JULIANA

juliana_valente06@hotmail.com

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tente isto:

Considerando seu exemplo

Celula A1 - JAN Celula B1 - FEV

Celula A2 - 6.111-1 Celula A2 - 6.111-1

Celula A3 - 7.222-2 Celula A3 - 6.666-6

Celula A3 - 8.888-8 Celula A3 - 7.222-2

Ponha na Celula C2 esta formula =PROCV(B2;$A$2:$A$4;1;FALSO) e copia para as outras duas celula C3 e C4.

Ela esta verificando se o valor que esta em fevereiro tem um igual em janeiro, se tiver ele copia o valor, se não encontrar ele marca #N/D.

Veja se resolve, qq dúvida retorne.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Eu utilizei a fórmula que você me passou, mas ainda tenho um probleminha.

    Quando tem um numero na coluna 1 e na 2 nao, eu gostaria que mostrasse tambem, pois é uma tabela com registros e ela tem que me mostrar os registros que entram e saem.

    ex:

    COLUNA A - COLUNA B

    11.111-1 / 11.111-1

    22.222-2 / 33.333-3

    44.444-4 / 44.444-4

    Neste caso eu gostaria que me falasse que foi inserido o numero 33.333-3 (coluna B) e que foi excluido o 22.222-2 (coluna a).

    será que isso é possivel???

    ou tenho que usar outro programa???

    obrigado e aguardo uma resposta sua.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Tente isto:

    Se os valores estão na mesma linha (ex. celula A3 = 22.222-2 celula B3 = 33.333-3, ambos estão na linha 3) então você poderia fazer um comparativo na celula C3:

    =SE(B3=A3;"";CONCATENAR("O VALOR ";A3;" FOI ALTERADO PARA ";B3))

    Agora se elas não estão na mesma linha, precisamos saber como esta a estrutura da sua tabela para podermos ajudar.

    Aguardo retorno.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
  • Autor do tópico
  • o problema é esse, pois tem situações que tem o numero nas duas colunas mas não estão na mesma linha.

    teria que ser a junção dessas duas fórmulas que você me passou para assim ela descobrir quais valores foram adicionados e quais foram excluidos.

    eu poderia te passar uma parte dessa tabela para você analisar??

    pode ser pelo seu e-mail??

    abraços e desculpe incomodar tanto você.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Consegui resolver o seu problema, mas é meio complicado, vamos lá, acho que não é tão fácil...

    Considerando seu exemplo

    -----A------ B

    1 Mês Jan Mês Fev

    2 6.111-1 6.111-1

    3 7.222-2 6.666-6

    4 8.888-8 7.222-2

    Como você quer os dados dos registros que: FORAM INSERIDOS, FORAM EXCLUÍDOS, RESULTADO. Vamos criar mais 3 Colunas que trarão as informações:

    ----------A------------B--------------C--------------D----------------E

    1------Mês-Jan-----Mês-Fev------INSERIDOS-----EXCLUIDOS-----RESULTADOS

    2------6.111-1------6.111-1

    3------7.222-2------6.666-6

    4------8.888-8------7.222-2

    Agora vamos as fórmulas

    Na 1ª célula da Coluna INSERIDOS:

    =SE(SEERRO(PROCV(B2;$A$2:$A$99999;1;FALSO);"")=B2;"";B2)

    Expanda até o desejado

    Na 1ª célula da Coluna EXCLUÍDOS:

    =SE(SEERRO(PROCV(A2;$B$2:$B$99999;1;FALSO);"")=A2;"";A2)

    Expanda até o desejado

    Na 1ª célula da Coluna RESULTADOS:

    =SEERRO(PROCV(B2;$A$2:$A$99999;1;FALSO);B2)

    Expanda até o desejado.

    Bom, é isso, boa sorte.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×