Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Entre para seguir isso  
Fernando Vaz P.

mostrar vezes que o numero repetiu

Recommended Posts

preciso criar um algoritmo que crie um vetor de 36 posiçoes com valores randomicos encontre o valor menor e maior e indique suas posiçoes... precisa também encontrar os valores repetidos e mostrar quantas vezes repetiou

consegui fazer ate encontrar os valores repetidos. e d tanto mexer até consegui uma hora contar certinho... mas na hora de mostrar na tela ele mostra repetindo os valores repetidos (acho q da pra entender hehehe)

tipo se o 10 repetiu 3 vezes ele mostra

10 3 vezes

10 3 vezes

10 3 vezes

+/- isso

aqui vai o que eu ja fiz até empaca nessa parte

var

vet: vetor[1..36] de inteiro

i, j, r, f: inteiro

maior, p_maior, p_menor, menor: inteiro

repet, n_repet: vetor[1..36] de inteiro

seed: inteiro

inicio

seed <- 101

maior <- 0

menor <- seed

escreval("entre com os valores do vetor: ")

para i de 1 ate 36 faca

vet <- randi(seed)

se (vet < menor) então

menor <- vet

p_menor <- i

fimse

se (vet > maior) então

maior <- vet

p_maior <- i

fimse

fimpara

limpatela

escreval(" vetor ")

para i de 1 ate 36 faca

escreva(vet)

fimpara

escreval()

escreval()

escreval("menor valor e:", menor, " na posicao:", p_menor)

escreval()

escreval("maior valor e:", maior, " na posicao:", p_maior)

escreval()

escreval(" numeros repetidos ")

para i de 1 ate 36 passo 1 faca

para j de 1 ate 36 passo 1 faca

se (vet = vet[j]) e (i <> j) então

repet <- vet

n_repet <- n_repet + 1

escreval("o numero",repet," repetiu", n_repet," vez(s)")

fimse

fimpara

fimpara

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×