Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
edcronos

[Resolvido] Excel fazer formatação condicional em "X" se um dos valores em volta for "Y"

Recommended Posts

Ola,

Eu não uso o excel nem para trabalho nem para estudo, apenas para certos projetos pessoais e sei muito pouco a respeito.

estava querendo uma formula, que colocasse formatação condicional se o valor fosse igual a certa celula, E que um dos valores em volta fosse igual a outra certa celula.

Tipo formatação condicional, Se o valor for = Q1 E (um dos valores em volta) for = Q2 “em uma formação tipo jogo da velha”

a planilha só contem numeros, em volta de 4000 linhas e 130 colunas.

se puderem me ajudar agradeço.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Para facilitar poste um exemplo da tua planilha, demonstrando manualmente o resultado esperado, num site gratuito como:

www.sendspace.com

Depois cole o link aqui no fórum.

Att.

Não tem resultado fixo, eu usei formatação condicional, digito o numero que eu quero realçado com alguma cor e o outo, mas fica difícil eu me situar no montante de numeros mostrados.

http://www.sendspace.com/file/ldtez8

acabei editando para ficar mais compreensível

Editado por edcronos

Compartilhar este post


Link para o post
Compartilhar em outros sites

estou achando que com formula na formatação condicional é totalmente inviável,

uma maneira simples e rápida "para quem entende"

talvez seria vba com uma rotina de busca e formatação a cada 4 células numa formação de 2x2 pulando apenas uma celula de cada vez, formatando apenas se forem achados os dois valores.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Será que é mesmo impossível fazer isso?

Se for, por favor alguém fale, e eu continuo de maneira manual mesmo

Editado por edcronos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Com tabelas auxiliares.

Em cada uma delas você irá analisar um dos pares de números. Então é só construir uma fórmula do tipo:

SE o valor da célula for igual ao primeiro número e o valor da célula ao lado for igual ao segundo número retorne SIM. Para isto você irá precisa de um SE com 8 "E" e um "OU".

Aí pode criar a formatação condicional com base nesta tabela auxiliar. Ou seja, se a tabela retornar "sim", pinte de amarelo.

=SE(OU(E(C4=$A$1;D4=$B$1);E(C4=$A$1;D5=$B$1);E(C4=$A$1;C5=$B$1);E(C4=$A$1;B5=$B$1);E(C4=$A$1;B4=$B$1);E(C4=$A$1;B3=$B$1);E(C4=$A$1;C3=$B$1);E(C4=$A$1;D3=$B$1));"SIM";"NÃO")

=SE(OU(

E(C4=$A$1;D4=$B$1);

E(C4=$A$1;D5=$B$1);

E(C4=$A$1;C5=$B$1);

E(C4=$A$1;B5=$B$1);

E(C4=$A$1;B4=$B$1);

E(C4=$A$1;B3=$B$1);

E(C4=$A$1;C3=$B$1);

E(C4=$A$1;D3=$B$1));"SIM";"NÃO")

C4 é a celula que vai ser comparada $A$1

$A$1 é onde se coloca o valor que estamos procurando

D4,D5,C5,B5,B4,B3,C3,D3 são as celulas que vão ser comparadas com $B$1 e que estão em volta de C4.

E(C4=$A$1;D4=$B$1); só retorna "SIM" se C4=$A$1 "e" C4=$A$1

=SE(OU( faz com que se uma dessas regras com "E" for "SIM" então o valor da celula auxiliar sera "SIM"

para se formatar o seu "PAR" se cria outra tabela auxiliar e inverte os valores de $A$1 e $B$1.

para mim ficou bem pesada a tabela, por causa do tamanho mas como não sei fazer diferente, vou ter que me contentar com essa solução que foi um salva vidas.

Editado por edcronos

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor do tópico necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×