Ir ao conteúdo
  • Cadastre-se
Entre para seguir isso  
Junior Borges

[Resolvido] Algoritimos

Recommended Posts

olá pessoal estou tentando fazer dois algoritimos, mas não sei onde eu estou errando, são os algoritimos seguintes:

1) Escreva um algoritimo que leia nome, sexo e altura de uma pessoa. Calcular e apresentar seu peso ideal conforme a tabela abaixo:

Homens: (72,2 x altura) - 58

Mulheres: (62,1 x altura) - 44,7

==========================================================

2)Fazer um algoritimo para uma farmácia que leia bairro do cliente descrição do medicamento e preço do medicamento, informe o valor da tele entrega conforme a tabela abaixo:

Até Vila Rica: R$ 3,00

Até Vila Regina: R$ 5,00

Outros: R$ 4,00

==========================================================

Agradeço desde já !!!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Por gentileza,

Poste seus códigos.. suas tentivas.

Compartilhar este post


Link para o post
Compartilhar em outros sites

1)

 var
string nome sexo;
float altura;

escreva ("Informe o seu nome");
leia (nome);

escreva ("Informe o seu sexo");
leia (sexo);

escreva ("informe a sua altura");
leia (altura);

if (sexo == "m") 72,7* altura - 58 /* AQUI EU NÃO SEI COMO MONTA O CALCULO, SE O CALCULO VAI JUNTO NO PARENTESES DO IF OU NÃO*/

2)

var
string bairro, descricao;
float preco, preco_final

escreva ("Informe o bairro do cliente");
leia (bairro);

escreva ("Informe a descrição do produto");
leia (descricao);

escreva ("informe o valor do produto");
leia (preco);

if (bairro=="Vila Rica"){
escreva("A tele entrega custa R$ 3,00");

else if (bairro=="Vila Regina"){
escreva("A tele entrega custa R$ 5,00");

else (bairro=="Outros"){
escreva("A tele entrega custa R$ 4,00");
}

preco_final --> preco + /* AQUI EU NÃO SEI QUAL VARIÁVEL EU VOU ATRIBUIR PARA FAZER O CÁLCULO */

Compartilhar este post


Link para o post
Compartilhar em outros sites

Então, podes fazer desta forma:




var
nome, sexo: caractere;
altura, peso: real;

escreva ("Informe o seu nome");
leia (nome);

escreva ("Informe o seu sexo");
leia (sexo);

escreva ("informe a sua altura");
leia (altura);

se sexo = "h" então
peso <- (72.2 * altura) - 58
senão
peso <- (62.1 * altura) - 44.7
fimse

escreval("Nome: ",nome)
escreval("Peso Ideal: ",peso)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá,

você precisa estudar um pouco mais de lógica..

Pense. Se você precisa calcular o preço do remédio + a tele entrega.. logo, precisas ter uma variável para o preço da tele entrega.

tente:


var
bairro, descricao: caractere
preco, total, frete: real

escreva ("Informe o bairro do cliente");
leia (bairro);

escreva ("Informe a descrição do produto");
leia (descricao);

escreva ("informe o valor do produto");
leia (preco);

se bairro = "Vila Rica" então
frete <- 3.00
total <- preco + frete
escreva("A tele entrega custa R$ 3,00, Total a pagar: ", total);

senão se bairro="Vila Regina") então
frete <- 5.00
total <- preco + frete
escreva("A tele entrega custa R$ 5,00, Total a pagar: ", total);

senão bairro = "Outros" então
frete <- 4.00
total <- preco + frete
escreva("A tele entrega custa R$ 4,00, total a pagar: ", total);
fimse



Cuide para os blocos.. se você está usando portugol ou visualG.. é "se ", "então", "senão" e "fimse"

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caso o autor necessite, o mesmo será reaberto, para isso deverá entrar em contato com a moderação solicitando o desbloqueio.

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante
Este tópico está impedido de receber novos posts.
Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×