Ir ao conteúdo
  • Cadastre-se
Visitante

Esse Algoritmo em Java?

Recommended Posts

Visitante

Olá amigos, estou estudando algoritmo e Java ao mesmo tempo e assim tudo o que aprendo em algoritmo tento converter em Java. Só que fiquei com uma duvida em relação a esse algoritmo que utiliza comando de repetição.

Como resolveria isso em um aplicativo Java com uma interface gráfica?

segue o algoritmo:

algoritmo "semnome"
// Função :
// Autor :
// Data : 18/9/2013
// Seção de Declarações
var
acumulador,m,somanota,not:real
nome:caractere
n,o,x,y:inteiro



inicio
escreval ("Quantos alunos serão informados?")
leia (y)
acumulador<-0
para x de 1 ate y faca
escreval("Nome:")
leia(nome)
somanota<-0
escreval("Número de notas a ser processada:")
leia(o)
para n de 1 ate o faca
escreval("Nota:")
leia(not)
somanota<- somanota+not
m<- somanota/o

fimpara
acumulador<-acumulador+m
se (m>=70)então
escreval(nome," aprovado com média ",m)
senao
escreval(nome," reprovado com média ",m)
fimse
fimpara
escreval("A média geral da turma é: ",acumulador/y)

// Seção de Comandos
fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

Implementação do algoritmo em java:


import java.util.Scanner;
import java.util.*;

public class SemNome {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);

// variaveis
float acumulador = 0, m = 0, somanota = 0, not = 0;
String nome;
int n, o, x, y;

System.out.println("Quantos alunos serão informados?");
y = scanner.nextInt();

for (x = 1; x <= y; x++) {
System.out.println("Nome: ");
nome = scanner.next();

System.out.println("Número de notas a ser processada:");
o = scanner.nextInt();

for (n = 1; n <= o; n++) {
System.out.println("Nota:");
not = scanner.nextFloat();

somanota = somanota + not;
}
// calcula a media de cada aluno
m = somanota / o;

acumulador = acumulador + m;

if (m >= 70) {
System.out.println(nome + " foi aprovado com média " + m);
} else {
System.out.println(nome + " foi reprovado com média " + m);
}
}

System.out.println("A média geral da turma é: " + acumulador / y);
}
}

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  •    1
    Visitante

    Valeu, funcionou! Só não vejo como transformar isso em uma interface com campo de texto para o usuário colocar as informações e gerar.

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Valeu, funcionou! Só não vejo como transformar isso em uma interface com campo de texto para o usuário colocar as informações e gerar.

    Você terá que usar a classe swing do java, nela tem este método JOptionPane.showInputDialog que mostra uma telinha para digitação, após isso é só recuperar o valor digitado. Pesquise ai que é fácil encontar exemplos diversos na internet, mas para descomplicar um pouco vou te dar uma ideia:


    import javax.swing.JOptionPane;
    public class SaidaNomeJOptionPane {
    public static void main(String[] args) {
    String nome = JOptionPane.showInputDialog("Digite o nome: ");
    String sobreNome = JOptionPane.showInputDialog("Digite o sobrenome: ");
    String nomeCompleto = nome + " " + sobreNome;
    JOptionPane.showMessageDialog(null, "Nome Completo:
    "+nomeCompleto,"Informação",JOptionPane.INFORMATION_MESSAGE);
    }
    }

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites
    Você terá que usar a classe swing do java

    Olá a todos...

    Só complementado a resposta: podem existir outra opções de interface no Java, logo o Swing seria somente "uma" delas... logo em vez de «terá que», sugiro entender-se como "poderá", correto?

    Abraços

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário

    Criar uma conta

    Crie uma nova conta em nossa comunidade. É fácil!

    Crie uma nova conta

    Entrar

    Já tem uma conta? Faça o login.

    Entrar agora





    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×