Ir ao conteúdo
  • Cadastre-se
creuzadopagode

Matriz (Algoritimo)

Recommended Posts

Poderiam me ajudar no seguinte exercício?

Faca um programa que receba:

• As notas de 15 alunos em cinco provas diferentes e armazene-as em uma matriz 15x5;

• Os nomes dos 15 alunos e armazene-os em um vetor de 15 posições.

O programa deverá calcular e mostrar:

• Para cada aluno, o nome, a média aritmética das cinco provas e a situação (aprovado, reprovado ou exame);

• A média da classe

Fiz da seguinte forma, porém não está dando certo :wacko:

algoritmo "Exercico 4"
var
notas: vetor [1..15,1..5] de Inteiro
alunos: vetor [1..15] de Literal
lin,col,cont : Inteiro
media: Real
inicio
Para cont <- 1 ate 15 faca
Escreval ("Digite o nome do aluno")
Leia (alunos[cont])
fimpara
Para lin <- 1 ate 15 faca
Para col <- 1 ate 5 faca
Escreval ("Digite o número do aluno e as 5 notas de cada aluno")
Leia (notas[lin,col])
media <- (notas[lin,col]) + media / 5
fimpara
fimpara
Para lin <- 1 ate 15 faca
Para col <- 1 ate 5 faca
se media >= 70 então
Escreval ("Aluno aprovado")
senao
se (media >= 60) e (media < 70) então
Escreval ("Aluno em exame")
senao
Escreval ("Aluno reprovado")
fimse
fimse
fimpara
fimpara

fimalgoritmo

Compartilhar este post


Link para o post
Compartilhar em outros sites

1º Calculo da média errado

Quando você faz:

(notas[lin,col]) + media / 5

E coloca dentro de um loop está dividindo primeiramente média por cinco e somando com

notas[lin,col] depois, ou seja, você deve fazer a soma dentro do parêntese.

2º Na hora de calcular média dê um tratamento melhor.

Para lin <- 1 ate 15 faca
Para col <- 1 ate 5 faca
se media >= 70 então
Escreval ("Aluno aprovado")
senao
se (media >= 60) e (media < 70) então
Escreval ("Aluno em exame")
senao
Escreval ("Aluno reprovado")
fimse
fimse
fimpara
fimpara

Você tá trabalhando com uma média só ao invés de trabalhar com 15.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×