Ir ao conteúdo
  • Cadastre-se
Pedro Costa_757766

RESOLVIDO Acumular valores numa celula de Excel

Recommended Posts

Gente,

 

Preciso de uma ajuda:

Numa planilha excel criei um macro que limpa os valores das celulas que defini, mas queria que, em simultaneo ele somasse os valores de uma celula (que faz o somatorio da coluna) numa outra celula em outra sheet. Isto é, sempre que limpo os valores do somatórios estes serão adicionados a outra célula.

Alguém pode ajudar, por favor?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Desculpe, infelizmente não entendi nada.

 

Por favor, anexe um arquivo com a estrutura que você está utilizando e os resultados projetados nas referidas células.

 

Eu te ajudo após isso ;)

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ok, pelo o que eu entendi você terá várias mesas e o 'guardar' deve pegar o valor de cada mês e salvar no Caixa Diário para o dia em que a ação for realizada.

 

É isso @Pedro Costa_757766 ?

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja se é isso.

Substitua os seus códigos pelos códigos abaixo.

Sub Macro1() Dim dtDia As Range  With Sheets("Caixa Diário")   Set dtDia = .[A:A].Find(Date)    If Not dtDia Is Nothing Then      dtDia.Offset(, 1).Value = dtDia.Offset(, 1).Value + [K21]    Else: MsgBox "data não encontrada": Exit Sub    End If  End With  Range("G5:G20,I5:I20") = ""End Sub
Sub Macro4() Dim dtDia As Range  With Sheets("Caixa Diário")   Set dtDia = .[A:A].Find(Date)    If Not dtDia Is Nothing Then      dtDia.Offset(, 1).Value = dtDia.Offset(, 1).Value + [E21]    Else: MsgBox "data não encontrada": Exit Sub    End If  End With  Range("A5:A20,C5:C20") = ""End Sub

obs. na sua fórmula abaixo, que está nas colunas "Descrição", foi omitido o último argumento "procurar_intervalo", nesse caso, se o valor procurado não existir, a fórmula retornará o valor mais próximo, o que pode não ser recomendável. Exemplo: a sua lista de Produtos vai de 1 a 5, se você colocar no consumo da mesa o produto 8, seria conveniente que a fórmula retornasse erro (#N/D), como um alerta, pois o produto 8 não existe, no entanto a sua fórmula retornará o valor do produto 5.
=SE(G5="";"";(PROCV(G5;Produtos!$A:$C;2)))

Se quiser testar, adicione o argumento no final da fórmula (em vermelho) e compare os resultados.

=SE(G5="";"";(PROCV(G5;Produtos!$A:$C;2;0)))
 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Ok, pelo o que eu entendi você terá várias mesas e o 'guardar' deve pegar o valor de cada mês e salvar no Caixa Diário para o dia em que a ação for realizada.

 

É isso @Pedro Costa_757766 ?

Basicamente é isso sim... o "guardar" além de "limpar a mesa" salva o valor no caixa diário de forma acumulativa, isto é, vai somando à medida que for servido 

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Pedro Costa_757766 , nosso colega @osvaldomp já passou por cima e respondeu. Acompanhe com ele! :)

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Veja se é isso.

Substitua os seus códigos pelos códigos abaixo.

Sub Macro1() Dim dtDia As Range  With Sheets("Caixa Diário")   Set dtDia = .[A:A].Find(Date)    If Not dtDia Is Nothing Then      dtDia.Offset(, 1).Value = dtDia.Offset(, 1).Value + [K21]    Else: MsgBox "data não encontrada": Exit Sub    End If  End With  Range("G5:G20,I5:I20") = ""End Sub

Resolveu...

Valeu Osvaldo

 

very tks

 

 

Resolveu...

Valeu Osvaldo

 

very tks

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×