Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
victor carneiro fardim

RESOLVIDO Bug chato no driver da NVIDIA para Linux. (micro-stuttering em tudo!)

Recommended Posts

Enfim, estou me irritando um pouco com um bug chatinho que andei notando no meu sistema - a saída de vídeo não é fluída. Uso Xubuntu 14.04 LTS, e basicamente, quando toco vídeos a 60FPS, por exemplo, dá pra notar que tem bastante micro-stuttering, enquanto que no Windows 7 roda lindamente a 60FPS.

 

Fucei o driver proprietário da NVIDIA e não consegui resolver o problema. Então resolvi trocar no próprio driver para a GPU integrada da Intel. Reloguei, e para minha surpresa os vídeos rodaram lindamente a 60FPS!!! (só houve um pouco de tearing porque minha TV funciona a 59.94 Hz e o monitor do meu note funciona a 60Hz). Ou seja, o problema está muito provavelmente no driver da NVIDIA (eu noto que ele é bastante bugado - minha TV fica acima do monitor, e na parte superior do monitor, às vezes ocorrem alguns "bugs", como rastros do cursor do mouse ou atraso - algo que não ocorre quando estou usando a GPU da Intel).

 

Queria saber se alguém sabe a resolução desse problema - não dá pra viver usando a GPU da Intel e tendo que trocar e fazer logoff toda vez que quero jogar, e depois destrocar. Tenho uma Geforce GT 750M.

Compartilhar este post


Link para o post
Compartilhar em outros sites
  • Autor do tópico
  • Resolvi :D

     

    A solução foi instalar o Bumblebee, um projeto que implementa o NVIDIA Optimus e permite trocar a GPU on-the-fly. O sistema usa a GPU Intel, e se você quiser rodar um app com a GPU NVIDIA, você abre ele com o programa "primusrun" (primusrun <nome do app>), e só aquele app é renderizado na GPU NVIDIA e copiado para a GPU Intel :) . Resolveu, não tenho mais micro-stuttering para usar o sistema ou tocar vídeos (já que ele usa a GPU Intel), e até o micro-stuttering nos jogos diminuiu bastante.

     

     

    Antes disso, tentei atualizar o driver para a versão 352.21, mas não adiantou de nadicas.

     

    Suspeito que o bug ficava na parte do driver que copiava o framebuffer para a GPU Intel (o memcpy era lento, talvez...); como o Bumblebee toma conta disso...

    Compartilhar este post


    Link para o post
    Compartilhar em outros sites

    Crie uma conta ou entre para comentar

    Você precisar ser um membro para fazer um comentário






    Sobre o Clube do Hardware

    No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

    Direitos autorais

    Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

    ×