Ir ao conteúdo
  • Cadastre-se
Lucio Carvalho

Como achar a media da turma em visualg?

Recommended Posts

Gente eu tava fazendo uns exercícios e fiquei com duvida nesse, não sei como achar a media da turma e os exemplos desse exercício na internet estão em outra linguagem.

Alguém pode me ajudar?

o que eu fiz:

algoritmo "Ex9Enquantopagina30"
// Função : Criar um algoritmo que entre com quatro notas de cada aluno de uma turma de 20
            //alunos e mostre:
            //- A média de cada aluno;
            //- A média da turma;
            //- Quantos alunos foram aprovados (média 7.0)
// Autor : lucio carvalho
// Data : 27/05/2016
// Seção de Declarações 
var
  n1, n2, n3, n4: real
  aluno: literal
  alunom: real
  turmam: real
  aprovados: real
  i, i2: inteiro
inicio
// Seção de Comandos 
  i:=1
  i2:=0
  aprovados:=0
  enquanto (i<=2) faca
    escreval ("Aluno:")
    leia (aluno)
    escreval ("Nota1:")
    leia (n1)
    escreval ("Nota2:")
    leia (n2)
    escreval ("Nota3:")
    leia (n3)
    escreval ("Nota4:")
    leia (n4)
    i:=i+1
    alunom:= (n1+n2+n3+n4)/4
    escreval ("Média:",alunom)
    i2:=i2+1
    se (alunom>=7) então
      aprovados:=aprovados+1
    fimse
    escreval ("----------------------------------------------------------------")
  fimenquanto
  turmam:= alunom+i
  escreval ("Média da turma:",turmam)
  escreval ("Aprovados:",aprovados)
fimalgoritmo

 

Editado por dif
Melhorar o título e colocar o código dentro do recurso CODE <>

Compartilhar este post


Link para o post
Compartilhar em outros sites

Tópico movido de Programação - outros para Iniciantes

Olá @Lucio Carvalho,

 

Como se calcula uma média? no caso seria basicamente "a soma dos valores dividido pela quantidade de valores"... ou seja, assim como você fez para calcular a média de cada aluno, onde você somou as notas e dividiu por 4, você precisa somar as médias e dividir pela quantidade de médias, no caso por 2.

 

Você também pode somar todas as notas e dividir pela quantidade de notas, no caso por 8 (4*2).

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×