Ir ao conteúdo
  • Cadastre-se
Geovanna Lima

Visualg diz que ele espera encontrar ')' no código?

Recommended Posts

Ola pessoal estou com uma dúvida no VISUALG pois esta dando erro no meu algoritmo e sou iniciante 

 

o algoritmo é esse:

var
origem: inteiro
inicio
escreva  ("1-Sul, 2-Norte, 3-Leste, 4-Oeste")
escreva ("5,6-Nordeste, 7,8,9-Sudeste, 10...20-Centro-Oeste")
escreva ("21...30-Nordeste, 30...-Importado")
leia("informe o codigo da origem do produto: ", origem)
escolha
       caso 1 (origem = 1)
            escreva ("produto do sul")
       caso 2 (origem = 2)
            escreva ("produto do norte")
       caso 3 (origem = 3)
            escreva ("produto do leste")
       caso 4(origem = 4)
            escreva ("produto do oeste")
       caso 5 (origem = 5 | origem = 6)
            escreva ("produto do nordeste")     
       caso 6 (origem = 7 | origem = 8) | origem = 9)
            escreva ("produto do sudeste")
       caso 7 (origem>=10 & origem<=20)
            escreva ("produto do centro-oeste")
       caso 8 (origem>=21 & origem<=30)
            escreva("produto do nordeste")
       caso 9 (origem>30)
            escreva ("produto importado")
fimEscolha
fimalgoritmo

 

 

E o visuALG fala que na linha 13 ele espera encontrar ')'. 

linha 13 seria essa: leia("informe o codigo da origem do produto: ", origem)

 

se alguém me ajudar agradeço muito

Editado por dif
inserir o código com o botão code, mover para lugar correto e melhorar o título

Compartilhar este post


Link para o post
Compartilhar em outros sites

Eita, Geovanna...

O comando leia é utilizado somente para leitura. Utilize um escreva, antes do leia, para fazer o que você esperava.

Até mais!

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×