Ir ao conteúdo
  • Cadastre-se
Vinícius Machado

Programa que calcule a matriz r visualg

Recommended Posts

Faça um programa que preencha uma matriz M (2 X 2), calcule e mostre a matriz R, resultante da multiplicação dos elementos de M pelo seu maior elemento da mesma.

 

 

algortimo matriz
variaveis
    M[2][2], R[2][2], i,j;
    
inicio
    para (i=1;i<=2;i++)
        para(j=1;j<=2;j++)
            Escreva ("Informe um numero inteiro")
            Leia (M[j])
        fimPara
    fimPara
    
    se(M[1][1] > M[1][2] ou M[1][1] > M[2][1] ou M[1][1] > M[2][2])
            R[j] <- M[j]* M[1][1];
        então Escreva("Matriz", R[j])
        
        senao se (M[1][2] > M[1][1] ou M[1][2] > M[2][1] ou M[1][2] > M[2][2])
                R[j] <- M[j]* M[1][2];
            então Escreva("Matriz", R[j])
        
            senao se (M[2][1] > M[1][1] ou M[2][1] > M[1][2] ou M[2][1] > M[2][2])
                    R[j] <- M[j]* M[2][2];
                então Escreva("Matriz", R[j])
                
                senao se (M[2][2] > M[1][1] ou M[2][2] > M[1][2] ou M[2][2] > M[2][1])
                        R[j] <- M[j]* M[2][2];
                    então Escreva("Matriz", R[j])
                    
                    senao Escreva("Todas Matrizes tem o mesmo valor:", M[j])
                
                fimse
                
            fimse
            
        fimse
    
    fimse    
fim


 

Editado por dif
Melhorar o título e inserir o código como botão CODE

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

@Vinícius Machado, qual a sua dúvida? você só postou um enunciado e um código... :)

 

Mas vamos lá..

Sugiro que tente fazer o código aos poucos, e não tudo de uma vez... tente sempre deixar seu código compilável e vá adicionando as estruturas aos poucos. Algo mais ou menos assim:

 

{algortimo matriz} //erro de ortografia e o nome fica entre parânteses
algoritmo "matriz"
{variaveis} //essa não é a sintaxe
var
  {M[2][2], R[2][2], ii,j;} //precisa corrigir essa declaração de variáveis...

  //pesquise na internet como declarar variáveis no VisuAlg, no caso como
  //declarar MATRIZES e INTEIROS.

inicio
{para (ii=1;ii<=2;i++)
   para(j=1;j<=2;j++)}  //pesquise na internet como utilizar o PARA no VisuaAlg
      Escreva ("Informe um numero inteiro")
      Leia (M[ii][j])
   fimPara
fimPara



fimAlgoritmo


Corrija esse trecho... depois insira um trecho para imprimir a Matriz, ou seja, para testar se leu a matriz corretamente. por ai vai...

 

No aguardo.

 

 

 

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×