Ir ao conteúdo
  • Cadastre-se
Fbatistette

RESOLVIDO Problema com delay_ms mikroc

Recommended Posts

Boa tarde senhores!

 

Estou realizando meu TCC utilizando um pic 16f887 copilando no MikroC.

 

O projeto se baseia no controle de 3 motores de passos e 1 servo-motor (formando um braço robótico) para controle de estoque.

 

No programa que fiz estava funcionando certo e com o seguinte uso de memoria.

Used RAM 123 (35%), Free RAM 229 (65%)

Used ROM 2414 (29%), Free ROM 5778 (71%)

 

Porém quando continuo a programa (acrescentando apenas uma linha, com qualquer comando) ele apresenta um erro de estouro de ROM:

 

There is not enough ROM sapce        _Lib_Delays.c

 

Queria saber se alguém já encontrou erro parecido.

 

Grato pela ajuda

Compartilhar este post


Link para o post
Compartilhar em outros sites
Visitante

@Fbatistette Você já tentou quebrar a rotina em pedaços ?  , não sou conhecedor, mas se não me engano tem um limite de ( 2.000 instruções) por pagina .

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×