Ir ao conteúdo
  • Cadastre-se
Gilmar Zezilia Alves

Problema no visualg calculando média errada

Recommended Posts

A média tem que dar 10,8

kg dos peixes

1 (12,0)

2 (10,6)

3 (9,8)

 

Deveria ser assim 

Média 10,8

maior 12,0

menor  9,8

Não sei a onde estou errando

 

  1. algoritmo "semnome"
    // Função :
    // Autor :
    // Data : 11/11/2016
    // Seção de Declarações
    var
    contador : inteiro
    somapeso : real
    pesomenor : real
    pesomaior : real
    peso : real
    inicio
    // Seção de Comandos
    pesomenor <-999999
    escreval ("----------------------------------------------------------")
    escreval ("COOPERATIVA NETURNO PESCAS")
    escreval ("----------------------------------------------------------")
    escreval ("")
    para contador de 1 ate 3 faca
       escreval ("Entre com o peso do ",contador,"° peixe: ")
       leia (peso)
       se peso < pesomenor então
          pesomenor <- peso
       fimse
       se peso > pesomaior então
          pesomaior <- peso
       fimse
       somapeso <- somapeso + peso
    fimpara
    escreval ("")
    escreval ("----------------------------------------------------------")
    escreval ("RESUMO DA PESCA")
    escreval ("----------------------------------------------------------")
    escreval ("")
    escreval ("Ótima pescaria João !")
    escreval ("A média de peso do pexeis foi de:",somapeso / contador,"kg")
    escreval ("O menor peixe pessou: ",pesomenor,"kg")
    escreval ("E o maior peixe pessou: ",pesomaior,"kg")
    escreval ("")
    escreval ("----------------------------------------------------------")
    fimalgoritmo

     

Editado por DiF
Botão CODE <>
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×