Ir ao conteúdo
  • Cadastre-se
Silvio232

Conversão portugol-java

Recommended Posts

Bom dia,

Preciso converter o seguinte código para Java,porém, estou tendo problemas,gostaria de ajuda.

 

var

nome:caracter
idade:inteiro
valhrtrab:real
diasmes:inteiro
d:caracter
n:caracter
turdiario:caracter
diastrabmes: inteiro
horasdia: inteiro
salario: real
inss: real
fgts:real
inicio
escreva("Digite o nome do funcionário: ")
leia(nome)
escreva("Digite a idade do funcionário: ")
leia(idade)
escreva("Digite quantos dias trabalhados no mês: ")
leia(diastrabmes)
repita
escreva("Regime de horas trabalhadas por dia. 6 ou 8 horas?: ")
leia(horasdia)
ate ((horasdia = 6) ou (horasdia = 8))
escreva("Digite o Turno. D para Diurno e N para Noturno ou Pressione S para Sair: ")
leia(turdiario)
se ((turdiario <> "D") e (turdiario <> "N")) então
escreval("Programa Finalizado!!")
fimse
se ((turdiario = "D") e (idade <=50)) então
valhrtrab:= 3
senao
se ((turdiario = "D") e (idade > 50)) então
valhrtrab:= 3 + (3*0.10)
fimse
se ((turdiario = "N") e (idade <=50)) então
valhrtrab:= 4
senao
se ((turdiario = "N") e (idade > 50)) então
valhrtrab:= 4 + (4*0.10)
fimse
fimse
fimse
salario:= (valhrtrab * horasdia* diastrabmes)+ (valhrtrab * horasdia* diastrabmes* 1.5)
fgts:= salario*0.08
se salario<= 1556.94 então
inss:= salario*0.08
senao
se ((salario >=  1556.95) e (salario <= 2594.92)) então
inss:= salario*0.09
senao
se ((salario >= 2594.93) e (salario <= 8189.82)) então
inss:= salario*0.11 senao
fimse fimse
fimse
escreval("O salario bruto é: ",salario)
escreval( "O Total do Depósito do FGTS é: ",fgts)
escreva( "O depósito do INSS é: ", inss)
fimalgoritmo
 

Muito Obrigado.

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá,

 

Em 1o lugar, qq program em java deve ser uma classe e ter um método principal, assim:

 

//Nome da classe deve estar em camel case e ser o mesmo do arquivo (ex MinhaClasse.java)

 

//Classe:

public class MinhaClasse{

    //Método principal (main)
    public static void main(String[] args){
      //Aqui você declara variáveis, código, etc

     }
}

 

Agora uma visão geral da sintaxe pro seu código seria:

 

//Declara variáveis: (Isso deve estar dentro do main) 

 String nome; //texto
  int idade       // inteiro
  float salario   //real

 

*pesquisa sobre tipo de dados em java e veja o que você precisa

 

Para printar no console (escreval) :

System.out.println("Olá, Mundo Java");

 

Para pegar dados do usuário (através do console):

String nome;
Scanner entrada = new Scanner(System.in)
System.out.println("Entre com seu nome");
nome = entrada.nextLine();

 

Condicional if fica:


 

if(nome == "Sergio Cabral"){
  System.out.println("Está em Bangu")
}else{
 // QQ outra coisa que você queira
}

 

 

 

  

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×