Ir ao conteúdo
  • Cadastre-se
Kaio Gomes

Questão: vetor com valores intercalados

Recommended Posts

QUESTÃO:

12)Elabore um algoritmo para ler dois vetores de valores numérico de 10 posições. 

 

a) Gerar e escrever um vetor de 20 posições que receberá nas 10 primeiras posições o conteúdo do primeiro vetor e nas 10 ultimas posições o conteúdo do segundo vetor. 

 

B) Gerar e escrever um vetor de 20 posições com os valores intercalados dos vetores lido.

 

MEU ALGORITMO (Está dando error no v4):

 

algoritmo "Questão 12"

var
i:inteiro
v1: vetor[1..10] de inteiro
v2: vetor[11..20] de inteiro
v3: vetor[1..20] de inteiro
v4: vetor[1..20] de inteiro

inicio
para i de 1 ate 10 faca   // VETOR 1
escreva("Informe um valor:")
leia(v1)
fimpara
 
para i de 11 ate 20 faca   // VETOR 2
escreva("Informe um valor:")
leia(v2)
fimpara
 
para i de 1 ate 10 faca    // VETOR 3(VETOR 1)
v3:=v1
escreva(v3)
fimpara
 
para i de 11 ate 20 faca   // VETOR 3(VETOR 2)
v3:=v2
escreva(v3)
fimpara
 
para i de 1 ate 10 faca
v4[2*i-1]:= v1
para i de 11 ate 20 faca
v4[2*i] := v2
fimpara
 
para i de 1 ate 20 faca
escreval(v4)
fimpara
 
fimalgoritmo

 

AJUDE ME!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
algoritmo "Questão 12"

var
i:inteiro
controle:inteiro
v1: vetor[1..10] de inteiro
v2: vetor[1..10] de inteiro
v3: vetor[1..20] de inteiro
v4: vetor[1..20] de inteiro

inicio
para i de 1 ate 5 faca   // VETOR 1
escreva("Informe um valor:")
leia(v1[i])
fimpara

para i de 1 ate 5 faca   // VETOR 2
escreva("Informe um valor:")
leia(v2[i])
fimpara

para i de 1 ate 5 faca    // VETOR 3(VETOR 1)
v3[i]:=v1[i]
escreva(v3[i])
fimpara

para i de 1 ate 5 faca   // VETOR 3(VETOR 2)
v3[i]:=v2[i]
escreva(v3[i])
fimpara
escreval (" intercalar")
controle:= 0
para i de 1 ate 10 faca
   se i mod 2 = 0 então
     v4[i]:= v2[i div 2]
   senao
     v4[i] := v1[i - controle]
     controle := controle + 1
   fimse
fimpara

para i de 1 ate 10 faca
escreval(v4[i])
fimpara

fimalgoritmo

Muito comovido com o seu.... POR FAVOR... eu resolvi ajudar... #fikaDika

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá @Kaio Gomes e @andbecker.

 

O vetor 3 está sendo gerado errado.

20 horas atrás, Kaio Gomes disse:

QUESTÃO:

12)Elabore um algoritmo para ler dois vetores de valores numérico de 10 posições. 

 

a) Gerar e escrever um vetor de 20 posições que receberá nas 10 primeiras posições o conteúdo do primeiro vetor e nas 10 ultimas posições o conteúdo do segundo vetor. 

 

b ) Gerar e escrever um vetor de 20 posições com os valores intercalados dos vetores lido.

 

De um modo geral, é necessário gerar o vetor, para só depois escrever na tela, da mesma forma que foi feito com o vetor 4.

 

Obs.: não confundir "exibir corretamente" com "gerar corretamente". O foco do problema são os vetores!

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites
5 horas atrás, Simon Viegas disse:

Olá @Kaio Gomes e @andbecker.

 

O vetor 3 está sendo gerado errado.

 

De um modo geral, é necessário gerar o vetor, para só depois escrever na tela, da mesma forma que foi feito com o vetor 4.

 

Obs.: não confundir "exibir corretamente" com "gerar corretamente". O foco do problema são os vetores!

eu nem corrigi o vetor 3, foquei na ajuda.. mas eumudaria tb.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×