Ir ao conteúdo
  • Cadastre-se
ET Bilu

Matrizes - produtos de uma loja

Recommended Posts

Estou extremamente perdido nesse exercício:

 

"Faça um programa que preencha: a. Um vetor de 8 posições, contendo nomes de lojas; b. Outro vetor com quatro posições contendo nomes de produtos; c. Uma matriz com os preços de todos os produtos em cada loja. O programa deverá mostrar todas as relações (nome do produto – nome da loja) em que o preço não ultrapasse R$ 120,00."

 

Como faço para associar uma matriz com dados de caractere?? cada elemento ter sua identificação, buguei. Aqui está o que eu fiz:

 

algoritmo "semnome"
// Função :
// Autor :
// Data : 25/11/2016
// Seção de Declarações
var
v:vetor[1..8] de caractere
v2:vetor[1..4] de caractere
m:vetor[1..8,1..4] de inteiro
l,c,i,i2:inteiro
inicio
para i de 1 ate 8 faca
   escreva("nome da loja")
   leia(v[i])
fimpara
para i de 1 ate 4 faca
   escreva("nome do produto")
   leia(v2[i])
fimpara
para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      escreva
   fimpara
fimpara



fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Parei pra fazer do zero, e parece razoável. 

 

algoritmo "ex5"
// Função :
// Autor :
// Data : 27/11/2016
// Seção de Declarações
var
lojas:vetor[1..8] de caractere
produtos:vetor[1..4] de caractere
precos:vetor[1..8,1..4] de real
i,c,l:inteiro
inicio
para i de 1 ate 8 faca
   escreval("lojas")
   leia(lojas[i])
fimpara
para i de 1 ate 4 faca
   escreval("produtos")
   leia(produtos[i])
fimpara
para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      escreval("preço produto loja ",lojas[c],"produto ",produtos[l])
      leia(precos[c,l])
   fimpara
fimpara
para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      se precos[c,l]<=120 então
         escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l:3])
      fimse
   fimpara
fimpara



fimalgoritmo

E muita coisa e eu n parei p ver se tem erro, pelo gerador de numeros aleatorios me parece funcionável o programa.

adicionado 13 minutos depois

ARRUMADO:

 

algoritmo "ex5"
// Função :
// Autor :
// Data : 27/11/2016
// Seção de Declarações
var
lojas:vetor[1..8] de caractere
produtos:vetor[1..4] de caractere
precos:vetor[1..8,1..4] de real
i,c,l:inteiro
inicio
para i de 1 ate 8 faca
   escreval("lojas")
   leia(lojas[i])
fimpara
para i de 1 ate 4 faca
   escreval("produtos")
   leia(produtos[i])
fimpara
para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      escreval("preço produto ",produtos[l])
      leia(precos[c,l])
      se precos[c,l]<=120 então
         escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l])
      fimse
   fimpara
fimpara
fimalgoritmo

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Em 25/11/2016 às 22:39, ET Bilu disse:

O programa deverá mostrar todas as relações (nome do produto – nome da loja) em que o preço não ultrapasse R$ 120,00."

 

Pelo que eu entendi, você está exibindo os dados da matriz junto com a leitura deles... acho que deveria separar: primeiro ler, depois exibe.

 

PS: por que está utilizando "c" e "l" para matriz? é inicial de algo?

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

4 horas atrás, ET Bilu disse:

Acho que isso eu já tinha consertado.  

 

 

Sobre:

6 horas atrás, Simon Viegas disse:

Pelo que eu entendi, você está exibindo os dados da matriz junto com a leitura deles... acho que deveria separar: primeiro ler, depois exibe.

 

Estou me referindo a esse trecho.

19 horas atrás, ET Bilu disse:

para c de 1 ate 8 faca
   para l de 1 ate 4 faca
      escreval("preço produto ",produtos[l])
      leia(precos[c,l])
      se precos[c,l]<=120 então
         escreval("loja ",lojas[c]," produto ",produtos[l]," preço",precos[c,l])
      fimse
   fimpara
fimpara

 

 

Você está lendo o preço, logo exibindo os dados...

 

Eu não estou dizendo que necessariamente tem que ser separado, mas o seu código acima está junto.

 

Se for como estou sugerindo, primeiro você ler todos os preços... após exibe os dados como foi pedido.

 

  • Curtir 2

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×