Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
Entre para seguir isso  
Ivonelopes

Imprimir Na Com1

Recommended Posts

Oi pessoal,

Estou com problema para imprimir em uma mini-impressora (Bematech MP20-CI)através da serial.

O programa é um clipper, e o suporte da Bematech me mandou o exemplo de programação, mais mesmo assim não consigo imprimir nada. Já com alguns outros programas que peguei para teste ela imprimi.

Estou usando os seguintes comandos:

PARA TESTE EM CLIPPER:

!MODE COM1: 9600,N,8,1

SET DEVICE TO PRINT

SET PRINTER TO COM1

@ 0, 0 SAY "ALGUNA COISA"

SET PRINTER OFF

SET DEVICE TO SCREEN

PARA TESTE EM DOS:

MODE COM1: 9600,N,8,1

DIR "ARQ" >COM1

aqui da :"Erro na Gravação do Arquivo"

Se alguém tiver as manhas e puder me ajudar, fico muito grata.

Compartilhar este post


Link para o post
Compartilhar em outros sites

n sei, mas estou c o mesmo problema, n e o cabo n, eu aqui estou usando o mesmo cabo q uso no unix, como e o cabo q você esta usando, poi n sei p o msdos, queria testar aqui, n sei fazer o cabo...

ate +

Compartilhar este post


Link para o post
Compartilhar em outros sites

Não me lembro direito, mas não tem de ter os dois pontos : na frente de com1?

Assim: dir >com1:

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado p tentar me ajudar.

Para o Tokiinfo, eu já testei com os :, e n funcionou.

Agora, para Italiano, eu tb n sei fazer o cabo, eu comprei ele conforme incicação do fabricante.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Alo pessoal

Copiei isto do post.

PARA TESTE EM DOS:

MODE COM1: 9600,N,8,1

DIR "ARQ" >COM1

aqui da :"Erro na Gravação do Arquivo"

O erro está na linha

DIR "ARQ" >COM1

Usando apenas

dir >com1

deverá imprimir o conteúdo do diretório na impressora da com1

Para imprimir um arquivo, por exemplo, chamado KAKA.txt, use:

type kaka.txt >com1

Post o resultado, por favor'

[]'s

Compartilhar este post


Link para o post
Compartilhar em outros sites

Obrigado Bradley, mais tb não funciona.

Deve ser alguma coisa c o cabo ou com a porta.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Quanto ao cabo, caso seja ambos DB9, 9 pinos, experimente ligar SOMENTE os fios 2,3 e 5, ligando assim:

ligue pino 2 da cpu ao pino 3 da impressora

ligue pino 3 da cpu ao pino 2 da impressora

ligue pino 5 da cpu ao pino 5 da impressora

Nenhum outro fio deve estar ligado, nem na impressora, nem no micro.

Caso a impressora seja DB25, 25 pinos, então ligue assim:

ligue pino 2 da cpu ao pino 2 da impressora

ligue pino 3 da cpu ao pino 3 da impressora

ligue pino 5 da cpu ao pino 7 da impressora

Tente de novo e poste aqui!

Compartilhar este post


Link para o post
Compartilhar em outros sites

tente

dir >prn ao invés de dir >com1

Isso é DOS puro ou tem o Windows no meio? A porta está configurada na BIOS?

Compartilhar este post


Link para o post
Compartilhar em outros sites

Se colocar dir>prn imprime na LPT1, mais quando coloco dir>com1, da erro na gravação do arquivo.

Isso pelo DOS, que é o que estou precisando fazer imprimir, quando pelo pelo windows imprime beleza, o que acho que segnifica que não é cabo e tb acho que a porta esta normal

Obrigado a todos.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Entre para seguir isso  





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×