Ir ao conteúdo
  • Cadastre-se
CristianSantos

VisualG Não consigo executar meu código por causa de um erro de sintaxe na linha 2

Recommended Posts

Meu código aponta erro na linha 2, não consigo executar o código!

(Visualg):


 

algoritmo "Desafio-2"
var
   Nduplica, assegurador, contador, valor, quantidade, nvezes : REAL
   najuda, nde01, nde05, nde010, nde025, nde050, nde1, nde2, nde5: REAL
   //procedimento para menor que 5 centavos
   procedimento menorq5cent()
   inicio
        se nvezes < 5 então
        nde01 <- nvezes
        contageM()
        nvezes <- 0
        assegurador <- 1
        fimse
   fimprocedimento
   //GENERICO
   procedimento Gmenorq5cent()
   inicio

        se ((nvezes < 5) e (nvezes > 0)) então
        nde01 <- nvezes
        fimse
   fimprocedimento
   //escrevendo a contagem
   procedimento contageM()
   inicio
    se Nduplica < 1 então
    Nduplica <- nduplica + 1
    escreval ("Moedas de 1 centavo: ",nde01:1)
    escreval ("Moedas de 5 centavos: ",nde05)
    escreval ("Moedas de 10 centavos: ",nde010)
    escreval ("Moedas de 25 centavos: ",nde025)
    escreval ("Moedas de 50 centavos: ",nde050)
    escreval ("Moedas de 1 real: ",nde1)
    escreval ("Notas de 2 reais: ",nde2)
    escreval ("Notas de 5 reais: ",nde5)
    fimse
    fimprocedimento
    //escrevendo procedimento entre 5 e 10
    procedimento entre5e10()
    inicio
    se nvezes = 10 então
      nde010 <- nde010 + 1
      contageM()
    fimse
    se (((nvezes < 10) e (nvezes > 5)) ou (nvezes = 5)) então
    nvezes <- nvezes - 5
    nde05 <- nde05 + 1
    fimse
     se ((nvezes < 5) e (assegurador = 0)) então //o assegurador impede de outra função < 5 crie uma contagem
    nde01 <- nvezes
    contageM()
    nvezes <- 0
 fimse
 fimprocedimento
 //GENERICO
 procedimento Gentre5e10()
    inicio
    se nvezes = 10 então
      nde010 <- nde010 + 1
    fimse
    se (((nvezes < 10) e (nvezes > 5)) ou (nvezes = 5)) então
    nvezes <- nvezes - 5
    nde05 <- nde05 + 1
    fimse
     se (nvezes < 5) então //o assegurador impede de outra função < 5 crie uma contagem
    Gmenorq5cent()
 fimse
 fimprocedimento
 // Maior que 10
 procedimento maior010()
 inicio
   se ((nvezes > 10) e ( nvezes < 25)) então // fui atento
      se nvezes >= 20 então
        nvezes <- nvezes - 20
        nde010 <- nde010 + 2
        Gmenorq5cent()
      fimse
      se ((nvezes < 20) e (nvezes >= 10))  então
         nvezes <- nvezes - 10
         nde010  <- nde010 + 1
         //escreva ("passei")
         se ((nvezes > 5) e (nvezes < 10)) então
            Gentre5e10()
         fimse
         se nvezes = 5 então
         nde05 <- nde05 + 1
         fimse
         se nvezes < 5 então
         Gmenorq5cent()
         fimse
      fimse
      contageM() //Sempre colocar a contagem no final do escopo
   fimse

 fimprocedimento
 //GENERICO
 procedimento Gmaior010()
 inicio
   se ((nvezes > 10) e ( nvezes < 25)) então // fui atento
      se nvezes >= 20 então
        nvezes <- nvezes - 20
        nde010 <- nde010 + 2
        Gmenorq5cent()
      fimse
      //se nvezes = 20 então
        // nde010 <- nde010 + 2
         //nvezes <- 0
     // fimse
      se ((nvezes < 20) e (nvezes > 5)) então
         nvezes <- nvezes -10
         nde010  <- nde010 + 1
         se nvezes = 5 então
         nde05 <- nde05 + 1
         fimse
         se ((nvezes > 5) e (nvezes < 10)) então
         Gentre5e10()
         fimse
        // se ((nvezes > 0) e (nvezes < 5)) então
         //Gmenorq5cent()
        // fimse
      fimse
   fimse

 fimprocedimento
 //maior que 25 e menor que 50
 procedimento maior025()
 inicio
   se ((nvezes >= 25) e ( nvezes <= 50)) então
      se nvezes = 50 então
         nde050 <- nde050 + 1
         nvezes  <- nvezes - 50
      fimse
      se (nvezes > 40) então
        nde025 <- nde025 + 1
        nvezes <- nvezes - 25
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
        fimse
      se (nvezes > 30 ) então
             nvezes <- nvezes - 25
             nde025 <- nde025 + 1
             Gmaior010()
             Gentre5e10()
             Gmenorq5cent()
      fimse
      se((nvezes > 24) e (nvezes < 31)) então
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse

 fimprocedimento
 //GENERICO
 procedimento Gmaior025()
 inicio
   se ((nvezes >= 25) e ( nvezes <= 50)) então
      se nvezes = 50 então
         nde050 <- nde050 + 1
         nvezes  <- nvezes - 50
      fimse
      se (nvezes > 40) então
        nde025 <- nde025 + 1
        nvezes <- nvezes - 25
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
        fimse
      se (nvezes > 30 ) então
             nvezes <- nvezes - 25
             nde025 <- nde025 + 1
             Gmaior010()
             Gentre5e10()
             Gmenorq5cent()
      fimse
      se((nvezes > 24) e (nvezes < 31)) então
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gentre5e10()
         Gmenorq5cent()
      fimse
   fimse
 fimprocedimento
 
//Começo do  50 até 1 real
procedimento maior050()
inicio
  se ((nvezes > 50) e (nvezes <= 100)) então
     se nvezes = 100 então
        nde1  <- nde1 + 1
        nvezes <- 0
     fimse
     se ((nvezes > 75) e (nvezes < 100)) então
      nde025 <- nde025 + 1
      nde050 <- nde050 + 1
      nvezes <- nvezes - 75
      Gmaior010()
      Gentre5e10()
      Gmenorq5cent()
     fimse
     se nvezes = 75 então
        nde050 <- nde050 + 1
        nde025 <- nde025 + 1
        nvezes <- 0
     fimse
     se ((nvezes > 50) e (nvezes < 75)) então
        nvezes <- nvezes -50
        nde050 <- nde050 + 1
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
  contageM()
  fimse
fimprocedimento
//GENERICO
procedimento Gmaior050()
inicio
  se ((nvezes > 50) e (nvezes <= 100)) então
     se nvezes = 100 então
        nde1  <- nde1 + 1
        nvezes <- 0
     fimse
     se ((nvezes > 75) e (nvezes < 100)) então
      nde025 <- nde025 + 1
      nde050 <- nde050 + 1
      nvezes <- nvezes - 75
      Gmaior010()
      Gentre5e10()
      Gmenorq5cent()
     fimse
     se nvezes = 75 então
        nde050 <- nde050 + 1
        nde025 <- nde025 + 1
        nvezes <- 0
     fimse
     se ((nvezes > 50) e (nvezes < 75)) então
        nvezes <- nvezes -50
        nde050 <- nde050 + 1
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
  fimse
fimprocedimento
procedimento maior1()
  inicio
  se ((nvezes > 100) e (nvezes <= 200)) então
    se nvezes = 200 então
       nde2 <- nde2 + 1
       nvezes <- 0
    fimse
    se ((nvezes <= 150) e (nvezes > 0)) então
       nvezes <- nvezes - 100
       nde1 <- nde1 + 1
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
    se ((nvezes > 150) e (nvezes < 200)) então
       nde1 <- nde1 + 1
       nde050 <- nde050 + 1
       nvezes <- nvezes - 150
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
    se ((nvezes < 150) e (nvezes > 100)) então
       nvezes <- nvezes - 100
       nde1 <- nde1 + 1
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
  contageM()
  fimse
fimprocedimento
//GENERICO
procedimento Gmaior1()
  inicio
  se ((nvezes > 100) e (nvezes <= 200)) então
    se nvezes = 200 então
       nde2 <- nde2 + 1
       nvezes <- 0
    fimse
    se ((nvezes <= 150) e (nvezes > 0)) então
       nvezes <- nvezes - 100
       nde1 <- nde1 + 1
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
    se ((nvezes > 150) e (nvezes < 200)) então
       nde1 <- nde1 + 1
       nde050 <- nde050 + 1
       nvezes <- nvezes - 150
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
    se ((nvezes < 150) e (nvezes > 100)) então
       nvezes <- nvezes - 100
       nde1 <- nde1 + 1
       Gmaior025()
       Gmaior010()
       Gentre5e10()
       Gmenorq5cent()
    fimse
  fimse
fimprocedimento
// Elaborando procedimento maior que 2
procedimento maior2()
inicio
  se ((nvezes > 200) e (nvezes <=500)) então
     se nvezes = 500 então
           nde5 <- nde5 + 1
           nvezes <- 0
     fimse
     se ((nvezes >= 400) e (nvezes < 500))então  // TEM ALGO ERRADO
        nvezes <- nvezes -400
        nde2 <- nde2 + 2
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     se ((nvezes > 300) e (nvezes <400)) então
        nvezes <- nvezes -300
        nde2 <- nde2 + 1
        nde1 <- nde1 + 1
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     se ((nvezes > 200) e (nvezes <=300)) então
        nvezes <- nvezes -200
        nde2 <- nde2 + 1
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     contageM()
  fimse
fimprocedimento
fimprocedimento
// GENERICO
procedimento Gmaior2()
inicio
  se ((nvezes > 200) e (nvezes <=500)) então
     se nvezes = 500 então
           nde5 <- nde5 + 1
           nvezes <- 0
     fimse
     se ((nvezes >= 400) e (nvezes < 500))então  // TEM ALGO ERRADO
        nvezes <- nvezes -400
        nde2 <- nde2 + 2
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     se ((nvezes > 300) e (nvezes <400)) então
        nvezes <- nvezes -300
        nde2 <- nde2 + 1
        nde1 <- nde1 + 1
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     se ((nvezes > 200) e (nvezes <=300)) então
        nvezes <- nvezes -200
        nde2 <- nde2 + 1
        maior050()
        Gmaior025()
        Gmaior010()
        Gentre5e10()
        Gmenorq5cent()
     fimse
     contageM()
  fimse
//percebendo valores maiores que 5
inicio

 contador <- 0
 quantidade <- 0
 escreva("valor: " )
 leia(valor)
 nvezes <- valor/0.01 // número de vezes que o 0.01 será usado
 //Percebendo valores menores que 5 centavos
 menorq5cent()
 //Percebendo valores menores que 10 centavos
 entre5e10()
 maior010()
 maior025()
 maior050()
 maior1()
 maior2()
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Estranho... acho que é devido ao tamanho do programa...

 

Estou fazendo alguns testes aqui....

adicionado 14 minutos depois

Reindentei o seu código e achei o erro...

 

algoritmo "Desafio-2"
var
   Nduplica, assegurador, contador, valor, quantidade, nvezes : REAL
   najuda, nde01, nde05, nde010, nde025, nde050, nde1, nde2, nde5: REAL

//procedimento para menor que 5 centavos
procedimento menorq5cent()
   inicio
   se nvezes < 5 ENTÃO
      nde01 <- nvezes
      contageM()
      nvezes <- 0
      assegurador <- 1
   fimse
fimprocedimento

//GENERICO
procedimento Gmenorq5cent()
   inicio
   se ((nvezes < 5) e (nvezes > 0)) ENTÃO
      nde01 <- nvezes
   fimse
fimprocedimento

//escrevendo a contagem
procedimento contageM()
   inicio
   se Nduplica < 1 ENTÃO
      Nduplica <- nduplica + 1
      escreval ("Moedas de 1 centavo: ",nde01:1)
      escreval ("Moedas de 5 centavos: ",nde05)
      escreval ("Moedas de 10 centavos: ",nde010)
      escreval ("Moedas de 25 centavos: ",nde025)
      escreval ("Moedas de 50 centavos: ",nde050)
      escreval ("Moedas de 1 real: ",nde1)
      escreval ("Notas de 2 reais: ",nde2)
      escreval ("Notas de 5 reais: ",nde5)
   fimse
fimprocedimento

//escrevendo procedimento entre 5 e 10
procedimento entre5e10()
   inicio
   se nvezes = 10 ENTÃO
      nde010 <- nde010 + 1
      contageM()
   fimse
   se (((nvezes < 10) e (nvezes > 5)) ou (nvezes = 5)) ENTÃO
      nvezes <- nvezes - 5
      nde05 <- nde05 + 1
   fimse
   se ((nvezes < 5) e (assegurador = 0)) ENTÃO //o assegurador impede de outra função < 5 crie uma contagem
      nde01 <- nvezes
      contageM()
      nvezes <- 0
   fimse
fimprocedimento

//GENERICO
procedimento Gentre5e10()
   inicio
   se nvezes = 10 ENTÃO
      nde010 <- nde010 + 1
   fimse
   se (((nvezes < 10) e (nvezes > 5)) ou (nvezes = 5)) ENTÃO
      nvezes <- nvezes - 5
      nde05 <- nde05 + 1
   fimse
   se (nvezes < 5) ENTÃO //o assegurador impede de outra função < 5 crie uma contagem
      Gmenorq5cent()
   fimse
fimprocedimento

// Maior que 10
procedimento maior010()
   inicio
   se ((nvezes > 10) e ( nvezes < 25)) ENTÃO // fui atento
      se nvezes >= 20 ENTÃO
         nvezes <- nvezes - 20
         nde010 <- nde010 + 2
         Gmenorq5cent()
      fimse
      se ((nvezes < 20) e (nvezes >= 10))  ENTÃO
         nvezes <- nvezes - 10
         nde010  <- nde010 + 1
         //escreva ("passei")
         se ((nvezes > 5) e (nvezes < 10)) ENTÃO
            Gentre5e10()
         fimse
         se nvezes = 5 ENTÃO
            nde05 <- nde05 + 1
         fimse
         se nvezes < 5 ENTÃO
            Gmenorq5cent()
         fimse
      fimse
      contageM() //Sempre colocar a contagem no final do escopo
   fimse
fimprocedimento

//GENERICO
procedimento Gmaior010()
   inicio
   se ((nvezes > 10) e ( nvezes < 25)) ENTÃO // fui atento
      se nvezes >= 20 ENTÃO
         nvezes <- nvezes - 20
         nde010 <- nde010 + 2
         Gmenorq5cent()
      fimse
      //se nvezes = 20 ENTÃO
         // nde010 <- nde010 + 2
         //nvezes <- 0
      // fimse
      se ((nvezes < 20) e (nvezes > 5)) ENTÃO
         nvezes <- nvezes -10
         nde010  <- nde010 + 1
      se nvezes = 5 ENTÃO
         nde05 <- nde05 + 1
      fimse
      se ((nvezes > 5) e (nvezes < 10)) ENTÃO
         Gentre5e10()
      fimse
      // se ((nvezes > 0) e (nvezes < 5)) ENTÃO
         //Gmenorq5cent()
      // fimse
      fimse
   fimse
fimprocedimento

//maior que 25 e menor que 50
procedimento maior025()
   inicio
   se ((nvezes >= 25) e ( nvezes <= 50)) ENTÃO
      se nvezes = 50 ENTÃO
         nde050 <- nde050 + 1
         nvezes  <- nvezes - 50
      fimse
      se (nvezes > 40) ENTÃO
         nde025 <- nde025 + 1
         nvezes <- nvezes - 25
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se (nvezes > 30 ) ENTÃO
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se((nvezes > 24) e (nvezes < 31)) ENTÃO
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse
fimprocedimento

//GENERICO
procedimento Gmaior025()
   inicio
   se ((nvezes >= 25) e ( nvezes <= 50)) ENTÃO
      se nvezes = 50 ENTÃO
         nde050 <- nde050 + 1
         nvezes  <- nvezes - 50
      fimse
      se (nvezes > 40) ENTÃO
         nde025 <- nde025 + 1
         nvezes <- nvezes - 25
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se (nvezes > 30 ) ENTÃO
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se((nvezes > 24) e (nvezes < 31)) ENTÃO
         nvezes <- nvezes - 25
         nde025 <- nde025 + 1
         Gentre5e10()
         Gmenorq5cent()
      fimse
   fimse
fimprocedimento

//Começo do  50 até 1 real
procedimento maior050()
   inicio
   se ((nvezes > 50) e (nvezes <= 100)) ENTÃO
      se nvezes = 100 ENTÃO
         nde1  <- nde1 + 1
         nvezes <- 0
      fimse
      se ((nvezes > 75) e (nvezes < 100)) ENTÃO
         nde025 <- nde025 + 1
         nde050 <- nde050 + 1
         nvezes <- nvezes - 75
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se nvezes = 75 ENTÃO
         nde050 <- nde050 + 1
         nde025 <- nde025 + 1
         nvezes <- 0
      fimse
      se ((nvezes > 50) e (nvezes < 75)) ENTÃO
         nvezes <- nvezes -50
         nde050 <- nde050 + 1
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse
fimprocedimento

//GENERICO
procedimento Gmaior050()
   inicio
   se ((nvezes > 50) e (nvezes <= 100)) ENTÃO
      se nvezes = 100 ENTÃO
         nde1  <- nde1 + 1
         nvezes <- 0
      fimse
      se ((nvezes > 75) e (nvezes < 100)) ENTÃO
         nde025 <- nde025 + 1
         nde050 <- nde050 + 1
         nvezes <- nvezes - 75
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se nvezes = 75 ENTÃO
         nde050 <- nde050 + 1
         nde025 <- nde025 + 1
         nvezes <- 0
      fimse
      se ((nvezes > 50) e (nvezes < 75)) ENTÃO
         nvezes <- nvezes -50
         nde050 <- nde050 + 1
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
   fimse
fimprocedimento
   
procedimento maior1()
   inicio
   se ((nvezes > 100) e (nvezes <= 200)) ENTÃO
      se nvezes = 200 ENTÃO
         nde2 <- nde2 + 1
         nvezes <- 0
      fimse
      se ((nvezes <= 150) e (nvezes > 0)) ENTÃO
         nvezes <- nvezes - 100
         nde1 <- nde1 + 1
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 150) e (nvezes < 200)) ENTÃO
         nde1 <- nde1 + 1
         nde050 <- nde050 + 1
         nvezes <- nvezes - 150
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes < 150) e (nvezes > 100)) ENTÃO
         nvezes <- nvezes - 100
         nde1 <- nde1 + 1
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse
fimprocedimento
   
//GENERICO
procedimento Gmaior1()
   inicio
   se ((nvezes > 100) e (nvezes <= 200)) ENTÃO
      se nvezes = 200 ENTÃO
         nde2 <- nde2 + 1
         nvezes <- 0
      fimse
      se ((nvezes <= 150) e (nvezes > 0)) ENTÃO
         nvezes <- nvezes - 100
         nde1 <- nde1 + 1
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 150) e (nvezes < 200)) ENTÃO
         nde1 <- nde1 + 1
         nde050 <- nde050 + 1
         nvezes <- nvezes - 150
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes < 150) e (nvezes > 100)) ENTÃO
         nvezes <- nvezes - 100
         nde1 <- nde1 + 1
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
   fimse
 fimprocedimento
   
// Elaborando procedimento maior que 2
procedimento maior2()
   inicio
   se ((nvezes > 200) e (nvezes <=500)) ENTÃO
      se nvezes = 500 ENTÃO
         nde5 <- nde5 + 1
         nvezes <- 0
      fimse
      se ((nvezes >= 400) e (nvezes < 500))ENTÃO  // TEM ALGO ERRADO
         nvezes <- nvezes -400
         nde2 <- nde2 + 2
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 300) e (nvezes <400)) ENTÃO
         nvezes <- nvezes -300
         nde2 <- nde2 + 1
         nde1 <- nde1 + 1
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 200) e (nvezes <=300)) ENTÃO
         nvezes <- nvezes -200
         nde2 <- nde2 + 1
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse
fimprocedimento
{fimprocedimento} //Comando sem correspondência ou fora do lugar [Simon.Viegas]

// GENERICO
procedimento Gmaior2()
   inicio
   se ((nvezes > 200) e (nvezes <=500)) ENTÃO
      se nvezes = 500 ENTÃO
         nde5 <- nde5 + 1
         nvezes <- 0
      fimse
      se ((nvezes >= 400) e (nvezes < 500))ENTÃO  // TEM ALGO ERRADO
         nvezes <- nvezes -400
         nde2 <- nde2 + 2
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 300) e (nvezes <400)) ENTÃO
         nvezes <- nvezes -300
         nde2 <- nde2 + 1
         nde1 <- nde1 + 1
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      se ((nvezes > 200) e (nvezes <=300)) ENTÃO
         nvezes <- nvezes -200
         nde2 <- nde2 + 1
         maior050()
         Gmaior025()
         Gmaior010()
         Gentre5e10()
         Gmenorq5cent()
      fimse
      contageM()
   fimse
fimprocedimento //faltou fechar o procedimento (provavelmente aquele comando lá em cima) [Simon.Viegas]
   
//percebendo valores maiores que 5
inicio
contador <- 0
quantidade <- 0
escreva("valor: " )
leia(valor)
nvezes <- valor/0.01 // número de vezes que o 0.01 será usado
//Percebendo valores menores que 5 centavos
menorq5cent()
//Percebendo valores menores que 10 centavos
entre5e10()
maior010()
maior025()
maior050()
maior1()
maior2()
fimalgoritmo

 

No aguardo.

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×