Ir ao conteúdo
  • Cadastre-se
Brendo Souza

Portugol Coleta e análise de questionário

Recommended Posts

Bom dia, gostaria que alguém me ajudasse a identificar o erro de um algoritmo para o seguinte exercício: Um cinema possui capacidade de 30 lugares e está sempre com ocupação total. Certo dia, cada espectador respondeu a um questionário (sendo assim 30 pessoas responderam o questionário), no qual constava sua idade e sua opinião em relação ao filme, segundo as seguintes notas: 5 – ótimo, 4 –bom, 3 – Regular, 2 – Ruim, 1 – Péssimo. Elabore um algoritmo que leia estes dados, calcule e imprima: a quantidade de respostas de cada tipo; a média de idade das pessoas que responderam ruim;  a percentagem de respostas péssimo e a maior idade que utilizou esta opção; média de idade das pessoas que responderam  ótimo ou bom. Fazer o exercício sem usar vetores, caso o aluno saiba como utilizar vetores.

 

//cinema

inicio

   Nota, cont, contNT1, contNT2, contNT3, contNT4, contNT5 inteiro;
   maioridd, idade, idade1, idade2, idade4, idade5 inteiro;
   mediabo, mediar real;
   percentagem real;

   contNT1=0;
   contNT2=0;
   contNT3=0;
   contNT4=0;
   contNT5=0;
   Nota=0;
   idade1=0;
   idade2=0;
   idade4=0;
   idade5=0;
   idade=0;
   mediabo=0;
   mediar=0;

   Para cont de 1 até 30 passo 1 faça
      Escreva ("Digite a sua idade: ");
      Leia (idade);
      Escreva ("Digite uma nota, 5 -ótimo, 4 -bom, 3 -regular, 2 -ruim, 1 -péssimo: ");
      Leia (Nota);
      se Nota == 1 faça
         contNT1 = contNT1+1;
         maioridd=idade;
         idade>maioridd;
         maioridd=idade;
         senaose Nota==2 faça
         contNT2 = contNT2+1;
         idade2 = idade2+idade
         senaose Nota==3 faça
         contNT3 = contNT3+1;
         senaose Nota==4 faça
         contNT4 = contNT4+1;
         idade4 = idade4+idade
         senaose Nota==5 faça
         contNT5 = contNT5+1;
         idade5 = idade5+idade
      fimse
   fimse
fimse
fimse
fimse
fimpara
mediabo= idade5+idade4/(contNT5+contNT4);
mediar= idade2/contNT2;
percentagem=(contNT1*100)/30;
Escreval ("A quantidade de pessoas que responderam Ótimo foi: ", contNT5);
Escreval ("A quantidade de pessoas que responderam Bom foi: ", contNT4);
Escreval ("A quantidade de pessoas que responderam Regular foi: ", contNT3);
Escreval ("A quantidade de pessoas que responderam Ruim foi: ", contNT2);
Escreval ("A quantidade de pessoas que responderam Péssimo foi: ", contNT1);
Escreval ("A percentagem de pessoas que responderam Péssimo foi de: ", percentagem);
Escreval ("A idade da pessoa mais velha que respondeu Péssimo é: ". maioridd);
Escreval ("A média de idade das pessoas que responderam ruin foi: ", mediar);
Escreval ("A média de idade das pessoas que responderam bom ou ótimo foi: ", mediabo);
fim

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×