Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Gnomo Psicodélico

C Conflito entre IF e Shellexecute

Recommended Posts

 Criei um programa onde se adiciona sites, eu adicionei um char e usei ele pra comparar se um COMBOBOX estava vazio, caso esteja ele avisa que não pode ficar em branco e para.
 Eu adiciono um site e quando clico pra abrir ele abre normal, mas se eu adicionar um site deixar em branco e clicar ele me aparece o aviso (até ai tudo ok), logo em seguida eu adiciono um link e ele simplesmente não faz nada quando eu clico pra abrir.
 Porque isso?

 

					FILE *c18;
					FILE *n18;
					FILE *hist;
					char comp;
					c18 = fopen("BD\\TV\\C18\\C18.bat","w+");
					n18 = fopen("BD\\TV\\C18\\N18.txt","w+");
					hist = fopen("BD\\TV\\HISTORICO\\H.txt","a+");
					TCHAR bufferItemField[FIELD_LENGTH];
					TCHAR bufferItemField2[FIELD_LENGTH];
                    comp = GetWindowText(gCanal18, bufferItemField, FIELD_LENGTH);
                    GetWindowText(nCanal18, bufferItemField2, FIELD_LENGTH);
                    SendMessage(GC18,LB_INSERTSTRING,0,(LPARAM)bufferItemField2);
                    if(comp == NULL)
                    {
                    	MessageBox(0,"LINK NÃO PODE FICAR EM BRANCO","ERRO",0);
				    	break;
					}					
                    fprintf(c18,"start ");
					fprintf(c18,bufferItemField);
					fprintf(n18,bufferItemField2);
					fprintf(hist,bufferItemField2);
					fprintf(hist,"\n");
					fclose(hist);
					fclose(c18);
					fclose(n18);


 A parte do código que executa o arquivo .bat pra abrir o site 
 

ShellExecute(NULL,"open","BD\\TV\\C18\\C18.bat",NULL,NULL,SW_HIDE);
					break;


 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×