Ir ao conteúdo
  • Cadastre-se
Maique da Silva Araújo

VisualG Resolução de Exercício no Visualg

Recommended Posts

algoritmo "Média e comparação"
var
notas: vetor [1..10] de inteiro
x, maior_media, soma: inteiro
media: real
inicio
escreval("Digite as 10 notas: ")
para x de 1 ate 10 faca
leia(notas[x])
soma<- (em="" x="" notas="" soma="">)
media<- (10="" em="" soma="">)
fimpara
escreval("A Soma das notas é: ",soma)
escreval("A média das notas é: ",media)
escreval("Os valores maiores que a média são: ")
para i de 1 ate 10 faca
se(notas[x] > media) então
maior_media<- em="" x="" notas="">
escreval(maior_media)
fimse
fimpara
fimalgoritmo

Olá amigos, tendo em vista não ter domínio na linguagem do visualg, estou com um problema para executar esse algoritmo. Gostariam que me ajudassem a corrigi-lo

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

1#

@Maique da Silva Araújo, segue um código ajustado. No caso servir de referência.

algoritmo "Média e comparação"
var
   notas: vetor [1..10] de inteiro
   x, maior_media, soma: inteiro
   media: real
inicio
escreval("Digite as 10 notas: ")
para x de 1 ate 10 faca
   leia(notas[x])
   soma  <- soma + notas[x] //vai adicionando as notas
fimpara
media <- soma / 10 //media = total / quantidade (fica fora do laço, pois só precisa ser feito uma vez)
escreval("A Soma das notas é : ",soma)
escreval("A média das notas é: ",media)
escreva ("Os valores maiores que a média são: ") 
para x de 1 ate 10 faca
   se(notas[x] > media) ENTÃO //se nota maior que a média
      escreva (notas[x]," ") //escreve a nota, e dá um espaço (pois vai ficar um no lado da outra)
   fimse
fimpara
fimalgoritmo

 

 

 

2#

Segue código utilizando o conceito de ALEATÓRIO.

algoritmo "Média e comparação"
var
   notas: vetor [1..10] de inteiro
   x, maior_media, soma: inteiro
   media: real
inicio
escreval("Digite as 10 notas: ")
ALEATORIO 2,10 //gerar número entre 2 e 10 (inclusos)
para x de 1 ate 10 faca
   leia(notas[x]) //<---vai sortear um número a cada leia() encontrado (simula um usuário digitando o número)
   soma  <- soma + notas[x] //vai adicionando as notas
fimpara
ALEATORIO OFF //aqui delimita o fim, ou seja, o comando só vale para o que está entre os comandos ALEATORIO
media <- soma / 10 //media = total / quantidade
escreval("A Soma das notas é : ",soma)
escreval("A média das notas é: ",media)
escreva ("Os valores maiores que a média são: ")
para x de 1 ate 10 faca
   se(notas[x] > media) ENTÃO
      escreva (notas[x]," ")
   fimse
fimpara
fimalgoritmo

Não tem mistério... o comando ALEATÓRIO apenas faz o papel do usuário digitar... só funciona na parte que está entre o ALEAOTIORIO X, Y   e   ALEATORIO OFF.

***

 

No aguardo.

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×