Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Maique da Silva Araújo

VisualG Resolução de Exercício no Visualg

Recommended Posts

Postado (editado)
algoritmo "Média e comparação"
var
notas: vetor [1..10] de inteiro
x, maior_media, soma: inteiro
media: real
inicio
escreval("Digite as 10 notas: ")
para x de 1 ate 10 faca
leia(notas[x])
soma<- (em="" x="" notas="" soma="">)
media<- (10="" em="" soma="">)
fimpara
escreval("A Soma das notas é: ",soma)
escreval("A média das notas é: ",media)
escreval("Os valores maiores que a média são: ")
para i de 1 ate 10 faca
se(notas[x] > media) então
maior_media<- em="" x="" notas="">
escreval(maior_media)
fimse
fimpara
fimalgoritmo

Olá amigos, tendo em vista não ter domínio na linguagem do visualg, estou com um problema para executar esse algoritmo. Gostariam que me ajudassem a corrigi-lo

Editado por Maique da Silva Araújo
não use negrito extensivamente, isso é contra as regras do fórum
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

1#

@Maique da Silva Araújo, segue um código ajustado. No caso servir de referência.

algoritmo "Média e comparação"
var
   notas: vetor [1..10] de inteiro
   x, maior_media, soma: inteiro
   media: real
inicio
escreval("Digite as 10 notas: ")
para x de 1 ate 10 faca
   leia(notas[x])
   soma  <- soma + notas[x] //vai adicionando as notas
fimpara
media <- soma / 10 //media = total / quantidade (fica fora do laço, pois só precisa ser feito uma vez)
escreval("A Soma das notas é : ",soma)
escreval("A média das notas é: ",media)
escreva ("Os valores maiores que a média são: ") 
para x de 1 ate 10 faca
   se(notas[x] > media) ENTÃO //se nota maior que a média
      escreva (notas[x]," ") //escreve a nota, e dá um espaço (pois vai ficar um no lado da outra)
   fimse
fimpara
fimalgoritmo

 

 

 

2#

Segue código utilizando o conceito de ALEATÓRIO.

algoritmo "Média e comparação"
var
   notas: vetor [1..10] de inteiro
   x, maior_media, soma: inteiro
   media: real
inicio
escreval("Digite as 10 notas: ")
ALEATORIO 2,10 //gerar número entre 2 e 10 (inclusos)
para x de 1 ate 10 faca
   leia(notas[x]) //<---vai sortear um número a cada leia() encontrado (simula um usuário digitando o número)
   soma  <- soma + notas[x] //vai adicionando as notas
fimpara
ALEATORIO OFF //aqui delimita o fim, ou seja, o comando só vale para o que está entre os comandos ALEATORIO
media <- soma / 10 //media = total / quantidade
escreval("A Soma das notas é : ",soma)
escreval("A média das notas é: ",media)
escreva ("Os valores maiores que a média são: ")
para x de 1 ate 10 faca
   se(notas[x] > media) ENTÃO
      escreva (notas[x]," ")
   fimse
fimpara
fimalgoritmo

Não tem mistério... o comando ALEATÓRIO apenas faz o papel do usuário digitar... só funciona na parte que está entre o ALEAOTIORIO X, Y   e   ALEATORIO OFF.

***

 

No aguardo.

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×