Ir ao conteúdo
  • Cadastre-se
MatheusINF

Outro Esse algoritmo é assim?

Recommended Posts

Fala galera eu tenho uma dúvida e preciso que me ajudem, meu professor passou o seguinte algoritmo:  FAÇA UM ALGORITMO QUE LEIA 2 NOTAS  DE UM ALUNO FAÇA A MÉDIA E IMPRIMA O VALOR DA MÉDIA.

 

E resolveu do seguinte modo:

Algoritmo média
/* Este algoritmo lê as notas e calcula a média de um aluno
Autor: ...
Data: ...
Ra: ... */

Variaveis
Real n1,n2,med,soma

Inicio
Leia n1
Leia n2
Soma <- n1+n2
med <- soma/2

Escrevaln "A média final do aluno é: ",med
fimalgoritmo

O problema é o seguinte eu sei fazer os algoritmos e tal porém eu não entendo como ele pode mandar o algoritmo ler as notas 1 e 2 sem pedir pro usuario informar as notas, e gostaria de saber se quando é escrito em pseudocódigo não precisa mandar o úsuario escrever os dados.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MatheusINF Sim, o código está certo!

 

Mas quando ele pede para ler as notas, o usuário vai informar as notas! O leia é a entrada, ou seja, o usuário que informa...

no caso o que você ta confundindo é com o escreva ( " Digite a 1 nota !" ) que no caso é a Saída ( O que vai aparecer na tela )

 

E pra economizar linha voce poderia fazer assim tb :

 

med <- (n1+n2)/2

escreva("Media: ",med)

 

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Felipe Merklein Martins Mnw mas  o algoritmo assim não ficaria mais correto?

Algoritmo média
/* Este algoritmo lê as notas e calcula a média de um aluno
Autor: ...
Data: ...
Ra: ... */

Variaveis
Real n1,n2,med,soma

Inicio
Escreva "A primeira nota: "
Leia n1
Escreva "A segunda nota: "
Leia n2

med <- (n1+n2)/2

Escrevaln "A média final do aluno é: ",med
fimalgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@MatheusINF Não é questão de estar mais correto, o algoritmo estando assim ou daquele jeito, ele está correto!

 

Assim o algoritmo está mais " Viável" ou seja, quem pegar esse algoritmo vai entender melhor do que aquele primeiro!

 

Então isso é muito relativo, vai da pessoa se quer deixar o algoritmo " bunitinho " ou não kkk... Normalmente eu faria

 

 

programa {

funcao inicio(){

real n1,n2,med

leia (n1,n2)

med = (n1+n2)/2

escreva("Media é:",med)

       }

}

No caso aí eu usei o PortugolStudio que é mais simples e bem melhor que o VisualG

  • Curtir 1
  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×