Ir ao conteúdo
  • Cadastre-se
Wellington Neto

VisualG Algoritmo que imprima vogais e consoantes

Recommended Posts

Me ajuda ai galera pf


Preciso de um algoritmo que a partir de uma palavra digitada pelo usuario ele imprima a quantidade de vogais e a quantidade de letras consoantes, Utilizando as funções copia e compr

2- Um algoritmo que solicite uma mensagem ao usuario em seguida calcule e imprima a quantidade de letras a, e, i,o, e u da mensagem

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Caro usuário,

 

Seja bem-vindo ao Fórum do Clube do Hardware.

 

No intuito de servir como fonte de pesquisa no caso de instituições de ensino, informamos que incorrer no resolvimento por completo de questões relacionadas a disciplinas escolares de cursos técnicos e faculdades podem ser revistas e removidas pela Equipe de Moderação do Clube do Hardware.

 

Para sanar dúvidas sobre esse tipo de problema, por gentileza, publique o passo a passo do desenvolvimento da questão, projeto, monografia ou conteúdo em dúvida para que possamos analisar se a resposta está correta ou não, ou para que possa ser auxiliado com a dúvida no desenvolvimento do exercício.

 

Infelizmente, não há como resolver os trabalhos pelos usuários. O objetivo do Fórum do Clube do Hardware é auxiliar seus usuários a encontrar soluções para que possam sanar suas dúvidas, e não de trazer soluções prontas para seus usuários.. Além disso, copiar e colar respostas que não são de autoria própria do qualquer usuário é considerado plágio, o que é ilegal.

 

Esperamos que compreenda.

 

Atenciosamente,

Equipe Clube do Hardware

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Esse algoritmo não resolve toda sua questão, mas acredito que possa te ajudar a entender a lógica. ESTUDE o código, não copie e cole, já que esse script apenas imprime a quantidade de vogais! Se sobrar alguma dúvida eu fico feliz em te ajudar, pois também estou estudando a mesma matéria.

Algoritmo "Quantidade de vogais"
// Disciplina  :  Lógica de Programação e Algoritmos 
//  
// Descrição   : Imprime o número de letras vogais digitadas na frase do usuário
// Autor(a)    : GKuze
// Data atual  : 27/06/2018

Var

entrada, letra: caractere
compEntr: inteiro //tamanho da "string" que o usuário digitou
nA, nE, nI, nO, nU: inteiro //numero de vezes que cada vogal aparece
i: inteiro // variável de varredura do para-faca


Inicio
escreva("Digite uma frase, por obséquio: ")
leia(entrada)

compEntr <- compr(entrada) // pega o comprimento da entrada

para i de 1 ate compEntr faca //para cada uma das letras, faça
   letra <- copia(entrada, i, 1)
   escolha ( minusc(letra)) // minusc() transforma um caractere (ou mais) em minúsculo
   caso "a"
      nA <- nA + 1
   caso "e"
      nE <- nE + 1
   caso "i"
      nI <- nI + 1
   caso "o"
      nO <- nO + 1
   caso "u"
      nU <- nU + 1
   fimescolha
fimpara

limpatela

escreval("A: ", nA)
escreval("E: ", nE)
escreval("I: ", nI)
escreval("O: ", nO)
escreval("U: ", nU)


Fimalgoritmo
  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×