Ir ao conteúdo
  • Cadastre-se
Luiz_Sergio

VisualG Exercicio de Visualg sobre Vetor.

Recommended Posts

Galera, to precisando de uma ajuda em um exercício de Visualg. Seguem o anunciado e o código que eu fiz. Obrigado.

 

Crie um vetor de 4 posições e o "alimente" com dados numéricos. Depois utilize o comando "para" para verificar os dados do vetor e mostrar, no fim, o maior e o menor número armazenado nele.

var
i,maior,menor:inteiro
numero:vetor[1..5] de inteiro

inicio

para i de 1 ate 5 faca
   escreva("Digite o numero: ")
   leia(numero)
fimpara

se numero >= 1 então
   maior <- numero
   numero <= 1 então
   menor <- numero
fimse
se numero > maior então
   maior <- numero
fimse

se numero < menor então
   menor <- numero
fimse


escreval()

escreva("O maior numero é ",maior," e o menor é",menor)


fimalgoritmo 

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luiz_Sergio    no enunciado ele pede para criar um vetor com 4 posições , e não cinco , e para comparar você precisa colocar as comparações dentro de um laço de repetição , então use o para como pedido , então pegue o primeiro número do vetor que está na posição 1 e coloque na variável menor e em seguida faça as comparações do maior e do menor dentro do mesmo loop ,   então seu código pode ser assim  :

Algoritmo "vetor_4"
var
  j,maior,menor:inteiro
  numero : vetor[1..4] de inteiro
inicio
  para j de 1 ate 4 faca
    escreva("Digite o numero: ")
    leia(numero[j])
  fimpara
  menor := numero[1]
  para j de 2 ate 4 faca
    se numero[j] > maior ENTÃO
      maior <- numero[j]
    fimse
    se numero[j] < menor ENTÃO
      menor <- numero[j]
    fimse
  fimpara
  escreval
  escreva("O maior numero é ",maior," e o menor é",menor)
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Só uns adendos:

algoritmo "vetor_4"
var
   maior, menor :inteiro
   i            :inteiro
   numeros      :vetor[1..4] de inteiro
inicio
para i de 1 ate 4 faca //para as quatro posições
   escreva ("Digite o numero: ")
   leia(numeros[i])
fimPara
menor:=numeros[1]
maior:=numeros[1] //também é necessário inicializar o maior
para i de 2 ate 4 faca //da segunda pósição em diante
   se numeros[i] > maior ENTÃO
      maior <- numeros[i]
   senao //são consições mutuamente excludentes
      se numeros[i] < menor ENTÃO
         menor <- numeros[i]
      fimSe
   fimSe
fimPara
escreval()
escreva ("O maior numero é",maior," e o menor é",menor)
fimAlgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×