Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
Luiz_Sergio

VisualG Exercicio de Visualg sobre Vetor.

Recommended Posts

Postado (editado)

Galera, to precisando de uma ajuda em um exercício de Visualg. Seguem o anunciado e o código que eu fiz. Obrigado.

 

Crie um vetor de 4 posições e o "alimente" com dados numéricos. Depois utilize o comando "para" para verificar os dados do vetor e mostrar, no fim, o maior e o menor número armazenado nele.

var
i,maior,menor:inteiro
numero:vetor[1..5] de inteiro

inicio

para i de 1 ate 5 faca
   escreva("Digite o numero: ")
   leia(numero)
fimpara

se numero >= 1 então
   maior <- numero
   numero <= 1 então
   menor <- numero
fimse
se numero > maior então
   maior <- numero
fimse

se numero < menor então
   menor <- numero
fimse


escreval()

escreva("O maior numero é ",maior," e o menor é",menor)


fimalgoritmo 

 

Editado por Simon Viegas
Inserir tag CODE
  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@Luiz_Sergio    no enunciado ele pede para criar um vetor com 4 posições , e não cinco , e para comparar você precisa colocar as comparações dentro de um laço de repetição , então use o para como pedido , então pegue o primeiro número do vetor que está na posição 1 e coloque na variável menor e em seguida faça as comparações do maior e do menor dentro do mesmo loop ,   então seu código pode ser assim  :

Algoritmo "vetor_4"
var
  j,maior,menor:inteiro
  numero : vetor[1..4] de inteiro
inicio
  para j de 1 ate 4 faca
    escreva("Digite o numero: ")
    leia(numero[j])
  fimpara
  menor := numero[1]
  para j de 2 ate 4 faca
    se numero[j] > maior ENTÃO
      maior <- numero[j]
    fimse
    se numero[j] < menor ENTÃO
      menor <- numero[j]
    fimse
  fimpara
  escreval
  escreva("O maior numero é ",maior," e o menor é",menor)
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Olá.

 

Só uns adendos:

algoritmo "vetor_4"
var
   maior, menor :inteiro
   i            :inteiro
   numeros      :vetor[1..4] de inteiro
inicio
para i de 1 ate 4 faca //para as quatro posições
   escreva ("Digite o numero: ")
   leia(numeros[i])
fimPara
menor:=numeros[1]
maior:=numeros[1] //também é necessário inicializar o maior
para i de 2 ate 4 faca //da segunda pósição em diante
   se numeros[i] > maior ENTÃO
      maior <- numeros[i]
   senao //são consições mutuamente excludentes
      se numeros[i] < menor ENTÃO
         menor <- numeros[i]
      fimSe
   fimSe
fimPara
escreval()
escreva ("O maior numero é",maior," e o menor é",menor)
fimAlgoritmo

 

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário


Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×