Ir ao conteúdo
  • Comunicados

    • Gabriel Torres

      Seja um moderador do Clube do Hardware!   12-02-2016

      Prezados membros do Clube do Hardware, Está aberto o processo de seleção de novos moderadores para diversos setores ou áreas do Clube do Hardware. Os requisitos são:   Pelo menos 500 posts e um ano de cadastro; Boa frequência de participação; Ser respeitoso, cordial e educado com os demais membros; Ter bom nível de português; Ter razoável conhecimento da área em que pretende atuar; Saber trabalhar em equipe (com os moderadores, coordenadores e administradores).   Os interessados deverão enviar uma mensagem privada para o usuário @Equipe Clube do Hardware com o título "Candidato a moderador". A mensagem deverá conter respostas às perguntas abaixo:   Qual o seu nome completo? Qual sua data de nascimento? Qual sua formação/profissão? Já atuou como moderador em algo outro fórum, se sim, qual? De forma sucinta, explique o porquê de querer ser moderador do fórum e conte-nos um pouco sobre você.   OBS: Não se trata de função remunerada. Todos que fazem parte do staff são voluntários.
    • DiF

      Poste seus códigos corretamente!   21-05-2016

      Prezados membros do Fórum do Clube do Hardware, O Fórum oferece um recurso chamado CODE, onde o ícone no painel do editor é  <>     O uso deste recurso é  imprescindível para uma melhor leitura, manter a organização, diferenciar de texto comum e principalmente evitar que os compiladores e IDEs acusem erro ao colar um código copiado daqui. Portanto convido-lhes para ler as instruções de como usar este recurso CODE neste tópico:  
ALLAN26BR

Outro visualg matris oposta olha ai pf

Recommended Posts

n consigo fazer matriz oposta olha o que eu conseguir pf ajuda rápido 

var
matr : vetor[1..3,1..4] de inteiro
linha, coluna, soma, matrizoposta  : inteiro
inicio
para linha de 1 ate 3 faca
   para coluna de 1 ate 4 faca
      escreva("informe o valor para a posiçao[", linha,",",coluna,"]:" )
      leia(matr[linha, coluna])
   fimpara
fimpara

escreval("--------------------------------------------------")
escreval("valores cadastrados:")
para linha de 1 ate 3 faca
   para coluna de 1 ate 4 faca
      escreva (matr[linha,coluna])
   fimpara

   escreval (" ")

fimpara
escreval  ("----------------------------------------------")
//      (" superior esquerdo: ", mat(1,4] )
escreval ("valor canto superior direito: ", matr [1,4])
//       ("inferior direito : ", mat [3,2])
escreval (" valor cant0 inferior esquerdo :",matr[3,1])


soma <- matr[1,1]+matr[1,2]+matr[1,3]+matr[1,4]+matr[2,1]+matr[2,2]+matr[2,3]+matr[2,4]+matr[3,1]+matr[3,2]+matr[3,3]+matr[3,4]


escreval (" a soma de todos os números é:", soma)


escreva("----------------------------------------------")
//      ("matrizoposta ")


escreva("----------------------------------------------")
escreval ("matriz oposta: ")
para linha de 1 ate 3 faca
   para coluna de 1 ate 4 faca
      (matrizoposta[linha,coluna]) <- (matr[linha,coluna] * -1)
   fimpara
fimpara

fimalgoritmo

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@ALLAN26BR     para postar seu código é melhor  o botão   <>   que está lá na barra de ferramentas de postar , pois senão seu código fica faltando alguns caracteres ,   e seu código está bom , faltou apenas transformar a matriz em matriz oposta , então seu código pode ser assim  :

Algoritmo "matriz oposta"
var
  matriz        : vetor[1..3,1..4] de inteiro
  matriz_oposta : vetor[1..3,1..4] de inteiro
  linha,coluna, soma, matrizoposta  : inteiro
inicio
  para linha de 1 ate 3 faca
    para coluna de 1 ate 4 faca
      matriz[linha,coluna] := randi (100)+(-50)
    fimpara
  fimpara
  escreval("--------------------------------------------------")
  escreval("valores cadastrados:")
  para linha de 1 ate 3 faca
    para coluna de 1 ate 4 faca
      escreva(matriz[linha,coluna])
      soma := soma + matriz[linha,coluna]
    fimpara
    escreval(" ")
  fimpara
  escreval("----------------------------------------------")
  escreval("Valor Canto Superior Direito ----:",matriz[1,4])
  escreval("Valor Canto Inferior Esquerdo ---:",matriz[3,1])
  escreval("A Soma De Todos Os Números é ----:",soma       )
  escreval("----------------------------------------------")
  escreval("----------------------------------------------")
  escreval("matriz oposta:")
  para linha de 1 ate 3 faca
    para coluna de 1 ate 4 faca
      matriz_oposta[linha,coluna] := matriz[linha,coluna] * -1
      escreva(matriz_oposta[linha,coluna]," ")
    fimpara
    escreval
  fimpara
fimalgoritmo

 

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário






Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×