Ir ao conteúdo
  • Cadastre-se
Renato Aboim

Excel vba - funções se e agregar

Recommended Posts

Oi Pessoal!

 

Será que vocês podem me ajudar?

 

Existe como escrever a função SE no VBA? Tenho a seguinte situação:

Coluna B contém uma lista de dados;

Coluna C contém um verificador;

Coluna D contém uma descrição

 

Na coluna F preciso da fórmula =SE(E(B3="A";C3<>"");D3;""). Essa fórmula se repete na linha 4,5,6... e pode ir até o final da planilha.

Gostaria que essa fórmula fosse aplicada em todas as linhas não vazias da coluna B (a partir da linha 6). Ou seja, na 1ª linha vazia o VBA pára.

 

Outra dúvida: na coluna G eu tenho a função ÍNDICE + AGREGAR para ordenar os valores da coluna F. Ou seja, todos os espaços vazios ficaram no final da lista.

Tem como fazer essa função no VBA?

 

Obrigado e um abraço a todos!

Duvida Renato.xlsx

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×