Ir ao conteúdo
  • Cadastre-se
anderdl18

Visual Basic VisualG:Erro Esperava encontrar entao, fimse, sintaxe incorreta.

Posts recomendados

Bom pessoal, estou desenvolvendo um programa em VisualG para uma atividade da Faculdade, que apresente um menu de opções e que permita ao usuário escolher a opção desejada, receba os dados necessários para executar a operação e mostre o resultado. Verificar a possibilidade de opção inválida e não se preocupar com as restrições, como salário inválido. Porém ao executar o mesmo apresenta o erro de "Esperava encontrar entao" e "fimse".

algoritmo "semnome"

var
op: caracter
sal, nsal: real
meses: inteiro
inicio
// Seção de Comandos
escreva ("Informe o salário R$: ")
leia (sal)
limpatela
   	escreval("------------------- Menu ---------------------")
	escreval("1)                Novo Salário                ")
	escreval("2)                Férias                      ")
	escreval("3)                Décimo Terceiro             ")
	escreval("4)                Sair                        ")
	escreval("----------------------------------------------")
   escreva ("Informe a operação: ")
   leia (op)
   limpatela
   escolha op
   enquanto op = 4 faca
   caso "1"
   escreva ("O salário do funcionário é R$:", sal, "reais.")
   se sal <= 350  entao
   escreva ("O novo salário será R$: ", sal*0.15, "reais")
   fimse
   se sal = 350 e <= 600 entao
   escreva ("O novo salário será R$: ", sal*0.10, "reais")
   fimse
   se sal > 600 entao
   escreva ("O novo salário será R$: ", sal*0.05, "reais")
   fimse
   caso "2"
   escreva ("O salário acrescido de férias será R$ :" (sal+(sal*0.3)))
   caso "3"
   escreva ("Informe os meses trabalhados")
   leia (meses)
   escreva ("O seu décimo terceiro será RS: " (sal+(sal*meses)/12))
   caso "4"
   escreva ("Encerrar execução")
   outrocaso
   ("Opção inexistente")
   
	fimescolha
	
	fimenquanto

fimalgoritmo

 

  • Obrigado 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@anderdl18      o enquanto está fora do lugar , e seu código com algumas modificações poderia ser assim  :

algoritmo "menu"
var
  op        : caracter
  sal, nsal : real
  meses     : inteiro
inicio
  enquanto op <> "4" faca
    escreva ("Informe o salário R$: ")
    leia (sal)
    limpatela
    escreval("------------------- Menu ---------------------")
    escreval("1)                Novo Salário                ")
    escreval("2)                Férias                      ")
    escreval("3)                Décimo Terceiro             ")
    escreval("4)                Sair                        ")
    escreval("----------------------------------------------")
    escreva ("Informe a operação: ")
    leia (op)
    limpatela
    escolha op
    caso "1"
      escreval("O salário do funcionário é R$:", sal, "reais.")
      se sal <= 350  entao
        escreval("O novo salário será R$: ", sal*0.15, "reais")
      fimse
      se (sal > 350) e (sal <= 600) entao
        escreval("O novo salário será R$: ", sal*0.10, "reais")
      fimse
      se sal > 600 entao
        escreval("O novo salário será R$: ", sal*0.05, "reais")
      fimse
    caso "2"
      escreval("O salário acrescido de férias será R$ :", (sal+(sal*0.3)))
    caso "3"
      escreval("Informe os meses trabalhados")
      leia(meses)
      escreval("O seu décimo terceiro será RS: ", (sal+(sal*meses)/12))
    caso "4"
        escreval("Encerrar execução")
    outrocaso
      escreval("Opção inexistente .     Tecle enter !")
      leia(op)
    fimescolha
  fimenquanto
fimalgoritmo

 

  • Amei 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

@devair1010 Cara muito obrigado, eu acabei recebendo a ajuda de um amigo que faz o mesmo curso que eu na Faculdade, mas com a sua ajuda e modificações vai me ajudar bastante quando tiver outros parecidos com esse, muito obrigado.

  • Curtir 1

Compartilhar este post


Link para o post
Compartilhar em outros sites

Crie uma conta ou entre para comentar

Você precisar ser um membro para fazer um comentário

Criar uma conta

Crie uma nova conta em nossa comunidade. É fácil!

Crie uma nova conta

Entrar

Já tem uma conta? Faça o login.

Entrar agora





Sobre o Clube do Hardware

No ar desde 1996, o Clube do Hardware é uma das maiores, mais antigas e mais respeitadas publicações sobre tecnologia do Brasil. Leia mais

Direitos autorais

Não permitimos a cópia ou reprodução do conteúdo do nosso site, fórum, newsletters e redes sociais, mesmo citando-se a fonte. Leia mais

×
×
  • Criar novo...

GRÁTIS: minicurso “Como ganhar dinheiro montando computadores”

Gabriel TorresGabriel Torres, fundador e editor executivo do Clube do Hardware, acaba de lançar um minicurso totalmente gratuito: "Como ganhar dinheiro montando computadores".

Você aprenderá sobre o quanto pode ganhar, como cobrar, como lidar com a concorrência, como se tornar um profissional altamente qualificado e muito mais!

Inscreva-se agora!